Roborock S6 MAXV Device Token

Anyone found a working solution to get the Roborock S6 MAXV working in HA? What I saw is that there is no working solution yet to get the device token, or is there?

1 Like

I’ve use the old version of mi-home on bluestacks to extract device token without much of an issue.

Which version did you use? I tried with an old version of bluestacks, which I had used successfully in the past to get a air purifier token but I couldn’t get it to connect with the S6 MaxV (global version)

I used mihome 5.4.49 on unrooted bluestack version 4.150.11.1001
got my token using solid explorer(any explorer should do) in folder smarthome>logs>date.txt file and look for “token”
I did not connect my roborock S6 MaxV to roborock app, directly to latest version of mihome on my phone before looking for the token on bluestack.

I then trial and error on scripts for room clean and placed them in vacuum card by denysdovhan

command: app_segment_clean
params: (tested 16 - 20ish)

**after running the service exit mihome app on phone and return to see if map highlighted is correct

Other than no live map view it works so far for me for the past week or so without any issue, even able to call script on google assistant.

2 Likes

I purchased the S6 MAX a few hours ago and I’m already looking forward to receive it. A year ago i get An S5 running, but i can’t remember how i did it exactly. Is it possible to get a step by step explanation how to do it. I have absolutely no experience with bluestacks up to now.

What I get until now is:

  • Install bluestack version 4.150.11.1001 (Link)

  • Download mihome 5.4.49 (Link)

  • Install mihome 5.4.49 as APK in Bluestack (How to)

And now i’m not sure ho to proceed. What I would epect is:

  • Start “Mi home”
  • Choose “Europe”
  • Choose “add device”
  • Use your existing account or create a new account
  • Add device
  • I have no idea where and how i will find the token then
  • When you have the token, use it in your configuration something like that (only dummy names and numbers):
vacuum:
  - platform: xiaomi_miio
    name: Roborock
    host: 192.168.178.25
    token: 3374746d3f753f632836565243756e58
  • restart home assistant

  • After this you should be able to control the vacuum cleaner with home assistant

  • If you would like to control the cleaner also with the roborock app, you can now install the app and use it normaly

Can you tell me how i will find the token and if i get the other points right?

The token can be obtained exactly as described in the post above yours - install 5.4.49, use an Android file explorer to go to the folder smarthome>logs> date .txt (where the date is your installation date), search in the text file for the word “token” and you’ll find it there.

The rest of what you posted is fine except for the Roborock app, I haven’t been able to use it if I already paired the vacuum cleaner with the Mi Home app, so I just use the Mi Home app for the live map.

I received the S6 MAXV yesterday and did the ‘installation’ today. As expected it did not work as described without problems. I struggled a few times to get some problems solved. For this reason here are my complete steps with details (first three are the same as listed above)

  • Install bluestack version 4.150.11.1001 (Link )
  • Download mihome 5.4.49 (Link )
  • Install mihome 5.4.49 as APK in Bluestack (How to )
  • Open the App and register if you do not have an account (it seems to me, that country does not matter)
  • Add device and proceed with the next two steps as described in the app
  • As described in the app: Reset your wifi by pressing the ‘Spot Clean’ and ‘Dock’ button until the vacuum cleanert tells you the wifi connection was reseted
  • As described in the app: Connect your Wifi
  • The cleaner could now be used normaly as intended with the app. Besides this, it is also now possible to get the token by using solid explorer or any explorer (Link). You find the relevant file in folder smarthome/logs/date.txt file. If you don’t find the token directly in the file, search for ‘token’.
  • When you have the token, use it in your configuration. Here is an example(only dummy names and numbers):
vacuum:
  - platform: xiaomi_miio
    name: Roborock
    host: 192.168.178.25
    token: 3374746d3f753f632836565243756e58

Troubleshooting:

  • For some reason, I could not connect the Roborock to the mihome version I run within Bluestacks. For this reason I did also a mihome installation on my smart phone and connected the Roborock with mihome on my smart phone. Afterwards you can find the vacuum cleaner in the mihome app on the smart phone and in the mihome app in Bluestacks. The Bluestacks installation was nevertheless necesary because the folder on my smart phone where the log-file with the token should be located was empty. Within the folder in Blestacks I found the file and could extract the token.
  • And a second thing costs me some minutes to solve it. Deviating from my last token, the new token consists only of numbers. For this reason the token had to be placed with ’ in the beginning and in the end. Without them there was a dataype error.

I hope this helps someone who tries to connect the Roborock to HA

During my ‘installation’ I found some other things you probably are interested in - Notes regarding the two apps and firmware upgrade:

  • As johnflorin already said. It is not possible to use the Roborock-app and the mihome app in parallel. The reason fopr this is because you have to reset the wifi connection if you link the cleaner to the Roborock-app and with doing this, you loose the connection to home assistant.
  • Up to now there seems to be no possibility to get the token with using the Roborock app.
  • If you like to use a newer variant of the mihome app, that is possible. You just have to deinstall the mihome app (after you have connected the cleaner to the Version 5.4.49 app and received the token) and reinstall the newest version. The cleaner will also be visible there and for me the token did not change. The connection to Home Assistant seems to work completely fine.
  • With doing a firmware-upgrade the token does not change for me. It seems to me, that you can do the upgrade without loosing anything (but be carefull, I also read some experiences from persons where the token was changed with the firmware upgrade)
2 Likes

Hi everyone,

I’ve purchased my very first vacuum device on yesterday. It is a Roborock S6 MaxV and I hope I will love it and will enjoy the automatic cleaning of my house :slight_smile:

I’d like to be able to manage it through Home Assistant and it seems not so easy. Is there an simple way to obtain the token ID without an Android device ? I only have non-jailbroken iOS devices. Thanks for your help.

Adding it to your Mi Home app on iOS, then installing Bluestacks on a PC and running the old Android version of the app there should do the trick…

Hi, I followed this guide https://www.home-assistant.io/integrations/xiaomi_miio/ for IOS phone and I took the token very easy. There are many operations, but it works.

Ciao

Stefano

1 Like

I confirm, it works perfectly. Thanks @martellucci :slight_smile:

1 Like

Doing these steps deny you to use the roborock app, as I understand, right?
I’m choosing between ecovacs and roborock, don’t have yet, but integration availability is near to be mandatory.
I’ll try to write to roborock.

Yes, but you can use the Mi Home app that does everything the roborock app does

1 Like

Let us know if they respond! I’d like to integrate this while continuing to using the roborock app instead of the mi home app. Thanks!

for the S6 MaxV the mi app doesn’t have all the features that the roborock app has (camera, voice, etc) also my MaxV was having error 5 issues, Mi app showed no firmware update, but roborock app had one and that firmware fixed the error 5 issue.

2 Likes

Are you able to get the token from the Roborock app?

The method outlined here worked for me with the Roborock app:

1 Like

I just got it working, by using the latest version of the Mi Home (wich is now called Ximao Home) using my own region on my own phone.

Than logging in on the bluestack Mi Home app with the version noted above. The only difference was that the file with the token was in another map.

But my Qeustion now is Could i switch back to the Roborock App? Has anyone tried this and will this work? Or will the token change when i connect to this app?

Because the Ximao Home App does not have the new remote camera function that the roborock app does have.

That’s what we’re all trying to accomplish also. Check out the post right before yours, that’s the most progress I’ve seen thus far.

Hi Medelay, may I know where is the token located in the new Mi Home app? do you mind to share?