Roku Integration errors

Hi - I have used HA yellow for 5 months and initially had Roku as an integration installed on HA. My HA was and the roku were connected via ethernet on the main network created by the modem/router. I have now a UDM router and moved all HA devices into its own VLAN. I can ping the Roku from the HA terminal with a response and I get the homekit controller integration notification but not a direct Roku integration which fails every time. I have tried everything I could think of including hard reset of Roku, restart HA, look for configurations entries for Roku, tried using the wifi network (same vlan but new IP address that responded positively to pinging), etc but still no luck …

Has anyone seen this problem?


Well it looks like I figured it out! in case it helps someone, here is what I did. After reading a few posts and looking at known issue in the git hub page for Roku integration, I focused on the device itself. I went to settings/system/advanced settings/connect with mobile app and turn the option to permissive allowing access from private ip in the same subnet. and it found them in the integration.

Still does not explain why it still responded to the pings from HA using the terminal but I am a noob so if someone knows, please let em know.

Back to automating …

1 Like

Saved me the headache of troubleshooting. Thank you kind stranger