Rollease Acmeda Automate Pulse hub integration


#1

Hi team,

I have battery powered roller blinds made by Rollease Acmeda.
In addition to having wireless remotes they also have a hub that integrates with iPhone/Android apps as well as Alexa, Google Home, and IFTTT.

The hub has a serial interface and has a pretty detailed instruction manual here

I see that they recently integrated into Control4 home automation.

Im not smart enough to get this to work no matter how hard I try so I’m hoping someone in the community can help?


#2

Hi Will

Did you ever receive a response on this? Im interested in these blinds also and would like to look at integrating with HA. I have one unit setup already BUT do not have the Hub yet. I am going to try integrating with the BroadLink RM Pro first, before i spend money on the Automate Hub. Will let you know if i get this working.

Just a quick question, Does the hub connect into your home network (without the use of the RS485), ie through your wireless or something like that?

Michael


#3

Hi,

I couldn’t get my remote or my hub to integrate with my RM Pro, I think they use some weird sort of RF signals that the RM pro just couldn’t work out.

Also, I gave it a solid attempt to use the Hub over serial but just could not get my head around it.

Good news though, the other week I was searching around IFTTT and found the blinds now have a public channel!
Search for automate in Ifttt channels and you should be able to integrate into Home assistant pretty easily.

I have used Node red to close/open the blinds on sunrise/sunset and it’s working well. Obviously would love to see blind battery and actual open status but I think it requires someone with a wider knowledge of how serial comms work to work it out


#4

I have the Rollease blinds and would like to get the hub. Does anyone know if the hub is available in Canada?
Also, +1 for HASS integration.
thanks


#5

I tried pretty hard with the RM Pro too, and couldn’t get it to learn either.
Have you got the Automate Pulse bridge to use IFTTT?


#6

Hi yes the pulse bridge/hub is working with IFTTT.


#7

Hi Will. I set up the Automate Pulse hub with IFTTT a few weeks ago and it was working fine. I had it automatically closing my blinds at sunset and opening them at sunrise based on a relationship with the Weather Underground app. I just happened to be tinkering with the IFTTT app a few days ago for no reason other than just looking at my settings and now there’s no connection with the Automate Pulse app anymore. When I originally setup the IFTTT routine, it displayed my Automate Pulse scenes and it allowed me to choose the desired scene for sunrise and sunset.

Seperately, my Automate Pulse hub app works fine still manually. It also still works flawlessly with Alexa with just my voice. I just cannot get it to work in the IFTTT app anymore. I first spoiled myself on getting motorized blinds to begin with in April of last year. Then I spoiled myself further by starting to just tell Alexa to open and close the blinds daily not having to use the remote or the app. Then, after setting up the IFTTT app, I was ultimately pleased because my blinds totally handled themselves based on the ever changing sunset and sunrise daily.

Is yours still working or would you be able to go into your settings and see if it still interfaces with Automate Pulse?


#8

I’m also using IFTTT with the Automate Shades service and can confirm that my setup is still working.

As to what’s happened to yours, not sure… but as a troubleshooting step you could try setting IFTTT back up again with the Automate Pulse service and see if that resolves your issue.


#9

Thanks cryptelli. That is what I tried. I deleted my two setups (one for sunrise and one for sunset) and tried to redo everything but when it gets to the part of having to choose the particular scene that I want to activate upon sunsrise/sunset, it says “no options found.” I even went into the Rollease app itself, deleted my scenes, and recreated them. Everything still works fine with Alexa so that tells me that the Rollease system is still communicating with other systems.

.

So, for now I guess me and the wife will have to go back to telling Alexa to close and open the damn blinds. I am so ridiculously spoiled but once you achieve a certain convenience, its hard to go without it.:roll_eyes:


#10

As everything is working outside of IFTTT can you check that your Automate Shades service in IFTTT has a status of ‘active’ as per my screenshot above.

I must admit my use of IFTTT with the Automate Shades service is by utilising Webhooks, though even that relies on the service connection to the Automate Pulse Hub.


#11

I’m having the same issue. Really annoying as I have a Google home hub which relies on IFTTT.

Pretty unimpressive first experience to be honest.


#12

Also getting ‘Options Unavailable’. Brand new installation with new accounts. Using the iOS app for the hub works fine. Cannot get it to work on Google Home/IFTTT. Scenes are made in iOS app. Any ideas?

Status is active on IFTTT


#13

My BIL works with the developers and he was able to report the issue last week. I’ll follow up with him to see if they’ve responded, since I’m having the same issues.


#14

Thanks Michael! Let us know how you go.

In the mean time, I’m trying to reverse the protocol so it can talk to Google Assistant SDK directly. I’m able to login to the API and check my hub, but I can’t seem to fully decode any of the messages. Does anyone have any experience with decoding the raw messages from/to the server?

I know that ‘ValueOf’ parameters relate to the frame keys and data keys such as the requests and responses for scenes and devices, but they are all out of order… Any guidance would be great!


#15

UPDATE:
Hi all,

I just got back an email from Matt, a Technical Support Officer from Rollease Acmeda’s Australian division. He said the issue should be fixed, but you may have to remove and re add the Automate service.

Sure enough, after removing and adding the Automate service on IFTTT.com, it worked! Scenes are recognised and the blinds work as promised!

ORIGINAL:
Sent an email and one of their Technical Support Officer’s from their Australian division got back to me within 12 hours, stating that they have escalated the issue with their service provider to get the issue fixed. They confirmed that multiple users are having the same issue and that he would get back to me when they have a solution.


#16

Hi all -

I’ve just put an order in for some Rollease blinds too. My plan is to connect to the hub using the RS485 port – the protocol is well documented – and see if I can do an HA component that doesn’t depend on the cloud.

I’ll try to report back here if I have any success! Might be a few weeks before they’re here, though!

Quentin


#17

Mine just stopped working this morning. I hadn’t played with any settings prior. When looking at IFTTT it says it can no longer contact the Automate service. Anyone else seeing that today?


#18

I removed the service and now I cannot re-add. Says “Could not connect Service”. I’ll try again in a little bit.


#19

Mine has stopped working as well… I may start working on a custom solution again as the manufacturers IFTTT solution is unreliable.


#20

Looks like the problem has finally caught me out as-well. While I’ve never had much issue with the IFTTT integration a native HA component would be better, especially if it could also report the battery level too.