Rollease Acmeda Automate Pulse hub integration

I set mine up using the Automate Pulse app (not homekit) so it was connected to the network. I then used the HomeKit controller integration to connect it to HA.

1 Like

@dgaust Thanks for your reply. I tried reset everything and start again.

With the Automate Pulse 2 app, I connect mafter going My Home > ADD NEW HUB > CONNECT TO NEW HUB, it can detect the presence of the hub.

Right after selecting the hub and clicking NEXT however, it takes me straight to connection to Homekit. I am not able to proceed further unless I pair the hub to my phone’s Homekit.

Can you kindly tell me how you are able to do so without Homekit? Perhaps is the app an older version or used another OS?

I used an Android phone.

That makes sense! Will dig out one to try. Thanks again @dgaust!

It worked after getting the hub onto the wifi network using an Android tablet I had.

It is integrated successfully into HA minus the nice stats such as battery level / signal strength. But I am happy with that. Hopefully someone will be able to integrate it better than via HomeKit in the future!

Thanks again for your time, @dgaust! :slight_smile:

Hey @timolol and @dgaust ,

Im replying to you because you managed to set up your Pulse Hub 2 successfully, but i am having trouble with no entities showing up.

I outlined the errors in this post: Rollease Acmeda Automate Pulse 2 hub integration

Any help would be appreciated, im at my wits end :’(

Hi @Phillip, looks like you’ve done all the right steps. Once the hub has been integrated in HA, the blinds / accessories should automatically populate. From your error log, not sure if it is the hub communicated with your HA incorrectly. Perhaps try removing the integration, restart both systems and re-integrate again?

1 Like

Thank you for taking a look at that. I will try again

Just a bit of an update on the native integration, I’ve got a pull request that I’m hoping will get accepted shortly:

Once accepted, it’ll live in the home assistant dev branch until the next release. I still have no idea if it will work with Pulse v2 hubs, if anyone with a v2 hub is keen to do some troubleshooting for me I’d be happy to add v2 support to the API.


Thanks x1000 for this @atmurray

I have a hub v2 and would like to help. Let me know what i can do

I already added the hub as a homekit accessory and my blinds are working really well… would i have to remove this integration in order to test yours?

If I copy the acmeda folder into my custom_components folder can I start using this? Are there any risks to overall system stability or performance?
What would the HA configuration.yaml settings look like?

Not sure if you heard, but configuration of integrations through yaml is being deprecated eventually.

Yup, but I didn’t see it on the list of Integrations. I checked again and I now see it. I was looking for he name to start with Acmeda but it starts with Rollease. A search helped me find it.

I still dont see it… You found it listed under configurations>intergrations>(+)?

Yes, in the UI. Go to Configuration, then Integrations, click on the + icon, then scroll down to Rollease Acmeda Automate.

Problem for me is that it adds the Integration successfully and finds the hub but no cover devices are found.

I am getting the following the log file:

> Logger: aiopulse.hub
> Source:
> First occurred: 8:53:11 AM (1 occurrences)
> Last logged: 8:53:11 AM
> Received unknown message type: b'63000091' message: b'06536d6172745f4964315f793a51001600030000000000000053020800303030303030333954020800303430323030313355020800303048464c50423156020c0046304645364245333236333057020d003139322e3136382e312e313637ff5f'

I get the following error message: Received unknown message type: b’61000091’

It seems to be objecting to scenes defined in the hub. I have attached a screenshot of the error messages

Hi @fantangelo, The unknown message type should be able to be safely ignored, it will still try and parse the message. Could you re-download and try the demo application to see if it still works?

Hi @gregbm, it seems like your scene list is being provided in a structure that it isn’t expecting.
A few bits of information that would help:

  1. Are you using a v1 or v2 hub?
  2. Could you let me know what scenes you have configured? A screen shot from the app would be useful.
  3. Could you download and try the demo app fo the API?
  1. I have two hubs, both v1. My scenes include rollers from both hubs.
  2. I have eleven scenes. Two screen shots attached.
  3. I am using the demo app to get these results.

Thanks for your help