S6-overlay-suexec: fatal: can only run as pid 1

Just updated HA and i’m getting an error I haven’t seen before:

s6-overlay-suexec: fatal: can only run as pid 1

I searched the forum and googled it and found:

https://developers.home-assistant.io/…/s6-overlay-base…/

I’m running HA in docker. I’ve shut down all other add-on containers but still can’t get in. I can’t get into access other addons because HA won’t start.

I have access to the default config folder but can’t work out where my addon’s are installed there or even if they’re installed there. Any ideas what to do?

Anyone got an easy guide to follow to fix it?

1 Like

I just updated and i get the same error

–Edit i just rolled back to old image, from the 18th , and then yea, it works again. :slight_smile: But it doesn’t fix the new version

Got help in the discord.

My problem was added to the Breaking Changes under home assistant container.
It wasn’t there an hour ago.

I just needed to remove --init from my docker install script.

Worked straight away for me.

11 Likes

How did you roll back? Are you using docker?

Thanks. Just removed init from the other container, and it worked.

The way i rolled back , was i duplicated the container, and then changed the image from homeassistant/homeassistant:stable to id id sha from the image like sha256:22526c9da9deb1d3f0c054ba33d1d464039ca8302d92165920c8a98da8ac59f6

Then started the container. This way i both have the old and the new version that i can change back and forth easily. Just stop one, and start the other :slight_smile: This doesn’t work with major breaking things. Like when they upgrade databases and such

smart!. I thought it was possible but I couldn’t figure out how to do that. Thank you.

Sorry I am a noob and having the same error. Can anyone show me the commands for duplicating and changing the image?

whats the command for this?

I’m using Portainer, as a container, where I can just easily duplicate and change settings.

But you just need to remove the --init from your docker run/compose. Otherwise if using Portainer you can remove it under runtime settings :slight_smile:

3 Likes

While I try to understand how to make the removal of /init stick in Portainer, here’s how I managed to revert to the old version, hoping it helps other Portainer users:

  • stop the Home Assistant container

  • go to the Images tab and locate the latest image with tags homeassistant/home-assistant:none

  • open the image and copy the image ID (line starting with sha256: )

  • go back to containers tab, open your Home Assistant container and click Duplicate/Edit

  • under Image Configuration, select “Advanced mode” (the one that gives you one line instead of two) and paste the Image ID you copied

  • click “Deploy the container”

and you should be back to your previous version

3 Likes

Thanks, I was trying to remove the /init entrypoint and failing; what I needed to switch off was under “Runtime & Resources” but kept overlooking it…

2 Likes

Thank you @dvdavide. I had the same problem, couldn’t find that --init, but your Portainer rollback procedure worked for me. Good exercise. :slight_smile:

Take a look at your docker command for starting up a new instance of Home Assistant. Do you see an –init parameter? If so, remove it and save your changes and re-run.

How do I remove the /init in portainer? when ever I remove it, it gets added automatically again

Anyone know if this would also affect a supervised installation? In the end that also gives you a bunch of docker containers and I can see an /init here in Portainer. In case the upgrade breaks my installation would this be the setting to change to ‘default’?

dvdavide mentioned above… when you duplicate your container, the init switch is under “Runtime & Resources”.

I’ve only just started using Portainer pretty interesting.

1 Like

I’m always so nervous to Update HA, but I just redeployed my entire OS. Almost always something breaks :(. It takes long enough to get it setup the way I want, but I can’t help but loose the will to set it up repeatedly after breaking ‘updates’.

Anyone who can help with this topic?
It also mentions the S6-overlay … can only run as pid 1 Error.

Thanks!

Thanks all for this discussion. I just updated from something in April to 2022.11.2 and ran into this. I thought I’d share my findings so that anyone else who encounters this issue has a bit more information on how to identify and resolve it.

My setup consists of

  • Raspberry Pi 3B+
  • Boot and run from an SSD
  • WiFi networking
  • Fully up to date R-Pi OS, 64 bits
  • Docker CE (according to dpkg) 5:20.10.21~3-0~debian-bullseye

Update strategy is to

  1. pull the new container docker pull homeassistant/home-assistant:stable
  2. run HASS backup
  3. stop container
  4. run my custom backup (which now includes the HASS backup) and copy off to another host
  5. rename old container `docker rename homeassistant homeassistant.2022.04
  6. restart container with the command previously used.
docker run --init -d \
  --name homeassistant \
  --restart=unless-stopped \
  -v /etc/localtime:/etc/localtime:ro \
  -v /var/local/hass:/config \
  --network=host \
  homeassistant/home-assistant:stable

And … no joy. Can’t connect to the web server. Check the status of the container and got

c499a73bd6d9   homeassistant/home-assistant:stable   "/init"                  4 minutes ago   Restarting (100) 17 seconds ago                                               homeassistant

I had previously been able to view the logs but this time there was nothing.

hbarta@polana:~ $ sudo docker logs -f --tail 0 homeassistant
hbarta@polana:~ $

Next step was to run the container interactively to see if anything came up.

hbarta@polana:~ $ docker start -i homeassistant
hass s6-overlay-suexec: fatal: can only run as pid 1
hbarta@polana:~ $

( I clobbered the exact text in my notes but I do know it included the error message above.) Searching for that led me to this post and the solution. I restarted my container w/out the --init argument and all seems well.

docker stop homeassistant
docker rm homeassistant
docker run -d \
  --name homeassistant \
  --restart=unless-stopped \
  -v /etc/localtime:/etc/localtime:ro \
  -v /var/local/hass:/config \
  --network=host \
  homeassistant/home-assistant:stable

Now I suppose I should go to the installation instructions and check for any other changes to the docker run command.

Thanks!

Hi I have a HASSIO addon, could you help me in fixing this addon