SABNZBD Configurator Re-appears After Restart

Periodically, the SABNZBD Configurator re-appears after an HA restart and requires the api key to be reentered. Entering the key again always fixes the issue but it is annoying and I’m wondering if there is a way to make this more permanent.

This occasionally happens with the Alexa Media Player custom component too, but not nearly as often as SABNZBD. Is anyone else experiencing this? Is this behavior normal and by design or is it a bug perhaps?


1 Like

I have this happen as well. I have the api key saved in my secrets.yaml file. Sometimes it works, sometimes it doesn’t. I have no idea why it doesn’t sometimes.

I get the same, too

Same here… has anyone managed to find a fix… ?

Haven’t found a fix, but I haven’t had it happen in a while now. Finger crossed it keeps working properly…

I noticed yesterday that ignoring the configurator and doing a couple more restarts resulted in it going away too. This occurred while I was doing some theme edits which required several restarts.

The issue could be related to how it checks for the key during startup; possibly a race condition where it has not been able to fully initialize and home assistant starts up faster than SAB. I’m speculating, of course. For me, I’ve not seen it since but expect that it will re-occur again.

I get the same issue and have been for about 5 different version of HASS

I am experiencing this issue. SABNZBD is running on a different device, so I can’t imagine a race condition being the problem.

Every time I reboot HA the configurator is requesting the API key, even though it is specified in my secrets.yaml file. :frowning:

Still happening here sometimes. I add it, it disappears after restart, i add it … again and again.
Quite annoying after several month now.

Seems to be happening less and less for me latley. Not sure what has changes, but I haven’t done anything on my end.

I agree … sort of better. I’m now up to 0.100.3.
One thing I’ve noticed is that it usually loses the key after I’m troubleshooting a different component and need to do several restarts of hass.

Sometimes, I’ll get lazy and just leave it unconfigured and SAB magically fixes itself after a few hours. If anyone has the patience, try just doing nothing and see if it recovers on its own…

For me, SAB is not critical, so it’s more just annoying. What I do now is either fix it when I know that I’m finished working on a component, or I’ll just leave it and it (usually) catches up after a while.


Hi, did you manage to fix this? I am on latest version but still getting it after prob 10 versions…

Why do you think that this has been solved? It’s NOT solved :frowning:

I did not say it was, I asked if it was…:wink:

I haven’t had to re-enter in the API key in a while now. I can’t confirm if this is fixed or not, but I haven’t experienced this issue for a few months now.

Same here. It’s been months since I have been prompted to re-enter now.

For me, I even can’t enter it. Well, I CAN enter it. but the window doesn’t go away, and there is still the notification that sabnzbd needs to be configured.

There are 2 API keys for SABNZBD… try the other key… the full control one.

I’m using the “full” key, the first one “API Key”, and it’s not working that way.

having the same issue here. using the API key, stored in secrets. was working fine until one of the updates over the last 2-4 months. now every time i reboot i have to enter the API key in the cofigurator notification and now recently, i can’t even get the configurator to take it.

i paste in the key and hit confirm. the button greys out and it spins for 20 secs or so, then the confirm button turns active again, but it doesn’t seem to actually apply it. the notification remains and my sab sensors don’t work.