Sagemcom router support

Hi,

I’d really like to have support for Sagemcom routers to track mobile phones at home.

Cheers!

Hi @Zetor77.

I am currently working on adding a Sagemcom component to HomeAssistant, which will allow for device tracking and which will add some sensors. Could you provide me with some more information about the Sagemcom device you use?

Currently my package is focussed around the SagemCom [email protected] 3890V3, however it should be fairly easy to support other devices if they are using the same internal API’s. It would be great if you could provide me with some internal information.

  1. Login on the Sagemcom router webinterface
  2. Open your browsers Developer Tools -> Console
  3. Paste and run the following string $.xmo.getValuesTree("Device/DeviceInfo");
  4. Share the JSON reply with me in a DM, or post here your ModelName, ModelNumber, Manufacturer, ProductClass, SoftwareVersion.
1 Like

Hi
Great to see that you are developing this component for HA.

Here’s some details about my router
Model: FAST3686
Software version: DNA_3.443.0-T1-MAC14
Linux version: 2.6.30-1.7.1mp3-svn17369
Hardware version: V2.0

Hope that helps. I could not run that command to get all information. I got $.xmo undefined error.

Hi @imick

I would be also very interested in this :slight_smile:
Me neither $.xmo.getValuesTree("Device/DeviceInfo"); didn’t work but i got those information:

Model : EMTA62-2 / SAGEMCOM modec laboxv3b
Standard Specification Compliant : EuroDOCSIS 3.0
Hardware version : 1.0
Software version : NCC-PC20_3.445.0
Serial Number : EMTA1629024382

Have you planned to put your work online on github for instance to get some help or to show your progress ?

Thanks

I am currently working on cleaning up the initial version of my code. Afterwards I will publish it, however it looks like both of your models are using a totally different web interface and thus different API’s.

It looks like the package I am working on will support:

I did some more digging and it looks like my package will only support Sagemcom routers of the [email protected] (fast) series… Other models are using different API’s.

I have published an initial version here: https://github.com/iMicknl/python-sagemcom-api.

1 Like

Hey @imick. I’d like to try this out but am still quite new to Home Assistant so am not sure how to incorporate your repo. Do I need to add it as a source somewhere? I have HACS installed if that makes my life easier, or do I need to do the manual steps on the README.md file?

Hi @GarethOates, I will publish a HACS version asap! Which model do you have?

1 Like

Hi @imick. Awesome, thanks. I have the Sagemcom [email protected] 3890V3.

@GarethOates / @didi4yeah, I just published the first basic version of the component. It currently has a basic device tracker, which only supports ‘Home’. Could you give it a try to see if the integration flow works for your devices?

Custom Component: Sagemcom [email protected]

Installed it just now but can’t get the integration flow to work. Updated to the latest version released 1 day ago, then restarted home assistant. Went to integrations, selected sagecom [email protected] and tried to add it. It just span around for ages and then went back to the list again. Am I missing a step somewhere? In case it matters, I’m in iPad app, connected to WiFi and vpn.

Hello and thanks for that.
It happens exactly the same as described by @GarethOates

Thanks for your feedback. This means that something is not going well with the package installation. I will have a look tomorrow and make some changes, or publish the package to PyPi.

Is this still under development?
I tried HACS custom_component, it adds devices to track, however service to restart router is not available

@stskrp unfortunately, my focus shifted a bit to building the Tahoma component, however I could prioritise this again soon. :wink:

Which features are you missing at the moment? I am aware that device tracking is not working correctly yet, where it only takes device into account that are home, but it won’t change the status to not_home yet.

Contributions welcome!

Thank you for update! :slight_smile:
Basically I want to be able to restart Sagemcom gateway from HA, but service seems to be not available, can’t find it through Dev. tools in HA

Hi @imick,

I would love to use your Sagemcom component, but i can’t add the repository to HACS. I have then installed in manually under custom_components, but “Sagemcom [email protected]” doesn’t show up in the normal configuration flow.

Have restarted HA a bunch of times and checked the right installation path. Any ideas? :slight_smile:

Thanks

Came home after work and it appeared… :smiley:

Great to hear! Unfortunately the integration is super limited at the moment, since I spent a lot of time on building the Somfy TaHoma integration for now… However I am still planning on improving the Sagemcom router component.

If someone is open to help, would be great ;-).

1 Like

Hello,

I have the new BBox wifi 6 router Modèle [email protected] 5688b. Unfortunately, it’s not supported by the bBox integration and yours too.
Could you try to add this model to your integration ?

Thank You