Samba Backup cannot connect to share

So i installed and thought i configured samba backup correctly, but looking at the logs i see this error:

cont-init: info: /etc/cont-init.d/ exited 0
cont-init: info: running /etc/cont-init.d/
cont-init: info: /etc/cont-init.d/ exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
[23-01-24 22:36:20] INFO: ---------------------------------------------------
[23-01-24 22:36:20] INFO: Host/Share:
[23-01-24 22:36:20] INFO: Target directory: backup
[23-01-24 22:36:20] INFO: Keep local/remote: all/all
[23-01-24 22:36:20] INFO: Trigger time: 01:00
[23-01-24 22:36:20] INFO: Trigger days: Mon Tue Wed Thu Fri Sat Sun
[23-01-24 22:36:20] INFO: ---------------------------------------------------
[23-01-24 22:36:21] WARNING: protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE
[23-01-24 22:36:21] FATAL: Cannot access share. Unknown reason.
s6-rc: info: service legacy-services: stopping
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped

What am i doing wrong? Shouldnt the host be the IP for HA and im only assuming the default samba share is actually called “share” or is it the host ip again?

I removed the name from the share parameter and the network response is gone, so now just getting this error:

[23-01-24 22:41:56] FATAL: Cannot access share. Unknown reason.

What am i doing wrong? I tried watching some youtube videos and read a few posts, but they all seem to say the same thing, which is provide the share name, but where can i find that?


just tried and no luck… :sob: :cry:

same 2 errors if i try and provide the “share” parameter in the configuration.

OK then, is it mounted? If not then you’ll need to mount it.
DO this:

sudo mkdir /mnt
sudo mkdir /mnt/share

do this:

sudo apt install cifs-utils

For reference here is where I found the info: Installing cifs-utils

So even though i can access the different shares from my windows pc, doesnt really meany anything correct? I mean ill try whatever i can to get this working and tested so i can finally get started on setting things up.

Dont seem to have sudo

I get the same message even if i run the commands directly on the Odroid device… (tried both ways)

It depends on what and where and which really. You haven’t really described on what the HA is on and where you are trying to send via share

Right now im merely trying to get the Samba Backup configured

I tried without sudo and got this message:

The device im using is Odroid-XU4Q eMMC version device


With these parameter settings in the configuration:

I see this in the logs:

Can you set up the unit with the HA on, as a share to your PC? Then you can maneuver around and see the folder/file structure.

Just found this thread, is it a possible solution for you?

Not sure i understand what you mean by “setup unit with HA on” currently from my windows pc, i am able to see my HA device on my home network, i can access the shares it has

And even setup a folder within the backup

just dont understand why HA configuration doesnt recognize what is clearly accessible

OMG :triumph: :face_with_symbols_over_mouth:

So found the problem to be the “Allowed Hosts” for samba share

“” this host was missing and now when i restart the add on and look at the logs

i see successful message

Now wait until tomorrow to see if the scheduled back up runs and places the back up in the target folder and onto the next phase…

THANK YOU for the suggestions and suggestions, without that i wouldnt have bothered to keep looking at settings and values.

So what triggered the allowed host file look?

Yeah, I knew we would get there sooner or later. Just a lot of variations based on platform, OS, containers, dockers, appliance, extended items, etc

I need to start pulling backups of my HA-Yellow as I add more things to it and may be add external storage.

Along with your suggestions and ideas on things to do and try, i figured i would start looking at everything from the beginning and going back thru the setup of samba share, i noticed i only had 1 allowed host… but everything i saw online had like 4 or 5, so figured i would add back 1 host at a time and see, and adding that one host, i restarted back up and got the successful message in the log, so i let it run on its schedule and tonight when i get home, ill check if it ran and i have a legit back up. :crossed_fingers:

I have a successful backup in my folder. I wont have time to do a restore, but i am going to add a few things now so i can test out the restore process…