SAMBA Share (2.0) not working with HASSIO 0.49.1 NUC eth0

Hi, I am using intel NUC with wired connection. web interface and SSH working but I can’t make SAMBA work. It says that interface eth0 was not found. Below is the log

 nmbd version 4.6.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2017
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
interpret_interface: Can't find address for eth0
WARNING: no network interfaces found
STATUS=daemon 'nmbd' : No local IPv4 non-loopback interfaces available, waiting for interface ...NOTE: NetBIOS name resolution is not supported for Internet Protocol Version 6 (IPv6).
smbd version 4.6.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2017
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Processing section "[config]"
Processing section "[addons]"
Processing section "[share]"
Processing section "[backup]"
interpret_interface: Can't find address for eth0
WARNING: no network interfaces found
INFO: Profiling support unavailable in this build.
No builtin backend found, trying to load plugin
Module 'tdbsam' loaded
tdb(/var/lib/samba/registry.tdb): tdb_open_ex: could not open file /var/lib/samba/registry.tdb: No such file or directory
tdb(/var/lib/samba/account_policy.tdb): tdb_open_ex: could not open file /var/lib/samba/account_policy.tdb: No such file or directory
account_policy_get: tdb_fetch_uint32_t failed for type 1 (min password length), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 2 (password history), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 3 (user must logon to change password), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 4 (maximum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 5 (minimum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 6 (lockout duration), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 7 (reset count minutes), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 8 (bad lockout attempt), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 9 (disconnect time), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 10 (refuse machine password change), returning 0
tdbsam_open: Converting version 0.0 database to version 4.0.
tdbsam_convert_backup: updated /var/lib/samba/private/passdb.tdb file.
tdb(/var/lib/samba/winbindd_idmap.tdb): tdb_open_ex: could not open file /var/lib/samba/winbindd_idmap.tdb: No such file or directory
STATUS=daemon 'smbd' finished starting up and ready to serve connections
open_sockets_smbd: No sockets available to bind to.
Deleting serverid.tdb record failed: NT_STATUS_NOT_FOUND
PANIC (pid 31): open_sockets_smbd() failed
unable to produce a stack trace on this platform
/run.sh: line 88:    31 Aborted                 (core dumped) smbd -F -S -s /etc/smb.conf
coredump is handled by helper binary specified at /proc/sys/kernel/core_patterninterpret_interface: Can't find address for eth0
WARNING: no network interfaces found
interpret_interface: Can't find address for eth0
WARNING: no network interfaces found

I also typed ‘ip link show’ in SSH and below is the result:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: [email protected]: <NOARP> mtu 1480 qdisc noop state DOWN qlen 1
    link/sit 0.0.0.0 brd 0.0.0.0
16: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue s tate UP
    link/ether 02:42:ac:11:00:03 brd ff:ff:ff:ff:ff:ff
addon_core_ssh:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 02:42:AC:11:00:03
          inet addr:172.17.0.3  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::42:acff:fe11:3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:646 errors:0 dropped:0 overruns:0 frame:0
          TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:59214 (57.8 KiB)  TX bytes:32275 (31.5 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Ok I solved the problem. Firstly I left the interface blank by setting interface="" and refresh the LOG. I then found out that the interface name for my ethernet in NUC is: “enp3s0”. So I set interface=“enp3s0”, filled username and password and SAMBA is working fine now. I can browse it from my PC. I hope this help those who have similar issue.

4 Likes

Thank you for your troubles as it lead to a solution that I was seeking for hours. Namely the nuc nic’s name.

Samba is now working, so much easier than using Winscp!

2 Likes

Hi, wanted to make a similar setup. How did you do your installation (newb here), downloading the HASSIo NUC image … and then?

Thanks, just what I needed!

Thank you! Just installed my Hass.io instance on virtual box and this has been driving me crazy for hours.

More people may be looking for this since Dr. Zzzz just did a video on it.

1 Like

So, how did you find the ethernet interface name on your NUC? I’m also having a NUC and I encounter the same problem. My interface name is different from “enp3s0” it seems.

Cheers! Saved me a lot of troubles :wink:
Samba is working now!

1 Like

I just wasted an hour and half on this one two :exploding_head:

The answer is to simply delete eth0 and just leave the “” then restart samba.

Here is where I found the answer https://community.home-assistant.io/t/hassio-virtualbox-samba-interface-name/107735/2?u=three

For any windows users.
eth0 is a linux term for the first physical ethernet port coding wise it makes sense. Windows uses Ethernet, Ethernet 1, Ethernet 2 not sure why the put a space in the name, then again microsoft is driven by corporate thinking not logic so why would it follow logically convention like linux.

Virtual cards don’t follow eth0 or Ethernet 1 etc protocol and generate their own name. I am using Virtualbox as VM.

I am guessing the NUC users above their NUC created an adapter the in the list in the pic which simply had the title “enp3s0” whereas virtual box created “VirtualBox Host-Only Network” and I would imagine as you add more virtual LAN ports in VB it just adds a number to the end like VMware did (also as seen in pic below).

1 Like