Schlage Zwave Lock Stopped Working - 0.51.2 - SOLVED

As the title states, I’m at 0.51.2. I have a couple of scripts/automations that lock/unlock my Schlage zwave lock on my front door. It has stopped working. I finally got to sit down today and look into it and started up ozwcp and can lock and unlock it fine from there. But under HASS - it doesn’t do a thing, even noting if locked or unlocked and calling the lock/unlock service does nothing. In fact, it just shows locked all the time. It shows up on the gui interface, but it acts dead even though in the Zwave panel I can see it being discovered, ready etc when I restart HASS. I’ve not made any changes other than updating to the latest HASS, no code or Zwave changes recently.

Anyone else seeing this? Ideas/thoughts?

I’ve got a couple Schlage BE469 locks and they are working fine under 51.2 – did you change something else as well? What were you before 51.2 as it could be another change as quite some ZWave stuff between 48 and now.

1 Like

@jwelter - thanks for responding, much appreciated!

I’ve not changed anything else and I generally upgrade about 1 week after each release to let the ‘kinks’ get worked out on the average. Now in all truthfulness, I may have skipped .49 or .50 (I’m not sure) and moved up to 51 because I was very busy. The only thing I changed which shouldn’t be a big difference was switching from the old zwave entities to the new ones.

I have the entity right on the automation and scripts - but the thing that’s got me is that it works with ozwcp but not HASS - and the piece in HASS that’s not working is the panel for the lock itself - which I don’t program at all.

I don’t see anything in the HASS logs at all. Anywhere else to look, any other ideas?

Thanks for the help!

The other issue is around 49 they started to self-install openzwave and with that came some config path changes.

You might have lost your options.xml file and more specifically the security key!

But you can now put that in the zwave section on configuration.yaml so check that out. It could explain it as the locks are typically the only secure devices most people have.

1 Like

@jwelter - that’s a good point - I’ll try to dig into that - I’m attaching a screenshot of my lock - it’s just strange - you can see in the log (the colored line) that’s obviously done stuff over the past hours…but it certaibn;y doesn’t react when you clock the lock.unlock on the panel…

The secure part might just be the trick - let me see if I get some more time I’ll peek into that.

Thanks for the quick response!

@jwelter - I think you might have hit it on the head - looked at the ozw_log.txt file - saw this -
2017-08-16 20:02:21.467 Detail, Node010, Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2017-08-16 20:02:21.467 Detail, Node010, ZW_SEND_DATA delivered to Z-Wave stack
2017-08-16 20:02:22.715 Detail, Node010, Received: 0x01, 0x07, 0x00, 0x13, 0x70, 0x00, 0x00, 0x7d, 0xe6
2017-08-16 20:02:22.716 Detail, Node010, ZW_SEND_DATA Request with callback ID 0x70 received (expected 0x70)
2017-08-16 20:02:22.716 Info, Node010, Request RTT 1256 Average Request RTT 1273
2017-08-16 20:02:22.716 Detail, Expected callbackId was received
2017-08-16 20:02:31.460 Error, Node010, ERROR: Dropping command, expected response not received after 1 attempt(s)
2017-08-16 20:02:31.461 Detail, Node010, Removing current message
2017-08-16 20:02:31.461 Detail, Node010, Notification: Notification - TimeOut

Looks like when you don’t have a security key - I’ll work on that angle and see where it goes.


This is my config snippet:

  usb_path: /dev/ttyACM0
  polling_interval: 60000
  network_key: "0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x07, 0x07, 0x09, 0x09, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01"

Make sure you use the same network key…

Also look at the first couple lines of the OZW log file - does it tell you the network key is missing?

Locks are funny as without the key certain things work; such as some status reporting; but they can’t be commanded… sounds like your issue.

1 Like

@jwelter - ok - that was definitely an issue, but apparently not the only one - now it gets the right response back in the ozw_log -

beginning of log:
2017-08-16 20:26:37.268 Always, OpenZwave Version 1.4.2508 Starting Up
2017-08-16 20:26:43.189 Info, Setting Up Provided Network Key for Secure Communications

Asked for lock/unlock - logs shows this:
2017-08-16 20:33:56.249 Detail,
2017-08-16 20:33:56.250 Info, Node010, Sending (Send) message (Callback ID=0x5b, Expected Reply=0x04) - DoorLockCmd_Set (Node=10): 0x01, 0x0a, 0x00, 0x13, 0x0a, 0x03, 0x62, 0x01, 0x00, 0x25, 0x5b, 0xf2
2017-08-16 20:33:56.259 Detail, Node010, Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2017-08-16 20:33:56.259 Detail, Node010, ZW_SEND_DATA delivered to Z-Wave stack
2017-08-16 20:33:57.507 Detail, Node010, Received: 0x01, 0x07, 0x00, 0x13, 0x5b, 0x00, 0x00, 0x7e, 0xce
2017-08-16 20:33:57.507 Detail, Node010, ZW_SEND_DATA Request with callback ID 0x5b received (expected 0x5b)
2017-08-16 20:33:57.507 Info, Node010, Request RTT 1256 Average Request RTT 1315
2017-08-16 20:33:57.507 Detail, Expected callbackId was received

Nothing happens…maybe some other zwave config issue? all other zwave devices are perfectly fine - so it has to center around this network key issue.

@jwelter - it acts as if the network_key is not read from the configuration.yaml file - I have it pasted in with quotes from the options.xml file and I’m still getting this during zwave initialization -

2017-08-16 20:47:55.135 Error, Node010, ERROR: Dropping command, expected response not received after 1 attempt(s)

which is usually the security key from what I can see with some quick searching…

Can you do a find on options.xml and see what they contain?

You should only have one of them in the HA folder.

1 Like

the one under here - /srv/hass/hass_venv/lib/python3.4/site-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config - is where I got the network key from in options.xml - it was not remarked out

the on under here - /srv/hass/src/python-openzwave/openzwave/config - has it remarked out in the xml file and does not contain my key - just the example key

I had this same issue and it was driving me crazy. After trying many things the only thing that worked for me was to delete the zwcfg_0xfa9a7ee7.xml from my homeassistant configuration folder and copy over the new file from the ozwcp directory.

1 Like

@jbolo - with the aio installer - where would I find the new xml to copy over - any ideas?

Thanks for the reply!

NM - found it - will try

I copied the file from the directory I was running launching owzcp from since owzcp was activating the lock without any issues.

I just had owzcp installed in the home directory of my “pi” account. So it was “/home/pi/open-zwave-control-panel/”

1 Like

careful - you loose custom naming!

1 Like

@jbolo and @jwelter - you guys got me going - the copy of the zw**,xml from the ozwcp dir to the .home assistant dir got it - I was able to lock/unlock from the HASS panel - thanks for putting me on a path!!

@jwelter - thanks for the warning - I’ll go over with a fine tooth comb - appreciate everyone’s help!!

Copy the correct one into the home assistant config directory.

Then symlink it to the site-packages folder you listed.

You can delete the one in /srv/hass/src - it is no longer used.

1 Like

Will do! Thanks again for the help and info!!