Scripts not showing up in Google Home app

Tags: #<Tag:0x00007f739674a458>

Hi,

I have setup Home Assistant on my local server and it’s working very well. After that I connected HA with Google Assistant via the HA Cloud (for security reasons). My media players and lights are showing up in the google Home app, but my scripts don’t.

Could someone take a look at my configuration en tell me what to change?

# Cloud
cloud:
  google_actions:
    filter:
      include_entities:
        - script.watch_a_movie
      include_domains:
        - light
        - media_player
        - script
        - switch
    entity_config:
      script.watch_a_movie:
        name: Watch a movie

I was having the same issue and discovered that the scripts simply don’t appear in the “Home” page with all of the lights, switches, and media players. Try the following and see if your scripts are there:

  • Navigate to your account page (person icon at bottom right)
  • Tap Settings
  • Open the Assistant tab
  • Tap Home Control

When going here I am able to see that my scripts are present and can be called by routines, etc.

Hope this helps!

4 Likes

Tnx!!! The scripts are listed in the home control tab. I’ll take a look at in a will try to call them with a voice command. That should not be a problem :slight_smile:

I have spend hours on this issue while staring at my config file…

It would be just peachy if this “feature” was documented somewhere. I wasted quite a bit of time on this one myself. I also haven’t been able to get my scripts to fire without using the “Start” key word first.

I really hope they’re going to use some of those monthly nabucasa fees to improve the documentation a bit.

Anyone knows how the scripts can be triggered from Google Home when they don’t show on the “Home” page? I had the exact same problem. My scripts are listed in the “Home Control” tab, but I can’t trigger them from there.

routines --> manage routines --> open an existing routine or create a new routine --> under ’ My assistant should… choose ‘Adjust scenes’ --> choose your script

2 Likes

Thanks. It works! Just one problem… I don’t have an option to create new routines in my Google Home. I just have the built-in ones: Good Morning, Bedtime, etc. Guess I’ll have to ask Google people about that one! :slight_smile:

in my app I have a little blue circle/dot in the bottom right corner with a white plus sign (in the manage routine screen)

Yes, I have it too now! I now also have “Routines” as an option under Account->Settings->Assistant. I know I sound like a moron, but I swear those options were not available just an hour ago! I switched my phone from Swedish to en-us to enable routines, but I guess you also have to wait for some kind of sync before all options turn up.

haha, I believe you.
After I have synced my devices I have to close the app and reopen it again to see my new devices/scripts

You can run a script with the word : activate…
Or indeed, use routines…
Or make a switch that runs a script if you want it visible

1 Like

After some frustration I just found out that our Dutch Google Home app doesn’t support routines yet… I’ve been turning the app inside out for hours looking for ways to add routines only to find out they’re not there.

So I guess I’ll have to build a switch for now

indeed, we dutch users need to wait for the routines
but you can create a script, it acts the same as a routine :slight_smile:

There is support now :wink: Not for belgium atm… Ill just fake being from holland for now :stuck_out_tongue:

1 Like

Thank you.