Sector Alarm


#41

You are right it start with a zero, will try as soon as I come home. Keep you posted.
Thanks!


#42

@donjohann

Yes so I actually resolved this problem past weekend. The problem was just what you wrote @mgejke. When using ‘’ around the alarm_id, code, email and password the problem was resolved.

sector_alarm:
  email: '[email protected]'
  password: '12345678'
  alarm_id: '12345678'
  code: '00000'

Something else that is weird is when using thermometers: or thermometers: true. The thermometers don’t show up. When removing this line all together they show up…
What is the alarm_panel-line supposed to do?


#43

When I turned on the logging in HASS.io I got the same error you did about the temperatures. Use ‘’ around your alarm_id and code. Check my previous post from today.

I am no python coder but it seems to fail when it thinks the value is an integer and not a string.
It fails to connect to Sector Alarm but still tries to get the thermometers.


#44

@Jesperj
That’s correct, it will log in succesfully, but fail when trying to request anything using the alarm_id since it’s incorrect.
I’ll check what it says when you do that and try to give a better error…

the alarm_panel-line is just if you for some reason only want the temperatures… :slight_smile:


#45

It works @mgejke @Jesperj !
Added “” for email, password, alarm_id and code and I got the thermometers to work. Nice.

Next action, make logic on the alarm entities :smile:

Thanks for the support!


#46

Hi, I just got a call from Sector Alarm, they say my central is contacting their central way more often that it should. Is there a polling thing in the code somewhere that can be extended?
Or any other tips.

Thanks


#47

@Bjorn_Hegle
Interesting! What did you say to them? How’s your central connected?
There’s a flag called scan_interval for polling components i HA, try setting it to something bigger. I’m not sure if it works out of the box or if I have to do something in the components as well.

scan_interval: <seconds>

Try that, if it doesn’t work I’ll add a setting for it…


#48

Finally fixed it. Had some problems with dependencies, but after an reinstallation of home-assistant and using ’ I got it working.
Thanks for all the help.


#49

Was that a problem for them? And what did they say about it?
Did you mention your setup?


#50

They asked me if I used the app in a special way or something. I didn’t tell them about the hassio setup :stuck_out_tongue:
My central is connected directly to my router.
They are coming on Tuesday to swap out my central, so I’ll see after that if it was the central or this component.


#51

Hi
I have updated my Home Assistant (Home Assistant
0.65.4) and now I got this error:

- Invalid config for [sector_alarm]: required key not provided @ data['platform']. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sector_alarm/

Still working though, but quite annoying with the error showing up.

Config is like this:

sector_alarm:
email: '[email protected]
password: 'XXX’
alarm_id: '01234567’
code: '0000’
thermometers: true
alarm_panel: true


#52

Has this been integrated into HA? I found this on Github:


#53

Hi

I have exactly the same error on version 0.65.5 and same config as “donjohann” except for the last two parameters, they have # before the parameter.
The component have stopped working!
Anyone found a solution?


#54

@patrikfrisk, @donjohann

Ah, I haven’t upgraded HA in quite a while. I’ll try to do that and see if I can fix the problem(hopefully this week)…


#55

Hi

I just want to confirm that I have the same problem that the component have stopped working. I also have 65.5 installed.

@patrikfrisk, @donjohann


#56

@Jesperj, @patrikfrisk, @donjohann

Running 0.65.5 on a raspberry pi with the latest code from https://github.com/mgejke/hass-sectoralarm I don’t get any errors at all.

Could you give me some more info?


#57

I’m also running on a raspberry pi and I have tried to replace the sector-alarm code again from

This is my config in configuration.yaml

sector_alarm:
  email: "[email protected]"
  password: "my secret password"
  alarm_id: "my alarmid"
  code: "0000"
  #thermometers: false
  #alarm_panel: true

But I still recive the following error:

Failed config
sector_alarm:
- Invalid config for [sector_alarm]: required key not provided @ data[‘platform’]. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sector_alarm/


#58

I can’t reproduce the issue…
From googling the error message it seems that it might be related to formatting, tabs/spaces etc.

Is your config split in different files? Could anyone post more or the entire config(as a code snippet so the formatting is correct)?


#59

This i my Configuration.yaml with the formatting included.
The Sector_alarm component is found in the bottom of the configuration.yaml

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: xx.xxxxxxxx
  longitude: yy.yyyyyy
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 39
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Stockholm
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
# introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

http:
  # Secrets are defined in the file secrets.yaml
  # api_password: Welcome
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
  - platform: yr  

# Text to speech
tts:
  - platform: google

# Cloud
# cloud:

# Pushbullet
notify:
  - name: Pushbullet
    platform: pushbullet
    api_key: My APIkey

# Devices
device_tracker:
  - platform: ping
    interval_seconds: 30
    consider_home: 1200
    hosts:
      Patrik_iphone: MyIPAddress
      Hugo_samsung: MyIPAddress
      Malin_iphone: MyIPAddress

# Sector Alarm
sector_alarm:
  email: "[email protected]"
  password: "My Password"
  alarm_id: "My AlarmID"
  code: "0000"
  #thermometers: false
  #alarm_panel: true

# Includes  
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

#60

I receive the same error message if i restart homeassistant.
If i do a full host reboot of hassio it works without the error…