Sector Alarm


#61

I tried “full host reboot” and it worked, thanks :slight_smile:


#62

I ran into a problem… upgraded to HA 0.66.1
Any tips on were to begin?

Traceback (most recent call last):
File “/usr/local/lib/python3.5/dist-packages/homeassistant/core.py”, line 1006, in _event_to_service_call
await service_handler.func(service_call)
File “/usr/local/lib/python3.5/dist-packages/homeassistant/components/alarm_control_panel/init.py”, line 140, in async_alarm_service_handler
yield from getattr(alarm, method)(code)
File “/root/.homeassistant/custom_components/alarm_control_panel/sector_alarm.py”, line 87, in async_alarm_arm_home
result = await self._hub.arm_home(code=code)
File “/root/.homeassistant/custom_components/sector_alarm.py”, line 165, in arm_home
result = await self._async_sector.arm_home(code=code)
File “/root/.homeassistant/deps/lib/python3.5/site-packages/asyncsector/asyncsector.py”, line 100, in arm_home
return await self.alarm_toggle(‘Partial’, code=code)
File “/root/.homeassistant/deps/lib/python3.5/site-packages/asyncsector/asyncsector.py”, line 89, in alarm_toggle
if ‘status’ in result and result[‘status’] == ‘success’:
TypeError: argument of type ‘NoneType’ is not iterable


#63

Iam getting same error as you… did ssh to hassio container and run “hassio host reboot” but still getting same error…

but the arm/disarm is working, and its also showing the temperature correctly … It just that iam getting the error when i do “Configuration validation”

Invalid config for [sector_alarm]: required key not provided @ data[‘platform’]. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sector_alarm/

iam running hassio 0.71.0


#64

I got a call from Sector today about my system querying the API for temperatures and generating a lot of traffic. They asked me to shut it off since the alarm system won’t return temperatures when only on 3G connection.

My question: is setting thermometers: false enough to make HA not query for temperatures?


#65

Arm/Disarm Alarm Automation

how can i do something like this with sector alarm ?

automation:

  • alias: Disable Alarm
    trigger:
    platform: sun
    event: sunrise
    condition:
    condition: state
    entity_id: alarm_control_panel.sector_alarm_011111111
    state: ‘armed_away’
    action:
    service: alarm_control_panel.alarm_disarm
    entity_id: alarm_control_panel.sector_alarm_011111111

#66

I’m trying to get this to work using https://github.com/mgejke/hass-sectoralarm

But when i try to validate my config from the web I’m getting the following error…

Configuration invalid
Component not found: sector_alarm


#67

I have made a patch for hass-sectoralarm and intialised a PR with mgejke to update the component on github, which is now updated:
Easiest instruction is to download the latest sector_alarm.py from https://github.com/mgejke/hass-sectoralarm and overwrite the sector_alarm.py in custom_components

Now your configuration checker works and it also works to do restarts of home assistant without having to do full host reboot - so i really recommend you to do this. @tali @Oscar_Sandstedt @patrikfrisk @donjohann

:man_dancing:


#68

Nice work! Thank you! :smile:


#69

Hi! Im using Hassio and the SectorAlarm is not working as it should. Im using release 0.77.3
Before i was running Homeassistant as a docker container in my Synology NAS, then SectorAlarm was working nice. I recive this message when i check my config.

“”
nvalid config for [sector_alarm]: required key not provided @ data[‘platform’]. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sector_alarm/
“”
Can some one help me whats wrong here?


#70

Try to download the latest code from the GitHub archive, it should solve your problem…


#71

Hi, i downloaded the latest code, now the Sector shows up with no errors, but the temp is not updating as it should. It updates if i restart Hassio, otherwise not. Any suggestions what i should do?


#72

Weird… Do you see the temp sensors values in your app or on the sector alarm webpage?


#73

Yes i see them in both app and on the web, and i see them in hassio allso but they are not updating unless i restart hassio, then the deliver a new temp only ones. Yes this is very strange…


#74

Ok, what version of hass are you running?

I am having big problems with sector alarm in the latest 0.78.0.
The component crashes on hass startup and once I patched the code for that, it now crashes when running temperature sensor code (alarm panel and status is ok) so I have to figure out why as the next step.

However it also lags a lot when retrieving the alarm status from sector alarm page - and the log is full of timeouts and warnings of the sensor taking to long to update.
Something must have changed in the last 1-2 major releases that cause this to break or behave differently I guess…
Running the asyncsector code standalone is no problem and it seems fairly responsive.


#75

Btw, when you update with the new code, make sure you also download and update the individual py files in the sensor and alarm panel folders as well…


#76

Feature request:
Is it possible to get the door lock included in this?
For examples, see: https://github.com/petterl/python-sectoralarm


#77

The addon does not work in 0.81.2:

Error during setup of component sector_alarm
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/setup.py", line 145, in _async_setup_component
    hass, processed_config)
  File "/config/custom_components/sector_alarm.py", line 77, in async_setup
    load_platform(hass, 'sensor', DOMAIN)
TypeError: load_platform() missing 2 required positional arguments: 'discovered' and 'hass_config'

#79

Hey

I get the exact same error


#80

I downgraded to 0.81.0 to get it to work.
The change that I believe broke it: https://github.com/home-assistant/home-assistant/pull/17952


#81

Someone found any solution to this except keeping to version 0.81?