Security Alert - HA Supervisord Won't Update


I have a Docker Supervisord installation from the official Github Repo (

Following the Security Alert posted Jan 14 2021 I attempted to update my instance. My issue is that it won’t update. I’ve reloaded Supervisor from the Supervisor -> System tab. I’ve tried selecting update from that same tab. I’ve also tried updating by clicking the UPDATE from the Supervisor -> Dashboard Tab. Nothing happens. And there’s nothing in the Configuration -> Logs. I dismissed the notification and since it’s not updated, the notification reappears. I have searched over the HA Community Forum as well as Googled and Youtube’d how to upgrade the Supervisord. Most of what I’ve encountered is “don’t run supervisord”, just run plain docker and the individual docker containers for the add-ons you want. But I think I’ve also learned that many of the add-ons aren’t as simple as running a separate docker container. So a bit perplexed on 1) what am I missing in upgrading my Supervisord install? 2) did I make a mistake choosing to run Supervisord?

Thanks all

Bump… I’d really like to update my instance but have not been able to find a way to update the supervisord docker installation as referenced in my earlier post. Given that it is an installation method from the official Github Repo I would think it was supported, in some fashion. I had been encouraged to not be concerned about a “unsupported” installation (Installation Method Recommendations), but not being able to update when it’s strongly recommended is an issue. Any suggestions as to what I am missing would be welcome.

Thank you

The recommendation to update is regarding the Core version, wanting to be at least 2021.01.3

What versions are you running?

…and for the record I think a Supervised install is the way to go. Best of everything.


I’m at 0.114.4.

To your point regarding a supervisord install:

That’s what I thought I had concluded after some research and some forum feedback. Also it best fit my use case based a number of factors and the available install options.

  1. my desire and preference to run a containerized implementation
  2. not commit an entire server/device to the install. I tried the Pi 4 8GB. I personally had nothing but issues with USB devices
  3. based on @finity’s comments to some installation questions I had asked on the forum

I’m still not a fan of the supervisord install’s direct control of the server/device, however. While I appreciate the need for encompassing management of the HA services/add-ons, I don’t love that it can/does reboot the entire server. I’m not sure to that degree of control is necessary to ensure the HA services are up. I only see the need, in general, it a new physical devices is connected to the server, i.e. USB device, storage, etc. I, as I’m sure many others, multipurpose my server to run other services/utilities.

In the end, I’m still perplexed and left with a system that tells me to update but the update mechanism built in doesn’t work. :frowning:

What do your logs say?


Following clicking the UPDATE button

On the supervisor view, go to the ‘system’ tab in the upper right. The logs for the supervisor are there.


Here are screenshots. After clicking the UPDATE buttons there is no log activity in either the supervisord or core logs

Did you reboot the host? If not, try that.

If there is no activity in the supervisor log (look at the bottom for the lastest info) it means its not getting the request to update. You should see logs about it reaching out for the download or a entry that says something has failed.

Try clicking the button in the left hand core panel in the screenshots above.

You can also try updating via the command line.

0.114.4 is the Core version (not supervisor) so whether you had a supervised install or not you would be in this same position.


That would mean there’s an issue with the UI. There are no entries indicating any activity, the request, a reach out for the update files, or failure. Tried that too.


I had, prior to my upgrade attempt. But that was a week ago. So at your query, I rebooted again and voila the upgrade took. It goes without saying, why did it work today as I had rebooted last week to install a Aeon Labs Gen5 stick and some zwave devices but not just prior to the upgrade attempt?


I’m in no position to debate that. With that said, I have the supervisord installation. I downloaded the supervisord installation script from and installed it. It is running as a docker container along with all the other add-ons I’ve installed. You can also see from the screenshots “Supervisor”. I can’t speak for certain, but I believe that tells me I have a supervisor install. That, however, I can’t be sure as I haven’t experienced the VM OS install or straight Docker container install.

I want to thank each of you for your input and help. It is very much appreciated! And @sparkydave, don’t take my response as negative. I just can’t speak with any experience to your point.

Again, thanks all!

Have checked why your system is in a unhealthy state? You might have to update your system first

I am running ubuntu 18.04 and have the same issue. When you reboot the system the unhealthy warning will disappear and you can update.

When a new version of the supervisor is installed the system will be unhealthy again regarding not privileged. I asked the ha devs and the said there is a bug in ubuntu regarding this. So after a supervisor update the system thinks it is not privileged. This goes away after a reboot.

I am now thinking about reinstalling the server with debian 10. A reboot before a core update is pretty annoying.

Hi hackerhatt,

Did you find an issue please ? I have the same problem Update Supervisor fails :wink:

Cheers !