💡 Sensor Light - Motion Sensor - Door Sensor - Sun Elevation - LUX Value - Scenes - Time - Light Control - Device Tracker - Night Lights


Thanks for the reply :slight_smile:

Not sure it’s related to the 2.9 release as I’ve only just upgraded from 2.8 today. My lights have always transitioned from ‘normal’ to ‘night lights’ at the crossover time. I’m using scenes for day, night and off btw

Thanks! :slight_smile:

1 Like


Yes they would of crossover at night (start time) but not in the morning (end time) and if you had different lights they would stay ON, this happen to me many times with a light flicker. It is tricky with so may options. This is why its it is crossing over now like this. It checking your selections and turning off lights that are different. If you have the same lights then you probably didn’t notice the bug. I am even ironing out a bug in them now.

Personally, I just set the night time later.

1 Like

Thanks @Blacky for the reply.

Updated the automation to use entitities as suggested. Hallway lights are working perfectly now however the Govee LED strip is still only turning on at 40% brightness instead of 100%. Updated YAML below:

alias: "Hallway: Motion-Activated Lights"
description: ""
  path: Blackshome/sensor-light.yaml
      - binary_sensor.hue_motion_sensor_2_motion
      - use_brightness
      - use_transition
    ambient_light_options: ambient_light_option_enabled
    ambient_light_value: 50
    include_ambient: ambient_disabled
    time_delay: 1
    light_transition_on: 0.5
    light_transition_off: 10
        - light.h615b_474e
        - light.hallway
        - light.h615b_474e
        - light.hallway
    light_brightness: 100
    ambient_light_sensor: sensor.hue_motion_sensor_2_illuminance

Ah, yes that makes sense. I’m never awake during the end time crossover.

I’ll push the night mode back a little for now :slight_smile:

1 Like


Can you confirm a few things on Govee LED strip

Can you dim the light manually? If so set it to 100% and see what happens.
Is there something else controlling the light? Automation or when turned ON something? Have a look in the logbook for it. If you go into devices you will see the logbook for it.


Yeah I can dim the light manually, and I’ve tried previously to increase it to 100% to force the brightness but it almost instantly updates back down to 40%

However my LED just became unavailable. After doing some digging I’ve changed a few settings around on the Govee integration and increased the polling rate. Will feedback once I have an update from testing these changes.

Thanks for letting us know. :+1:

Hello, thank you very much for this blueprint, it is great.
Would it be possible to add a function for night mode, like a binary sensor.
Example : If sensor is 1 then night mode.
Sorry for my English it’s Google translate.

Managed to resolve the issue with the Govee LED strip. Had to change a couple bits, just in case you get any more questions on it thought I’d make your life easier.

Polling Interval:
By default this is set to 10. This hits the Govee API limits within 24 hours. I’ve updated mine to 120 (I have 2 LED strips) and this seems to have reduced the timeouts. If you have more lights, try increasing this further. To make this change go to Settings > Devices & Services then click on Configure under the Govee integration.

The issue with the brightness not being set correctly was resolved by going to File Editor > /config/govee_learning.yaml and changing before_set_brightness_turn_on to true

My lights are now functioning as expected.

Just wanted to say thanks again @Blacky for your help and patience with all the questions you get asked on the daily.

Hi @Titom59

All good, thanks for letting us know.

Your welcome

Not realy following you here. Night mode will use the trigger to turn the lights on and off. Would you be so kind to maybe give us a use case so I can understand what you are after?


Thanks for giving us all an update as I am sure someone will find it useful.

I am realy glad you found out what was going wrong and you got it all working now. :+1:

Your welcome :smiling_face_with_three_hearts: and thanks for your kind words :+1:

New update 3.2

:warning: Please read the breaking change before updating. I hope you all understand… the decision was not easy.

Breaking Change :broken_heart:

You can no longer have areas & devices in “Lights - Switches - Scenes” and “Night Lights”. This is to help the automation run correctly. The good news is all you need to do is expand your areas & devices down to entities. To do this, simply click the expand button “<>” in areas & devices down to entities (see below) and you’re done. Your final selection should be all green.

Areas :x:

Devices :x:

Entities :white_check_mark: :+1:

Having the ability to still select areas and devices is a nice quick easy way to find your entities.

Bugs Fixes :bug:

  • Fixed a bug in crossover lights.

  • Fixed 2 error logs.


Blacky :grinning:

Back to FAQ: Click Here


Sorry it’s not easy to make yourself understood with the translation.
Here is an example that I would like to apply at home.
I have sensors under the bed and I would like when a sensor is activated night mode is used.


If you go into bed, activating night mode would only work if you stay in the bed because once you get out of bed it will be deactivated :thinking:


I will assume that when you get out of bed the lights turn ON being night lights and when you get into bed the lights turn off.

You could use this blueprint but you would need to create 2 automations or you could use this blueprint (sensor Light) and download my other blueprint “:gear: Turn Light, Switch or Scene On & Off with Trigger Conditions” and use this for your bed sensor. It has a selection for entity as the trigger.

This is how I would set it up.

Use this blueprint (sensor light) make all your selections, don’t use night lights and select the "Use The Time Options " for say “on time” 7am & the “off time” 10pm. Now you could just use this blueprint again or my other blueprint but we need to create another automation for night time. Create another automation, dont use night lights but set up the normal lights for your night lights. Make your selection using your bed sensor as the trigger and set the "Use The Time Options " for “on time” 10pm & the “off time” 7am.

Now is should work.

Hope this helps you and I have got it correct.

New update 3.3

Bugs Fixes :bug:

  • Fixed a bug in night lights “Transition - ON” and Transition - OFF". It was using normal lights transition time rather than night light transition time.


Blacky :grinning:


Hi Blacky, Thank you so much for the updates. I’m happy to report my logs are boring again nothing to read, well nothing that has to do with your blueprint that is. You should really consider putting up a donation link. This blueprint is priceless for people that are new to HA or just want to be able to save time. When I was getting all the log errors I decided to write my own lighting automations through the GUI. turned out to be easier then I thought it would be. HA has come a long way when it comes to ease of use and figuring things out without having to do lots of research. As soon as you posted the latest update I upgraded and deleted most of my lighting automations. Such a time saving blueprint, thanks Again


This blueprint keeps getting better and better! I use it in a lot of locations in the house, but there is one scenario I would like to see supported. Because my motion sensors are not very sensitive they often time out in the rooms where we watch TV, so I use a different blueprint that keeps them on if the Harmony remote is on.
The Trigger Sensor By-pass Option (using If lights are ON, leave lights ON) works if I turn the TV on after the automation is triggered, but if the TV is already on then the automation will not trigger.
I understand this is by design, but would it be possible to have an additional option to enable the bypass and turn on the lights if they are not already on?
Many thanks!

I’m having issue with the automation not triggering.
I’m using v3.3.
I created an automation and added my door sensor to it and the lights in the room and i didnt change anything else.
when i open and close the door nothing happens and the automation doesnt trigger any ideas?

Hi @geox19

Perfect thanks for letting us know.

A lot of people have asked for this… it is nice way for someone to say thank you so I will set one up.

love it, thank you again for your kind words :smiling_face_with_three_hearts:

1 Like


Nice to hear from you again and thanks for your kind words.

Is there a way to include the Harmony remote into the trigger and group your triggers? This could be the solution for you.