💡 Sensor Light - Motion Sensor - Door Sensor - Sun Elevation - LUX Value - Scenes - Time - Light Control - Device Tracker - Night Lights

More new hardware brings more questions.

Have a Kindle Fire HD 8 in Kiosk mode using Fully Kiosk. Motion detection is an exposed entity called fire_hd_8_tablet_motion_detection. Seen by HA.

Automation is supposed to turn on front hallway switch as I pass by the table. In developer tools, state shows ON when I pass in front of the camera.

But the target switch does not turn on the light. I have the same Front Door Dimmer Switch properly turning on the light with the same Blueprint when a door sensor is opened. Yet, switch doesn’t turn on light with Fire HD 8 entity being on.

alias: Front Hall Light on w Fire Camera Motion
description: Front Hall Light on with Motion by Kindle Fire camera
path: Blackshome/sensor-light.yaml
- switch.fire_hd_8_tablet_motion_detection
entity_id: light.front_door_dimmer_switch_z_wave
time_delay: 3
include_light_control: []
light_brightness: 75
include_ambient: ambient_disabled
include_time: time_enabled
after_time: “00:01:00”
before_time: “23:59:00”

Any idea where to start?


Hi Harry,

First looks like you would like this automation to run 24/7. If that is the case you can disable the time option.If the time option is disabled then the automation will run 24/7. We can use the time option as a condition so if we would like it to run (only work) between the hours of 6pm to 7am we then can enable the time option and input the times we would like. :+1:

But this is not what is wrong just a tip for anyone reading this.

Could you check one thing for me? Could you go into your developer tools before you move in front of your Kindle Fire HD 8 and check the state of your entity “switch.fire_hd_8_tablet_motion_detection” is in. We are looking for an OFF state. Then when you walk in front of it, could you check the state again. The state should change and we are looking for an ON state. If you can let us know these states I will be able to assist further.

Thanks Harry

Blacky :smiley:

Looks like you may be on to something. Just checked, with nobody around, and the state was on.

Attached a screenshot. Perhaps that entity only describes if the motion feature is turned on or off …not whether it’s actually activated.

looks like the problem.

Thanks for letting us know

cheers for this ,
hoping its gonna solve my issues ,
"govee flood lights with a reolink camera,person motion sensor "
was set to turn which it did ,but would never turn off,

1st run on this blueprint bingo !

like i can use the cameras entities to control motion :slight_smile:

first of all: Big thank you @Blacky for this wonderful blueprint.

I second the idea of @capstan1. Using a boolean helper to let the blueprint know that it is nighttime would be great. I would use this helper in other automations as well to e.g switch of Circadian/arcadian lightning, switching off media in the bed rooms, …

Hopefully there is an entity exposed and I’ve just missed it. People do say they use it for motion detection, to wake up from a screensaver etc.


Thanks for the feedback :+1: nice to know it is working with your cameras motion sensors.


Thanks for your kind words :smiling_face_with_three_hearts:

Thanks for taking me back to @capstan1 suggestion that I was “pondering” on. I have also read through this post again and a few other people suggested similar things. The blueprint is ready for this feature now. I can see a lot of use cases to activate night light mode with some type of helper. Stay turned

Blacky :smiley:



Hi Harry,

I have had a quick look at the fully kiosk. I will PM you.

@Blacky amazing blueprint! It is feature-rich and considers so many scenarios. I am currently using a simple motion light blueprint but it does not handle a restart, so if a light is triggered on and a restart occurs, the light will stay on even if there is no more motion. I will give this one a try. Many thanks for your work!


Thanks for you kind words.

This will handle a restart and will look to see what is happening at the time of the restart and preform the correct action.

If you do find a bug let us know as I will be going through this blueprint in about a week to fix 2 bugs reported.


Blacky :smiley:

1 Like

Thanks for the great support and commitment to your BPs. ! :slight_smile: Newb question: When you release a new version, do I simply re-download and import the BP? I presume I won’t need to re-create the automations based on the BP unless there is some new feature in the release that I want to use?


Go back to the first post, there’s a link to frequently asked questions. I think right at the top of those questions is a detailed explanation on upgrading versions.



No problem at all, happy to help and your welcome.

Great question!

This is one thing I realy like about blueprint :heart:. You can have 100 + automations using it and if something is wrong ( bug fix :bug:) you only need to update one file. It normally takes about 5 to 30 seconds to do once you know how.

For all my blueprint, when I update them it will have a version # so you can keep track. This is displayed in the top posts and in the code. In the changelog, it will have all the versions with a link to the release notes. Each time I update, if something is required I will put it in the release notes and it is normally a step by step guide on how to do it. Before you update it is a good idea to read this first. Also in the FAQ at he bottom there is " UPDATES OF BLUEPRINT" section. If you haven’t updated for a while this is a good quick reference as it lists all the points if something was needed to be done. Sometimes I need to do this to move forward.

To update a blueprint I have a FAQ on this. It is a step by step guide Click Here. Like anything the first time takes the longest but once you know how to do it, it is quick and easy.

Now to your question: So if nothing is required to do in the release notes, you just update the blueprint and all your automations are good, nothing to do. If there is some new feature you would like to use then yes you will have to go into each automation and choose your options.

If you would like to easily find all the automation that are using this blueprint. Go into blueprints and click on the 3 dots next to the sensor light blueprint and select “show automations using this blueprint” You then can easily edit them all. See below.

Hope this helps and enjoy.

Blacky :grinning:

Does anybody have any best practice for using this awesome blueprint with Adaptive Lighting?

Thanks so much for all your work again Blacky. I’m having a little bit of trouble with the lux sensor? I have it set to “my lights don’t effect my sensor” and at a level of 37 lux. They turn on just fine with presence, but they never turn off, even when lux is back up over 80. Any thoughts why this might be?


Hi Chris

Your welcome

I have just tested it again here and it worked perfectly. Below are my selections.

I have to ask even if I know the answer sorry. Are you using the correct lux sensor?

You can try 2 things.

  • Redo the automation just encase something went wrong.
  • Provide us your YAML of the automation? This YAML code are the settings you have selected in the automation so I can help. To do this go into your automation, top right 3 dots, Edit in YAML, copy all the code, come back to the forum and in your reply at the top tool bar click on “</>” and paste code in there.

I then can have a look at it.

FAQ - Night Lights - Entity State

This option allows you to use an entity to activate your night lights. You can use this option in your automation to activate your whole house into a night mode. Example of entities or use cases are;

  • Alarm system - Some type of sleep or night mode.
  • Turning your mobile phone on “Do Not Disturb” when you go to bed.
  • A helper toggle.
  • A switch near your bed.
  • A bed sensor.
  • Etc

When the entity is in the ON state, night lights will be activated. When the entity is in the OFF state, the night lights will be deactivated.

Note: If you are using other conditions, then they must be met too.

iPhone Set Up - Do Not Disturb

Things change and your iPhone may be different, but hopefully this will help some.

If you would like to use “Do Not Disturb” on your phone then you must turn this feature ON and have the Home Assistant App installed on your phone.

Then you will need to go into your phone settings and under “Home Assistant” you will need to turn this on. For an iPhone it is called “Focus” as shown below.

You will the need to turn this feature ON in focus. To do this swipe up or down and you will see something like this.

When you tap/hold/push on focus more options will appear.Then if you tap on the 3 dots you will see settings.

You will then need to turn ON focus status.

Once turned on go back and you will see an area with “Allowed Notifications”. You do not need to allow anything for Home Assistant to see if focus is turned ON or OFF.

You then can go into Home Assistant and in settings / devices & services / mobile app / your mobile phone device you will see the state change when you turn it ON and OFF with your phone. This will confirm that HA is receiving your focus status. You then add this entity into the automation under “Night Lights - Entity State” as shown below.


Blacky :smiley:

Back to FAQ: Click Here

Back to “The Settings & Best Practice Guidelines” Click Here

1 Like

Hi @Blacky. Thanks for your contributions. I am looking to switching to your blueprint and am wondering if you’re considering adding support for adding user customizable conditions that would determine whether an automation runs or not. I have a few helper toggles that allow me to easily turn my light automations off for the whole home, per floor, etc. So, my light automations always check that various toggles are ‘enabled’ before proceeding. A kill switch of sorts.

I was thinking the newly added condition selector could work great here: Selectors - Home Assistant (home-assistant.io)