Set my home location

When I go to Configuration > Zones and select home, The default Home map is set to Amsterdam.
Can I edit this or, do I need to create a new zone and then delete the original?

Go to Configuration -> General and change your location there.

You can set zones within the zone file (I use packages) and I have my home zone set there too. (no conflicts as yet)
But as Tink says, the only way HA recognises ‘home’ is if you set it from the front end.

Doesn’t work. There is no way to set the location, and the File Editor gives a “401: Unauthorized” error, so there is no way to set the location. The home location being permanently set to Amsterdam makes the whole ecosystem almost useless when the sunrise and sunset times and everything else that is home time sensitive or location sensitive like weather is completely wrong. Apparently it ignores the set time zone and goes from the location instead.!

This is a clean install of the Home Assistant Operating System on a Raspberry Pi 3 B+.

The Android app gives exactly the same result.

I even tried the Samba route, but it doesn’t show up on my network even though it says it’s running.

I tried a new clean slate install with the same result. The filesystem is “read only”, so there’s no possibility of making changes. I’ve tried every way I can find to make the filesystem writeable, to no avail.

The unauthorized is solved easily : disable enhanced tracking protection in your browser.

As I said, I get exactly the same error from the official Home Assistant app on my phone. It’s not the browser, it’s the Home Assistant setup.

1 Like

I am with wo1fmane here… I’ve done 5 fresh installs, EACH ONE IS GEO LOCKED, also to note, simply because I could I even tried 2 different other sd cards, the same result. For web browsers again simply because I could. I have used browsers (PC opera, chrome, chromium, firefox, IE, Edge) (MAC Brave and Safari) ALL have the same result wo1fmane is talking about

Same for me. I cannot change the location at all, it’s stuck. I can move around the mini-map, but this does not change the location of the pin in it. Right-clicking also does not change the location of the pin on the map.

1 Like

I fixed it by manually configuring in YAML. In my view there is a bug int he GUI, the location is not configurable using the GUI simply.

homeassistant:
  elevation: xxx
  latitude: xxx
  longitude: xxx
5 Likes

I just tried it on 2022.4.5 and could set the home location in the UI just fine. You have to click and drag the marker though.

3 Likes

Here is how to solve the issue… (in version core-2022.5.5)

Steps:
Go to your ‘Map’ card (showing the incorrect location)
Click the ‘pencil’ icon (top-right corner)
Select your ‘Home’ location (right-hand side)
Click & drag your ‘Home’ icon very slightly

… once you drop the icon in a location your ‘Map’ card will now default to the new location.

4 Likes

Tried that numerous times, edit and dragging the pin. Then updating and restarting.

Doesn’t work in GUI.

Doesn’t work. I have the latest HA. I had allowed HA to detect during onboarding.

Having an issue here. I just moved. Trying to move the marker on the map does not work. Even after hitting save and restarting. Marker just reverts to old location. Any ideas?

1 Like

Having this same problem. Drag pin, hit save and back out. Next time I go back into the screen it’s reverted to the old position.

Just wanted to say thanks!! Was tearing my hair out but this worked, I am no longer in Amsterdam.

I’ve just done the same, you have to click and drag the home icon :slight_smile:

Thank you for suggesting this, worked perfectly.