Setting a sensor as a binary sensor

Tags: #<Tag:0x00007f326e574c00> #<Tag:0x00007f326e574a70>

I have an Aeotec Multisensor Gen5. I have data for temperature/humidity/lux but the motion detector doesn’t seem to work. I read I have to access the open z-wave control panel to change the command option from “basic set” to “binary sensor report”. Is it bundled with hass.io? How I access it? Any other way to set my sensor as a binary sensor?

Thanks,

Not sure if Hass.io is different, but in “normal” ha there is a zwave option in the menu on the left.
In there select your sensor
Then scroll all the way down.
There you can change settings. Change setting 5 to binary and save.
That did the trick for me…

Yes, you should be able to do this from the ZWave panel in HASS, I did the same just a few days ago - that wasn’t there probably when that post was written.

Thanks, seem to work! Not very user friendly, but do the trick once you know how to :smiley:

Mmm ok so I configured my option to binary sensor. But my entity sensor.aeotec_zw074_multisensor_gen5_burglar always have “7” as value. Do I have to do anything else to detect motions?

EDIT: I also have the binary_sensor.sensor entity, but the value stay “on” most of the time with and without motion. Some time it goes “off” for a very short period and then go “on” again.

I use the binary one and ignore the other one, and that works well for me.
Once it is activated it stays in ‘on’ state for a while - 3 minutes in my case and i’m not sure where to specify that.
Can it be that you have actual motion going on close to it that makes it go back to ‘on’ after it turns off?

I have the same issue, butI am struggeling to find the setting, all the way in the buttom i have “Node config options” and there “Config parameter”. If I understand right I should edit the Nr 7 “Customer Function”. But how do I edit the Bit 4 to 1 insted of 0?

For me it was option 5, not 7. Do you have the aeotec multisensor 6?
See steps below:

Select the right sensor

Then scroll down to the bottom

No, I have another sensor, a Philio Tech Multisensor 3 in 1 Motion / Light / Temp and what I understand from all documentation i need to set this a option 7 bit 4 to 1. However, I don’t get how I should write in the config value to set Bit 4 as 1.

Bit 4: Notification Type (0: Notification Report, 1: Sensor Binary Report)


(the 4 in config value is there when i chose that option)

I managed to set it to 41 now, but it didn’t change a thing, still not working. I think I give up

I realize this is an old thread but since I just recently had trouble setting up a Philio PIR sensor I would just like to share how I made it work as a binary sensor.

Config Parameter 7 is a bit controlled parameter, containing multiple yes/no “switches”. If you want to configure this parameter, you need to type in a number in the input field, which then “translates” to a series of bits corresponding to a state for each of the switches. So you basically configure every switch with a single number.

There are 8 bits (from 0 to 7), each corresponding to a switch. So the number, that goes into the input field, is the number that is translated from the series of digits (yes/no’s) you choose for each switch. To get the number to put in, you can use a binary calculator like the one here: http://www.calculator.net/binary-calculator.html. Just pick the “Convert binary Value to Decimal Value” option. In the calculator, just type in the series of bits, depending on your selections, like “00010110” (which translates to 22) but remember it has to be backwards, meaning that the last bit is bit 0 (zero).

One last thing you could do if it still doesnt work is to try pushing the tamper button three times. This is what finally made the setting work for me, after pushing “Set Config Parameter”.

Thansk, I have not got this to work so it is still interesting even if the tread is old.

I have managed to set the Bit 4 to 1 “Sensor Binary report” but it won’t still respond to any movement in HASS. What di you have to change to get it to work @anderstbl ?

Did you also set Bit 1 as 1? To enable OFF report. Ozw recommends setting 22, which does this and sets Bit 4 to 1 also…

Sorry but I don’t rely understand. I a little bitt confused about this bit setting. Is setting 22 bit 1? And Bit 4 should be on 1, I think that I have managed to set bit 4 to 1 but I am not sure. What I have done set the byt to 41 and sent the command, is that wrong? I don’t rely understand how to calculate the bits. How do I know the bits is 00010110 as you say in the example that I should put in?

Why did you set the byte to 41?

If you look at the bottom of the description field, you can see that "ozw recommended setting: 00010110: 22. This means that they recommend the following for each switch in the “Customer Function”:

  • Bit 0 (reserved): 0
  • Bit 1 (enable OFF report): 1
  • Bit 2 (enable super sensitivity mode): 1
  • Bit 3 (reserved): 0
  • Bit 4 (notification type - 1 = binary, 0 = notification): 1
  • Bit 5 (dont know what this means): 0
  • Bit 6 (disable report bat on trigger): 0
  • Bit 7 (reserved): 0

If you take each switch selection from above, it comes out as 00010110 (backwards, bottom to top).
If you type this number into the Binary Calculator, it will give you 22, exactly as they already wrote.

As you can see, this setting enables OFF report as well as binary report type, which is what you want :slight_smile: So I would recommend the same as ozw (the value 22) for the customer function.

1 Like

Ahhhhaaaaaa…NOW i final got it!!! This solved the everything and my sensor is working! Thanks for the help @anderstbl :handshake:

Glad you got it sorted out :slight_smile:

1 Like

My “config parameter” area is greyed out so I can’t select anything.

It did recognize as a binary sensor when I installed it (in my case it’s a door/window entry sensor, which Home Assistant correctly named as binary_sensor.XXX) but I have the same issue with it perpetually being stuck to ‘on’ even though the sensor light beeps to indicate that it is recognizing open/close.

Any thoughts on why I might not be able to set a config parameter?

Arne there any other menus available when selecting your device in the zwave panel?

A few, I’ve played with them all a bit but nothing I select lets me edit config params.

Can you see those or is it just showing the one picture?