Setting up SmartThings with Cloud Hook

I’m attempting to follow the instructions for setting up my SmartThings hub with this but I’m running into a wall. I decided at this time to use Nabu Casa and not worry about opening up my server publically. My understanding with the instructions is that all I need to do is.

  1. Use and setup Nabu Casa
  2. Get my personal access token from Samsung/SmartThings
  3. Connect Home Assistant Cloud, logged-in with a subscription.

What other steps are there after that?

I’ve created my token.

Am I supposed to then do the Configure Home Assistant config steps? If so when I do the system is unable to complete. I get an unknown error.

Log Details (ERROR)
Tue Apr 30 2019 08:48:33 GMT-0700 (Pacific Daylight Time)
Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 418, in start
resp = await task
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 458, in _handle
resp = await handler(request)
File “/usr/local/lib/python3.7/site-packages/aiohttp/”, line 119, in impl
return await handler(request)
File “/usr/src/app/homeassistant/components/http/”, line 33, in real_ip_middleware
return await handler(request)
File “/usr/src/app/homeassistant/components/http/”, line 68, in ban_middleware
return await handler(request)
File “/usr/src/app/homeassistant/components/http/”, line 216, in auth_middleware
return await handler(request)
File “/usr/src/app/homeassistant/components/http/”, line 115, in handle
result = await result
File “/usr/src/app/homeassistant/components/config/”, line 154, in post
return await super().post(request, flow_id)
File “/usr/src/app/homeassistant/components/http/”, line 46, in wrapper
result = await method(view, request, *args, **kwargs)
File “/usr/src/app/homeassistant/helpers/”, line 86, in post
result = await self._flow_mgr.async_configure(flow_id, data)
File “/usr/src/app/homeassistant/”, line 80, in async_configure
flow, step_id, user_input)
File “/usr/src/app/homeassistant/”, line 98, in _async_handle_step
result = await getattr(flow, method)(user_input) # type: Dict
File “/usr/src/app/homeassistant/components/smartthings/”, line 79, in async_step_user
await setup_smartapp_endpoint(self.hass)
File “/usr/src/app/homeassistant/components/smartthings/”, line 202, in setup_smartapp_endpoint
hass, config[CONF_WEBHOOK_ID])
File “/usr/src/app/homeassistant/components/cloud/”, line 105, in async_create_cloudhook
hook = await[DOMAIN].cloudhooks.async_create(webhook_id, True)
File “/usr/local/lib/python3.7/site-packages/hass_nabucasa/”, line 35, in async_create
raise ValueError(“Hook is already enabled for the cloud.”)
ValueError: Hook is already enabled for the cloud.

If it says it is already enabled, shouldn’t I see something somewhere on my devices already connection to my hub?

Anyone? Help? Am I misunderstanding this?

Maybe this video can point you to the right direction. I was able to get mine worked by following it

Hi Dan,

have you solved? … i have your same issue …

same issue

I’m having the same issue I’ve done it ever way possible that’s available on the internet. Those step by step directions are not the way to go. I’m running version 0.101.2 and I just dont get it.

Has anyone been able to resolve the issue? I removed my base url and ssl cert info as I was previously using a webhook and having stability issues with the integration. I decided to give the cloud option a try.:unamused:

Any resolution yet?