Setup failed for tado


#1

Just started to have an issue with Tado.

Setup failed for tado: Component failed to initialize.

Anyone else have the same issue?


Tado Heating Component Not Working
#2

Same here. I think Tado servers are down.


#3

Same here. Must be a problem with the Tado servers or the Tado API.

My log says:

2019-03-14 20:43:17 ERROR (SyncWorker_8) [homeassistant.components.tado] Unable to connect to mytado with username and password
2019-03-14 20:43:17 ERROR (MainThread) [homeassistant.setup] Setup failed for tado: Component failed to initialize.

#4

probably related to this:

Starting March 2019, authentication will require retrieving access and refresh tokens from auth.tado.com

PyTado did not yet switch to the new authentication server, but tado probably did.


#5

i fixed it in my HA by replacing my.tado.com with auth.tado.com in

and

in deps/lib/python/site-packages/PyTado/interface.py


Tado stop working with 0.89.2
#6

Same here.

Tado device tracker is working though, climate and sensors are not.


#7

Yup, same here.

I’m running Hassio on a Pi, so I don’t think I can get access to the source directories to modify it?


#8

Yes, that worked for me as well! Thanks!


#9

Thanks this worked as a quick fix :+1:


#10

Where to put those two files after making the changes? I run hassbian


#11

Same here. Looks like a global problem. Your workaround solution works! You’re great!
Hope next updates will fix this.


#12

Hello, this is solution for docker users:

1.- Access by ssh to the host and execute docker ps to get the code from the docker container:

5a4353db1768        homeassistant/home-assistant:latest

2.- Now copy the file: /config/deps/lib/python3.7/site-packages/PyTado/interface.py to a folder inside the host:

docker cp 5a4353db1768:/config/deps/lib/python3.7/site-packages/PyTado/interface.py /media/interface.py

3.- Modify the file Interface.py the row 115 and 140 of the file Interface.py change my.tado.com by auth.tado.com (thanks @Macs)

4.- Now copy the file from the host to the container:

docker cp /media/interface.py 5a4353db1768:/config/deps/lib/python3.7/site-packages/PyTado/interface.py

5.- Restart Homeassistant docker container :slight_smile:

Thanks @diplix


#13

the solution by @diplix did also work for me. I simply put the SD card of my HASSIO into my PC and searched for interface.py files. I modified all Tado related files accordingly and now it is working again!

Thanks again for the super fast solution


#14

Thanks this worked for me using virtual python environment on ubuntu 18.04

though found it in /homeassistant/lib/python3.6/site-packages/PyTado/interface.py


#15

Thanks for the workaround :+1:


#16

Same problem here.
But on Hassio any idea where to find the interface.py to edit?

i cannot find it in deps/lib/python/site-packages/PyTado/interface.py


#17

Fantastic!

On my docker (Home Assistant version 0.89.1) the path was :usr/local/lib/python3.7/site-packages/PyTado/interface.py

But it’s now working again :slight_smile:


#18

The string “my.tado.com” appears in several places, should it always be updated? Tnx


#19

For the life of me I can’t find interfaces.py on my Hassio set up. I have connected to it via SFTP and have searched for it but can’t find it anywhere, I have access to root. Anyone have any suggestions, I have checked the two locations listed above and also tried putting the SD card into a PC but I don’t see an interfaces.py there either?

I have found/config/deps/lib/python3.7/site-packages/ but it is not in there either.


#20

same for me. No way to find tado py file in hassio. Waiting for update of hassio