Shelly devices cannot be discovered by HA


I am new to HA but want to lean how to make a better smart home.

So far I have had the Raspberry Pi 4 for three months. Half of my 50 smart home devices load into HA and the rest don’t. So achievements to date are zip.

I have a number of projects in mind but need to get all my smart home devices loaded first.

My first goal is getting a Shelly Button 2 to work and register the clicks. And loading all the 23 shelly devices.

So far, 9 shelly devices are loaded with no problem, 5 fail to set up and keep retrying and 9 devices cannot be discovered.

Only one has a static ip address. Usually if I create a static ip address in the shelly app, the device goes offline and it takes me a few days to get it back online. I follow the url Shelly Wi-Fi Setup & Troubleshooting Guide - SmartHome but again the device goes offline and does not set up a static ip address.

For 5 devices I can get into the web interface. The rest of the other ip addresses fail to load as the site took too long to respond. If you ping them, the ip cannot be found. So if there is another ip address hidden somewhere I don’t know where to look as the Telstra modem and Shelly app give the same ip address.

I can set up scenes in Shelly app so I know the shelly devices are all on the internet and work.

I have tried searching HA Support but they just tells you what works, which for me does not work. So I must have another problem, maybe with the ip addresses.

With the button I started following this video

Awesome Shelly Button 1 and Home Assistant integration (

All sounds easy but never seems to work. It fails at the 4:17 go to the web interface as that fails to load.

So the device cannot be discovered by HA.

Some other advise I tried like this

Setting up Shelly buttons with HA Docker - Community Guides - Home Assistant Community (


Add the button to Shelly App and update the firmware.

Plug the button into a charger and connect to the local web-server (http://buttons_ip_address).

Enable CoIoT under Internet & Security > Advanced - Developer Settings > Enable CoIoT (see Fig 1):

Set CoIoT peer to:


Save the configuration and reboot the button: Settings > Device Reboot > Device Reboot.

For one, you do not need http:// I just enter the ip_address and I get into the web interface.

For the button I cannot get into the web interface.

My HA spec on the Raspberry Pi is

Spec rpi4-64

Home assistance core 2023.12.4

HA Operating System 11.2

Any assistance in getting all the shelly devices loaded would be appreciated.


Sounds more like a WiFi setup issue. What APs and how many in the location. Have you setup a separate network including a 2.4 GHz Wifi network and VLan for IoT devices and the HA? Describe the location, type of building and construction. Is mDNS enabled (multicast), also is unicast enabled since you set that on the Shelly devices?

Not certain of all your terminology at this is not my area of expertise but to answer the best I can.

But there are 23 shelly devices all up there are about 78 devices with ip addresses.

The Telstra Arcadyan smart modem comes with a 2.4 GHz and a 5 GHz channel.

Plus there is a TP-Link Deco Mesh router with a 2.4Ghz and 5Ghz channel.

I have not set up a VLan.

The building is a three bedroom two storey townhouse. Brick.

All the devices work with Goole Home and in their own iphone software app. About a third of the devices have the unicast enabled. The rest of the shelly devices I cannot get into the web interface as the devices show up as not connected in the modem interface and I cannot ping them. That was my next target to investigate.

I did not read anything about enabling multicast, so I haven’t done it.

Any ideas so I can at least get these devices into HA would be appreciated


Suggest that you admin your router and use DHCP address reservations for the devices. This will stop them from changing IP addresses without you modifying anything in the HA world.
Hopefully this will either help, or will eliminate that issue and help you find the problem.

Which router is handing out IP addresses? If both, that is a problem, there should be only one.

Sorry for the delay in responding, New Years.

I turned off the IP addresses from the Deco TP LInk. So only the Arcadyan issues the ip addresses.

So if it is an IP problem, then it is something else.

Any other thoughts?

I set up 6 static ip address in the Arcadyan Modem to match the Shelly products static ip addresses. But when I do a arp -a in CMD, only one of the ip addresses shows up and it is marked as dynamic. So i don’t think the static ip address are not set up correctly.

Some of this I only copy from userguides etc but I will try setting them up again and change the local device ip address first as per image. I read this will set up a seperate subnet. I left the local device ip address the same as the modem.

WIll update how this goes.

This just took all Shelly devices offline, so i reverted the change.
Still waiting for some 6-7 devices to come back online.

I have no idea of where to look next…

So what is under static leases (These are known as static IP addresses) from the pic you posted? Also you need to cycle the shelly devices if the there is a change from two dhcp servers to one. Also with a 1440 min lease time, that equates to 24 hours (1day). So unless you cycle the shelly’s they will retain the old setting until the lease time expires.

The pic I posted was from a pdf I was following. But when i tried all of the shelly devices went offline. It took me a couple of hours to reset. I changed the locap ip address back to and similar for the DHCP start/end range.

I also deleted the five static ip address i set up on the Acradyan router as any checks in CMD did not show any static ip addresses i had set up.

I have made static ip addresses in the shelly devices which whould update the router but they change occasionally, so they are not static. They do not show up as static in arp -a table, Shelly says they are static, my Kapersky has smart home software and they have the same ip as the shelly but may not show up in the arp -a table. Plus i usually cannot ping them and kaperspky shows them as offline even thou google home/shelly can control them.

So as I far as I can figure out I am still trying to set up static ip adresses for the shelly devices as this neither works in the router not shelly.
So I am looking for another way to do it and prove they are static ips.

At the momenet i have nine shelly devices offline and are waiting for them to come back online whihc normally takes a few hours.

So I am seraching for a clear was to set up static ip addrress and prove that they are static.


Kerpersky (Firewall) could be blocking ping to/from the Shellys

I can turn that off or on and it has never been a problem. Some shelly devices i can get to the web interface some i cannot. I set them up as static ip in the modem and the shelly software. Cannot figure a pattern as some in can get the interface and other i cannot.

I am now up to 17/25 shelly devices loaded. They just seem to slowly make themselves available. But then one will fail to initialize, then that jumps to six fail to initialse when you reboot HA.

I have spoken to my Ip provider and they offered no support on how to verify static ip addresses.

I have run out of ideas.

Any suggestions would be appreciated.

I would say that you need to think about using the modem with a new router and wireless setup with more control and less limitations. A router that supports multiple networks, vLans, static IPs.

Over the last few days I spent $s upgrading to the Google Mesh 6E router. Set up the new static IPs for shelly devices.

To date I had 20 devices recognised by HA, with 14 that kept saying in HA “Fail setup, Will retry”, so I deleted all these to Add Device using the new IP address.

None loaded up into HA. Trying to add device by entering the IP just gave me “Failed to connect” so none of the new IPs worked.

The only devices that are still in HA and transitioned to the new router were the door sensors.

Also for Shelly only six devices can get into the web interface. And none of these are in HA.

Can anyone propose any idea on what to do now?
Any assitance would be much appreciated.


Okay, are you trying to run everything wirelessly? What is the HA running on? You need to give a lot more detailed info on the hardware and how the network is setup physically.

The HA is running on a Raspberry Pi 4. The Google mesh 6E Pro router has three hubs, (the main one plugged into the NBN modem is upstairs). The Raspberry Pi is downstaris and is plugged into the Nest wifi point that is downstairs.

The Raspberry pi build Core is 2024.1.2
The operating system is 11.3.

After I setup all the shelly devices for static IP, I also set up the static ip in the google mesh router. Then i rebooted the lights, rebooted the router and rebooted Raspberry Pi.

Do you need any other info? Any suggestions?


Does the PI have a static IP address? It should. I would put the PI on the main using a wired ethernet.

Also a meshing network may cause interference with the wireless devices. So you may have to tune the wireless network. Different channels to cover different areas and manual power settings (custom for dB power levels) so your not swamping/over powering you IoT devices

Q1 I noticed that the ip address has not changed over to the new router eg 192.168.0.?? (old) to 192.168.86.?? (new).

So will work on changing this over first.

it is easier for me to leave the raspberry pi plugged into a point as i have access to it and a number of screens etc.

Q2 Google has software to finetune the mesh signals and does not offer any other way to do it. Best I could do is to try turning one off.

If changing router, I would normally have the new router reuse the ip address of the old router. If the old router is still online, change it’s ip address first and disable it’s dhcp server.