Shelly Plus 1 24V DC not working

Hey Guys,

I got a couple of Shelly 1 Plus units to automate my garage door and sliding gate motors. These new Shelly’s have a dedicated 12v terminal, and the units work fine wired up to my garage door, which supplies its own 12v feed. The AP publishes itself straightaway and I can connect and configure it in HA.

Both units also work fine with 240v. I’ve just tested by wiring up active and neutral and seeing the AP straight away.

I cannot get either unit to work on the 24V feed from my BHT gate motor though. I’m just wiring up the motor’s 24V aux + and - to the Shelly’s DC terminals but I get no AP. I’ve confirmed with a multimeter 24V is going to the Shelly’s terminal.

Is there something I’m missing with 24V DC requirements? Do I also have to wire the SW/0/1 terminals before the AP starts up??

Thanks in advance.


Have you set the jumper on the side of the Shelly 1 to 24v?

The new Shelly Plus 1’s don’t have a separate jumper to set for low voltage.

Shelly Plus 1 - Shelly Cloud

I have the same issue. I’m sure my wiring is correct but I did not see the Shelly pop up in my wifi list or during pairing with the app. Holding down the reset button for more than 10 seconds did not help.
Did you manage to solve the issue?

Same issue here.

Edited: Nevermind. Should have read the labels L(-) & N(+). Would expect the other way around. Switched the wires and it started working. :see_no_evil:

1 Like

I have been looking at the Shelly 1 Plus for a garage door project, but I am trying to figure out why I would want the plus over a regular Shelly 1 (other than the easier pairing and the newer model.). Are there any Cons to the plus that I should be considering?

Hi Everyone,

I am having a similar problem getting my Shelly Plus 1 online with a 24v DC.
I tried connecting the 2 wires from the 24v transformer to the L and the N sockets on the Shelly (and also tried reversing them) but I could not get the Access Point to come alive.
As a test, I connected the 2 wires to the 12v and the N and that worked instantly - the AP point became visible…
Unfortunately after 10 seconds (as I was configuring things on the mobile app) I heard a soft “pop” and the connection went dead. I suspect I “fried” the unit by putting 24v where it expected only 12v.

But before I buy a new one and try again I wanted to see if anyone had any additional tips or thoughts on how to get the Shelly 1 Plus connected with 24v DC. (I checked with a voltage tester and it is indeed 24v).

Thanks in advance for your feedback,

I don’t suppose you ever figured this out did you? I just did the same and mine went pop. Pretty deflated about it. It was to replace an unreliable Shelly 1 so quite annoying to have now broken this one as well. I don’t know what the wiring should have been but it’s definitely not the same as the original one.