Siri shortcut doesn´t work

Hey guys,

just wanted to try voice controlling some stuff using Siri, so i got the shortcuts listed here.

The button works without any problems.
Same goes for the siri-shortcut itself, as long as i lauch it from the shortcuts-app and write in a text. When i start it using “Hey Siri, Assist” it asks for the next command, i tried using “turn on office light” (in german, shortcut is set to german). it replies with “ok” but does not turn on the light.

anyone knows how to fix that?

2 Likes

I have exactly the same!

Same here. Assist Button works with speech to text in German. Also Assist works if I type German text. If I use it with Siri, it opens up the assist and telling me it got the command. Command answer looks a bit different and not complete. So nothing happens in the end.

I use it in Swedish, but experience the same issue.

Same for me here also Language set to German.
even a self written shortcut does work as a shortcut but noch via Siri

I had the same as I was using assist setup in French and Siri setup in English.

I updated Siri language to french to match assist&shortcut language and now it works.

I am facing the same problem. Did anyone find a solution. Siri, Assist button and Assist are all set to the same language (German). Text input works fine, speech to text via Assist button works fine, but using Siri doesn’t work. If I look at the text that she interpretes, she basically stops listening after the device I want to control (she cuts off the actual command).

Same issue. Unsure if this is a Shortcut bug, but there are other dictation bridge shortcuts (like Savant) that do not have this issue.

When triggering the shortcut manually, there is no issue. It’s only when triggering the shortcut action from a “Hey Siri” voice command. At this point nothing is logged in Home Assist or happens.

My guess is you cannot ask for text in a voice triggered shortcut and must ask for input speech.

Hey so I have the exact same issue here and it started around the ios 17.4 update. Anything on what can be done to fix it? I have so many shortcuts with HASS. Really frustrating :confounded:

Hello everyone.
Same problem here. The strange thing is that Siri actually performs shortcuts which are just made of action/actions which are existing in actions in companion app. What Siri does not perform is for example shortcut which use “Render Template”. Anyway, manual run of the shortcut works perfectly. Anyone solved this?

Hi, being quite a newbie, I would be curious if someone found a solution as well. I face the same issues as described above. Typing the text in german language works perfectly. Dictating the german text works perfectly. Saying “Hey Siri, Assist, Öffne Rollläden oben” (“hey siri, assist, open shutters upstairs”) doesn’t give any reaction…

I’m having the same issue has anyone solved this,
Render template in iOS 17.4

I found a solution

https://www.reddit.com/r/shortcuts/comments/1bocnuh/psa_since_ios_174_has_siri_been_failing_to_run/

Unfortunately this doesn’t work for me, as the phone has to be unlocked and it doesn’t work via CarPlay. I use several shortcuts via CarPlay to render HA templates, so I can ask Siri to tell me the status of various sensors. If I add this work around Siri just tells me it can’t do it while I’m connected to CarPlay. It all worked fine (for years) until I updated to the latest version of iOS, v17.4.1, recently, so looks like it’s an iOS bug that Apple have introduced and need to fix…