Skip 0.55.1 - go directly to 0.55.2

something I would like to know also, how do you update if you don’t have access to after installing 0.55.1


What I did was in ssh “hassio host reboot” to reboot the pi.
Then I tried to restart hassio, which didn’t work.
After that I issued “hassio homeassistant update”
This took some time. A restart after the update failed again, so I did another reboot of the host (raspberry pi)
When he pi was back online I could initiate a new ssh-session.
I started my browser again a tried several times to access the home page of hassio, after a couple of minutes it worked .
My version is now 0.55.0 again.

This worked for me. Maybe I was just lucky

can’t even ssh into it, connection refused

So exactly how do I fix this if I can’t SSH into hassio?

Exact same procedure I did and I’m back at 0.55.0.

Try a hard reboot then…

Rollback procedure when not having the SSH add-on running:

  • Generate an SSH private/public key pair (you can google that)
  • Place the SD card into your computer
  • Place the contents of your public key file into a file called ‘authorized_keys’ on the root of the SD card
  • Eject the SD card, place it back into your Raspberry PI
  • Boot the device
  • Connect to your device using root as username, 22222 as the port and ensure your generated private key is used for authentication
  • Once you are in, execute the following command:
    curl -d '{"version": "0.55"}'
  • Wait till it returns “OK”. Please be sure to wait, this could take 10 minutes.
  • Wait a little more
  • Done.

Thanks. I got SSH to work. I did hassio homeassistant update and got this message:

core-ssh:~# hassio core-ssh:~# hassio homeassistant update
core-ssh:~# API error:
-ash: API: not found

From the SSH add-on you need to run the following command:

curl -d '{"version": "0.55"}' http://hassio/homeassistant/update

1 Like

call first hassio supervisor reload to fetch the version from server. After that you can use hassio homeassistant update

from ssh
hassio supervisor reload
hassio homeassistant update
– will update to 0.55.2
hassio host reboot
– give it a couple of minutes to reload and then try frontend

worked for me now all running fine again

1 Like

I’m using Docker with the solution described here:

I’ve never got the “hassio” command to work, is it docker attach I should use?

So, it doesn’t look like I can use the instructions from this thread, right?

I found a solution for Docker users.

I was trying this:
$ sudo docker attach hassio_supervisor

And got this:
[hassio.dock.homeassistant] Start homeassistant homeassistant/raspberrypi2-homeassistant with version 0.55.1

So I tried this:
$ sudo docker pull homeassistant/raspberrypi2-homeassistant

And the update seems to fix the problem.

I’m using docker on Ubuntu, and just did a pull of the latest release, and all is good again. On 0.55.2 and all is functioning well.

docker pull homeassistant/home-assistant

This created a new docker image but it’s alongside my other ones. How do I tell HASSIO to use the new image?

EDIT: I’m trying the pull request again using the existing image’s name.

EDIT 2: Okay, that worked!

To anyone else that has the same problem as me:

I connected to my Ubuntu box via SSH and executed this to see what my image was named:

docker images

Then I executed the pull request using the exact same name as the existing image:

docker pull homeassistant/qemux86-64-homeassistant

1 Like

Resinos doesn’t boots up. It stucks at splash screen. I need to recover my configs.

Thank you! That worked for me running a stuck HASSIO 0.55.1 and upgrading to 0.55.2. I appreciate it

EDIT: More details: I couldn’t log into HASSIO by https, my automations stopped working, and my log file on Samba Share was stuck at 4:30 pm on Oct 16, no matter how many times I rebooted via SSH or reset my router/modem/pi. I used PuTTY to log into HASSIO and check the log file there, to find an error (can’t remember the exact error) that I used to search for this topic. After upgrading using the above instructions, I can log in again, my automations work again and my Samba Share log file is updating again.

Hi Frenck,
thanks for the instructions. After following them, now I get below error:
$ ssh -p 22222 [email protected]
Permission denied (publickey).

Any ideas?

How can I ensure that I my generated private key is used for authentication? what is the command?
PS: Do I need to copy file to the root of SD card as well?

Place the contents of your public key file into a file called ‘authorized_keys’ on the root of the SD card

where is 0.55.2, I see only 0.55.1? Or has been solved?