SkyConnect not finding devices (12/2023)

Hello fellow HA users

After digging around on the forum, the internet and trying many things, I turn to you for help. For context, I am new to Home Assistant but I am an experienced server owner.

I recently installed HomeAssistant on my server (Quartz64 with DietPi) as a Docker container with Docker compose. Worked as a charm. I have been able to connect my ESPHome dongle and my Skyconnect dongle (ZHA) without any problems.

This weekend I tried to connect a Sonoff module and a Lidl Home ceiling lamp to HA. Thats where I fail.
The ZHA is available and gives no error. When I try to add a device to ZHA it goes into search mode but it doesn’t detect anything.

What I already tried:

  • Look in the docker container if the skyconnect is visible: yes it is in /dev/ttyUSB0
  • Upgrading the firmware of the Skyconnect dongle (from to
  • Following advices from Zigbee Home Automation - Home Assistant => dongle is 1 meter from the serverbox in a USB2.0 port, not near any device producing or reading a signal. The Sonoff device I try to add is approx. 7 meters away from the dongle.
  • Following advices in SkyConnect not finding devices including the last one with some restarts of the whole server not only the container.

I put the ZHA integration in debug mode but even then when searching the “show logs” part is always empty:

Hopefully you have some new insights for me. Thanks in advance!

Best regards,

Did you try putting the pairing device near the skyconnect? Like really near.

I did try to add the remote controller of the lidl lamp to HA too and held that one like at 10cm of the SkyConnect Dongle. Same result unfortunately.