SkyConnect not finding devices

Yesterday I received my SkyConnect dongle and plugged it to my Rasberry Pi HA installation (using the extension cord of course).

After online research I learned that I needed to install ZHA integration, which immediately detected the SkyConnect dongle.

However when trying to add devices nothing is detected. I took note of the best practises- and tried a Tradfri bulb, put it pairing mode (on/off few times and light is flashing), but to no avail. Also tried the Ikea (battery powered) Remote, (pairing mode after 4 times back button) and Aqara E1 roller blind driver, but none are detected.

Any idea what I’m doing wrong here?

I just upgraded to the latest version of HA (2022.12) . Looking just now at the hardware options I noticed this post about SkyConnect, but reading this it seems to only be affecting the option to simultaneously run Thread and Zigbee.

1 Like

Same here :frowning:

I’ve done a bit more testing and managed to connect an Ikea Tradfri Control Outlet (smart plug).

I managed to get it detected but only when holding it in a range of 20cm to the SkyConnect dongle. Any further distance will leave it undetected in pairing mode. However, if I then move the SkyConnect further away from the control outlet the switch function fails to work, moving it closer in range again (20cm) restores the switch function.

I tried to reproduce this for about 10 times and consistently get it detected in a short range, but not in a long range.

Alas, the remote controller and Aqara E1 roller blind still won’t detect not even in close range.

Another step further…

I managed to detect the battery operated Tradfri remote and Aqara E1 by holding it close to the Tradfri Outlet (which acts as a Zigbee router).

However, I still have the issue that the Outlet. It will only be paired within 20cm of the Skyconnect and even then connection seems intermittent controlling devices. Perhaps still some interference. it is located in the meter cupboard which is same place a the (now turned off) Tradrfi Hub. The Tradfri hub connection has been solid. Still I’ll try to move my Raspi to another location and see if this improves the connectivity.

It maybe an interference thing… I moved my raspi with HA to a different location and I’m able to pair and operate devices at larger distance as expected.

Very strange though that the same location as the Tradfri Hub seems to be giving problems.

Again I’m using the extension cable provided. I even tried disabling the wifi on the AccessPoint close by (both 2.4 and 5GHz channels).

Is there any way I could further troubleshoot interference?

I’d really like to keep my HA rasberry pi installation in the utility/fusebox cupboard due to the fact that it is connected with a P1 cable to my smart energy meter.

I tried setting ZHA to channel 20 and 25 (after removing integration) but to no avail.

Moving the device to another location fixes the problem.

Any idea how to further troubleshoot interference?

I did already turnoff devices in same cupboard (Tradfri hub and WiFi AP). Only other thing is the smart meter but researching this it seems that one only does GPRS and CDMA which should not be near the 2.4GHz range.

Yesterday I had the same issue for lights placed close to the coordinator. I migrated ZHA from a ZBDongle-E so I had some lights already in my zigbee network. After pairing approx. 30 devices, using the skyconnect stick, in other rooms I wasn’t able to pair 3 lights in the same room as the coordinator. The behaviour is similar to the one posted in the DevBlog related to the Zigbee/Thread firmware, but I didn’t upgrade the firmware yet.

Thanks @derski. Can you share a link to the DevBlog article you mentioned?

I assume you refer to this post:

Also found some interesting info on this discussion.

You can do a energy scan using zigpy (see zigpy-znp/ at dfbc7a44ea217f99c1715c07042494afaa5dde33 · zigpy/zigpy-znp · GitHub).

In general USB 3.0 is a big source of intereference. Do you have a USB 3.0 SSD conected to your Raspberry Pi? Also make sure to use the USB 2.0 port of your Raspberry Pi.

Thanks @agners,

Indeed I have an external SSD connected to a USB3 port of the Raspberry Pi. I did notice that reception becomes poor when the Sky Connect is close to the SSD and USB ports but also part of the power extension cord connected to to the Raspberry Pi power supply.

Thanks for suggesting the zigpy-znp tools. I think I’ll have to find the Bellow equivalent for the SkyConnect dongle as its not based on TexasInstruments.

Alas bellows scan won’t complete from console (disabled ZHA and SSH protect mode)

docker exec -it homeassistant bash
bash-5.1# bellows -d /dev/ttyUSB0 scan --energy --duration 500


I am running a fresh install on a Home Assistant Blue latest SW as of 21/12/22.
ZHA recognises skyconnect alright but cannot add any devices. HABlue inside a cabinet and dongle is outside it via cable so interference unlikely.
I will try to reverse back to older OS version and see if issue is with 2022.12

1 Like

I spent all afternoon trying to pair devices and nothing, even with them sat 5cm from the Sky connect. I’m running HA on a Pi 4 and also using an SSD, but I used the supplied USB extension for the Sky Connect. Made no difference. Anyway I moved back to an SD Card instead of SSD and everything pairs no problem from a few metres away. Problem I have now is that automations don’t trigger, the triggers exposed don’t align with what the devices do.

1 Like

Fresh install back to
Home Assistant 2022.9.6
Supervisor 2022.11.2
Operating System 8.5
Frontend 20220907.2 - latest

Now tried to pair frist smart switch and it finds it super fast, no issues what so ever.
Looks like issue related to latest HA version.

At the moment running with Combee2/deconz and only 1 switch in ZHA with Skyconnect but looking good so far.

I will try to migrate it all other devices over to ZHA and see how it goes.

1 Like

Doesn’t the December update include a different version of the ZHA integration? I noticed that is called “SkyConnect v1.0” instead of ZHA

Are you saying you running both Conbee2 and Skyconnect controllers simultaneously?

I had the same issue with my SkyConnect yesterday. The 50cm USB extension it shipped with isn’t long enough in my case. I added a further 1m extension and now it’s finding all the devices fine

So in my case at least, the issue was the well know USB interference.


I had the same issue. When I moved the stick to a usb adapter I got it to work.

Yes, looks like anything 9 and above has a new version of the zigbee integration (didn’t check the logs though it didnt work on OS9)
I was running both skyconn and combee but I didn’t like the mess it makes with entities so Im now on a fresh install (OS8.5) and only skyconnect and so far so good.

Im still pairing devices so not sure if automations etc will work as yet…

Wow!!.. I just plugged in a 1,5m extension and now it reaches the outlet downstairs without and problems! Why did I not try this before?