Skyconnect with Home Assistant running on Synology VMM

Hey All,

Last weekend I finally received my Skyconnect from Hass, really exited to start dangling my feet in the world of Zigbee as I’ve never used it before and i’m planning on changing all my WiFi (SmartLife) devices to zigbee devices for the performance.

Now, i’ve found multiple articles online telling me that USB support on synology was scrapped since DSM 7.0 and i’ve found multiple ways of mannually activating/installing the drivers in order to get something to work. The guides i’ve tried until now are the following:

SkyConnect with Home Assistant Docker in Synology (usb drivers) - Community Guides - Home Assistant Community (

Synology: How to Add USB Support on DSM 7 – Marius Hosting

But none of these guides has helped me into getting it in the list of the VM configuration within VMM.
After I plugged in the USB device in my Synology DS920+ and after following the guides above I still don’t have the ability to select the USB device in the VM configuration.


Is there anyone that has the same issue and maybe knows how to resolve this?
i’m thinking about switching the VM to vmware because ther i don’t need any drivers on the host but only on the VM itself. I don’t understand why Synology removed the support for USB devices in DSM 7.x

Thanks to everyone in this community.

On DSM 7.1 I didn’t need any drivers for VM. As soon as it was plugged in front USB port I did see it in VMM and could map it with VM.
This machine was a clean install (DS415+) I use for testing. There were no prior installed drivers or anything similar.

I currently don’t have it mapped as I’m playing with it in Docker (that does require drivers).

Did you try to unplug/replug and see if it will than show in Edit virtual machine.

Thank you for your reply,

My exact issue is that the USB doesn’t show up after plugging in…
i’ve tried unpluging and pluging back in, also tried multiple ports the ones in the back and the port in the front.

I also have rebooted the device (synology NAS) multiple times to no avail.

You should not have to do anything with USB drivers inside the Synology DSM operating system since it will only “pass-through” to the VM, but you do need to get Synology Virtual Machine Manager to see the USB device so can mount to the virtual machine, however, you not seeing it there under the virtual machine in Synology VMM to mount it is probably more likely a problem with the USB dongle itself of the USB extension cable that you are using for it.

The enclosure/chassis/casing design of some computers (and NAS:es) makes it so that the USB plug on some USB dongle are slightly too short so could be that you can not physically plug the dongle all the way into the USB port in order for it to get proper contact, (as the chassis is basically in the way).

Some enclosures/chassis/casings are very thick so some USB adapters can not make physical contact and others have the board for the USB port to far inside the enclosure which makes it hard to adapters with short USB plugs without using a USB extension cable that has a little extra long USB plug to get plugged in further. For example, if you search then you find that many USB adapters have this issue with the Home Assistant Blue enclosure/chassi/casing and the solution there has been to use a USB extension cable with “longer” plug.

That is, the USB adapter plug is a little too short which makes it harder and sometimes impossible to plug it into some USB ports if the computer enclosure/chassis/casing is too thick around the USB-port as that will physically prevent the USB dongle from actually making a proper connection inside the USB port even if it looks like it is plugged in all the way that is possible.

If that is the issue to work around it you can use a different USB extension cable that has a longer USB plug than what the dongle has on its own, or better yet, connect it via a powered USB 2.0 hub (with a USB cable that has as a longer USB plug) as you should really be doing that anyway if your Synology only has USB 3.0 ports (as connecting to a USB 3.0 port without going through USB 2.0 hub can cause serious interference to Zigbee and Thread as well as Bluetooth radios, while connecting via a USB 2.0 hub will practically convert one USB 3.0 port into many USB 2.0 ports which do not have the same issue with interference).

Regardless, read and follow → Guide for Zigbee interference avoidance and network range/coverage optimization

Thank you for the suggestion to check if the USB is plugged in… the fact that you guys told me twice that it should work without any additional steps isn’t helping me.

I made this post because it’s NOT plug and play and it DOESN’T work for me the way you guys keep describing.

Don’t take offence, I was only trying to help by clarifying that it is for a fact a know design fault causing some USB adapter’s plugs not to get a proper data connection due to poor design of some computer enclosure/chassis/casing around the USB ports, then that is the case it does not matter if you unplug and replug the adapter as it can not mechanically reach to connect.

Anyway, maybe your SkyConnect USB dongle is simply just broken.

Just to try to rule that out you should be able to troubleshoot and verify if the SkyConnect USB dongle is broken or not if you plug it into a Windows computer after installing Silicon Labs CP210x USB to UART Bridge VCP Drivers → CP210x USB to UART Bridge VCP Drivers - Silicon Labs

You can then install Python for Windows to then as an example zigpy-cli and/or bellows CLI to test running a few commands (like example “Performing an energy scan” with zigpy-cli which does not make any changes but do test the radio).

Another more advanced tool you could try useing is sniff Zigbee traffic with Wireshark via ember/ezsp:

Just to also verify, you are using provided extension cable with it?

Sorry for my offenciveness in my previous post.

I feeel soo freaking stupid…

you were sort of right… I have a cupboard where all my electrical is located and i’ve also placed my routing/switching and my Synology servers

I’ve never noticed until now that i plugged the USB in the wrong Synology NAS… I’m so sorry for this. this was stupid of me. Thank you all for the time and effort you guys put in the messages, now I can finally start with building my Zigbee network.

kind regard,