Slow automation of 4+ Z wave devices

I setup a scene so when i press down 3x any of my switches it does 4 things:

  1. Turn on kitchen sink light
  2. Turn off kitchen table light
  3. Turn off kicthen overhead light
  4. Turn off living room overhead light

All 4 of these dumb lights are connected to inovelli red series dimmers. All switches and my computer running HA are in the same open air room.

Running this scene it can take anywhere from 4 seconds to 15 seconds to complete. If I take out any one of the 4 things, it seems to go quicker.

Is this timeframe just par for the course? As you begin adding more things it takes exponentially longer? Or is there something i can be looking into?

This is the reason I ditched zwave in favour of wifi. I found it to be incredibly slow despite having a well meshed network.

Others seem to have better performance. Never worked out why.

Hmmmm. And when I was researching it was all, “don’t go wifi cause your gonna have 30 things in your house using the wifi and then when you try to stream or use internet you may have problems”

I don’t get it, 2 wave devices is pretty consistent, 2nd one turns off maybe 1 sec after first.

3 devices still pretty repeatable.

4 devices totally hit and miss. I tried turning off each on as an individual node in node red. Tried listing them all in one node; doesn’t seem to make difference.

You do need a multiple wireless access point system. Using an all in one router, modem, wifi access point will not get you far.

I’ve got 4 Ubiqiti wireless access points and over 100 wifi iot devices, super fast and reliable.

Sorry I couldn’t help with your zwave issues.

This is obviously not a general problem with zwave. If it was, zwave would be completely useless. I have around 40 zwave devices at this point and everything is pretty much instant. My zwave network has changed quite a bit over time and I never experienced any kind of issues with it. Others have considerably larger meshes and don’t experience problems like this either. Blindly switching to Wifi, which comes with its own set of issues, wouldn’t be very smart.

You need to go into the logs and see what goes wrong. With extreme delays like that, it shouldn’t be too hard to see where things start messing up by looking at the timestamps.

My experience is the exact opposite. It’s impossible to generalize things like this, as they depend so much on the individual setup. Device compliance, high vs not-so-high quality components, RF signal strength, wave propagation patterns within your house (zwave and wifi use different frequencies that behave very differently depending on the building materials used in your home) and so many more. Dismissing a technology just because it doesn’t work for you is never good advice.

But regardless of all this, the kind of delays the OP is getting are just outside of anything normal. There’s clearly an issue somewhere.

Not in my experience.

I’m glad zwave works for you but it is far too expensive and unreliable for me.

Are you really saying that a reaction time of 4 to 15 seconds is considered normal ? Let’s be a little realistic here shall we. I get it that you don’t necessarily like and / or have good experiences with zwave and prefer wifi. Fair enough. But if such delays were normal, do you really think that zwave would have had even the slightest chance on this competitive market, not even talking about the thousands of devices available using the protocol ? Rhetorical question, considering it’s one of the leading low power home automation connection layers out there.

If you get delays like this with any protocol or physical layer, then something is seriously wrong with your setup.

Have you tried watching your OZW_Log.txt while you operate your z-wave devices?

I too am slowly working through all my zwave stuff and replacing it with wifi. While not on the same level as described by the op, my zwave switches lag way behind my wifi switches running esphome. I have esphome based motion sensors all over my home, the the rooms that are most responsive and almost instant are the ones with esp to esp.

1 Like

Just an idea here. I never used scenes, but did you try to set these lights in a script ? Not sure if that would make a difference, but it’s maybe worth a try. You can then also follow each service call in the logs and see if there is something abnormal there. Also, are you using the builtin OZW or the new ‘experimental’ 1.6 component ?

As a real world reference here, I just did some timing here on my system. I have a script that does something very similar to what your scene does. I have 5 Qubino ZMNHJD modules (they’re for heating control, but essentially operate like dimmers from the point of view of HA) that are set to a certain light level, one after the other in a script. I just call the light.turn_on service 5 times in a row. Really basic stuff. All the modules turn to the requested mode pretty much instantly as I push the button, there is no visible delay.

This is on a Raspberry Pi with an Aeotec Gen5 Z Stick and the builtin OZW 1.4 integration.

1 Like

Yeah I wish someone had warned me about the issues with zwave before I spent a stupid amount of money on it. This is one case where quality was not proportional to price.

The funniest/saddest part for me is that I’ve been getting loads of free Treatlife (tuya based) hardware in exchange for Amazon reviews. What I’ve had to actually buy, I scored for like $2-$3 a switch on eBay. The hardware quality is just as good as all my other stuff, and all of them can be flashed with esphome. I was paying like $30 a dimmer before and now I’m finding them for under $5. On top of all of that is the fact that they respond almost instantly every time. Esphome is just so rock solid.

1 Like

My zwave network has been more reliable then the wifi switches I have in my house. I’ll admit that a year ago, that wasnt the case, but basically since late summer, it’s been rock solid and instant.

Yeah a lot of work has been put into making zwave more reliable since I abandoned it. Not sure if it’s still an issue but does your network still have to re-initialise whenever you restart home assistant?

Nah it doesn’t have to anymore since it runs in it’s own separate container. However, it does the first time, or if the host system is rebooted.

1 Like

Well that sounds a lot better for a start.

Alright so its much better but I am not sure why as I changed a lot of things:

  1. Switched to AOTEC Z hub
  2. Because I switched to AOTEC, I pretty much started over
  3. ONLY added the 4 switches I am trying to scene control
  4. Switched to OpenZWave beta integration
  5. Did a network heal after adding the 4 switches (I dont know if this is necessary or not)

Now the 3 lights turn off and 1 light turns on all within 2 seconds. It will be interesting to see if this remains true as I add the other ~15ish Z wave switches.

Spoke too soon, its slow again. And I see some errors in my log. I did a lot of adding and removing, so after I got the errors you see for node 60 in the pictures below, i started on clean slate again and just added all my nodes back. But issue still remains.

I am going to try having node red call a HA script, as @HeyImAlex suggested, as opposed to having node red itself turn the switches off/on.

And those “expected response” received is not unique to a certain switch or even a certain z wave stick as I’ve now had it happen on Nortek and AEOTEC sticks

I dont get it, i just dont get it.


What are you running HA on ? While I don’t use it myself, people have reported bad performance of Node Red on lower powered platforms like the Pi, especially with an SD card.

I would try the script thing, if only to rule out NR being responsible. Can’t help with the timeout error, I’m not too familiar with the low level implementation details of the zwave protocol. I’m sure someone with more knowledge about that will be able to tell you what that error means.

Running HA on virtual Linux machine that resides on Windows 10 computer.

No other issue with HA aside from this z wave stuff.