SMA Solar Integration - Sunnyboy Inverter

Does the SMA Solar Integration work with the SMA Sunnyboy Inverter? If so how did you get it to work?

TIA, Jeff

Yes it does.

It requires that your Inverter is connected to your network, either via wifi or Ethernet. You should also reserve it a static IP address in your router’s DHCP server.

Then just follow the documented configuration:

https://www.home-assistant.io/integrations/sma/#configuration

Thanks for your help.

I just had to get the user password from the installer.

Now what does everyone do with that information? Trying to come up with some idea as how to use it and not just display it.

If I’m producing a lot of extra solar power and it is either hot or cold inside I turn my reverse cycle heat pump on.

Good idea!

Now is there anybody else out there that does something with their solar integration?

New user here. Trying to add my SMA SunnyBoy 5.0 to HA.
I enter the IP address as Host and my password for user or installer
I’ve unchecked SSL since this older device doesn’t have SSL.
I get error “Invalid Authentication”

From memory you do need to use SSL but you need it to not verify the certificate (the other option).

Have the exact same issue - Did you solve it and able to integrate your SMA SB 5.0 in HA ?
Still unsuccessfull from my side …
Many thanks,

It’s been a while but for the records: Some SMA inverters neither have a web frontend to connect to, nor do they communicate modbus TCP or Speedwire (over Multicast). An example is the Sunny Boy 4000 (With green LC Display). These inverters cannot be integrated with the nice and stable SMA SOLAR integration provided by @emontnemery as those inverters are lacking a web server to poll. If your inverter is configured with the SUNNY EXPLORER application (as an idicator of legacy) you may need to use a physical RTU connection to ingest the legacy YASDI formatted data. See instructions here:
https://community.home-assistant.io/t/best-way-to-connect-sma-sb-4000tl-20-to-ha/390754

Does anybody know if this (or any other) integration will work with an SMA Windy Boy (5000) over RS485. The RS485 we can use as a virtual com port over IP if that helps.
RS485 is the only data comms mechanism available.
Another option might be an ESP8266 directly on the Windy Boy interface to MQTT but I can’t seem to find any information on the pinouts either.
Thank you in advance.

Chiming in…
I have a Sunny Tripower 5000TL-20 … I don’t seem to be able to connect via the integration… message is always can’t connect… I tried with Cert, no Cert, User, Installer :frowning: :frowning:

Do I have to change any config parameter in the system?

I can read and receive data through the web access to www.sunnyportal.com… i.e. the access to my plant Web Interface

Any Hints?

PS: I can’t access the system though by entering the ip address directly in a browser… :slight_smile: e.g. 111.222.333.444 brings no connection (time out)

Good to read that I’m not alone. Same problem here.
I have Sunny Boy 5000TL-21 at which I attached a webconnect/speedwire module with ethernet.
I can ping the device, I can use it via Sunny Explorer and Sunny Portal, but it is refused with the Hass SMA addon and I can’t approach it directly via the browser either: connection time out.
It’s a mystery to me what it is I’m doing wrong or forgot to enable. The SMA documentation isn’t helpfull either.

So, I moved over to SBFspot over bluetooth. That works fine, but that feels silly when there’s a ethernet connection available. Besides, SBFspot requires HAOS-SBspot, MariaDB, Mosquitto MQTT broker, and phpMyAdmin. A lot of overhead, I think.

However, if anyone has a good idea to get the SMA add-on working, you would earn my gratitude!

Now I am in an even worse situation :frowning: :frowning:
I finally got someone to lend a windows pc (have only Macs) and installed Sunny Explorer.
Activated Modbus - because seemed the only way…
And now the inverter is in NIRVANA ini 192.1168.0.XXX… so no tool can reach it???

I read that Config Assist van help but where the hell is the tool? no where can I find it?

Any hints PLEASE??

Same situation over here…
I have acces to the info via the SMA energy IOS app, i got data in the homewizard- P1 meter app, I can acces it via the web portal
but Home Assistant doesn’t work…
I have the IP and tried to acces it with a browser → no connection
When I use the windows app sunny explorer it can connect with that same ip address.

Anyone has a solution?

You must use the installer password. Hopefully they will give you their password

No, you don’t have to use the installer password! Select ‘User’.
It was a bit of a struggle for me too, but this is what you have to do.
At host just give the ip addres, no http or https.
Select use SSL certificate, unselect Verify SSL certificate.
Group, select user. Then give your user password.

My problem was that I was unsure about my user password so I created a new one. For this you have to open a web browser and go to the inverters IP address. Select user and then forget password. Now you have to input your WPA2-PSK, this can be found on the sidepanel of your inverter.
Type this in and give a new password. After this, use this password for you integration. For me it worked. I have a SB3.0-1AV-41 manufacture 2020-11-27

1 Like

This did it for me, thank you!

“At host just give the ip addres, no http or https.
Select use SSL certificate, unselect Verify SSL certificate.
Group, select user. Then give your user password.”