Smart Meter Texas stops working

Is anyone else having problems with smart meter Texas integration released on 0.115.0 ? I never knew this was even possible until I saw the release announcement, so I jumped on it right away (ty devs) !

I followed the directions, created my account, and then configured the home-assistant integration via the web UI. It seemed to go well.

However, after a few hours, I noticed the sensor started changing to ‘Unavailable’ and no data was coming through.

It’s been a few days, and it continues to do the same thing. It works for a few hours, and then it stops working.

This is what I see on the log

Logger: homeassistant.config_entries
Source: components/smart_meter_texas/
First occurred: 10:34:29 AM (1 occurrences)
Last logged: 10:34:29 AM

Error setting up entry removed_username for smart_meter_texas
Traceback (most recent call last):
  File "/home/haos/devel/haos/virtualenv/lib/python3.7/site-packages/homeassistant/", line 228, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/home/haos/devel/haos/virtualenv/lib/python3.7/site-packages/homeassistant/components/smart_meter_texas/", line 50, in async_setup_entry
    await smart_meter_texas_data.client.authenticate()
  File "/home/haos/devel/haos/virtualenv/lib/python3.7/site-packages/smart_meter_texas/", line 166, in authenticate
    json_response = await resp.json()
  File "/home/haos/devel/haos/virtualenv/lib/python3.7/site-packages/aiohttp/", line 1031, in json
aiohttp.client_exceptions.ContentTypeError: 0, message='Attempt to decode JSON with unexpected mimetype: text/html', url=URL('')

My install info

arch	armv7l
dev	false
docker	false
hassio	false
installation_type	Home Assistant Core
os_name	Linux
os_version	5.4.51-v7+
python_version	3.7.3
timezone	America/Chicago
version	0.115.0
virtualenv	true

Any help is appreciated.


1 Like

Yes, it’s an open issue. You can watch/subscribe to if you want to know when it’s fixed. BTW, please don’t add “me too” comments to the issue without providing additional information that isn’t already there.

Duly noted. Thanks

For those that just want something that works, try:

It requires Node Red, but it has been EXTREMELY reliable.

1 Like

I just finished configuring and installing. I’m not too familiar with node-red, but I can’t make it show me any log of what its doing, debug all nodes is blank, home-assistant.log shows nothing. Only feedback I have so far “MQTT send reading” node is connected. all my sensors are there with value 0 and 1 sensor unknown.
does it take time for some data to start appearing?


My old python setup for this had been rock solid, but stopped working recently after the winter storm that hit TX last week, so I’m not sure if there is any connection between the 2 events, but the timing sure feels right for it.

I decided to test the Node Red solution, and I get the same results. Looks like the same connection reset error is being reported by both the Node Red and the pysmtreader solutions.

I’m wondering if anyone is having any success with this these days.

There’s an issue on Smart Meter Texas’ side due to all of the power outages. It’ll probably take them some time to get things back up and running for their API.

My integration stopped working as well - does anyone has any updates from SMT ?

This has never been really all that reliable, but it seems to be working as usual now.

I tried to add the integration today - and it work - so I am getting only the electric meter counter and I think in 1 hour intervals. Lets hope the integration stays alive - as @M0E-lnx said - it is not that reliable and I do agree 100%.

Tried adding the integration today, but it just kicks back saying that it “Failed to connect”.


This is working fine for me now. This of course means I’ve come to terms with its limitations, so every now and again, it flickers on and off, but since I’m only interested in tracking Daily and Monthly energy usage, those smaller blips are not a big deal to me.

Yes, I’d love to get to this level of tracing. I’ll keep trying to add the integration… We’ll see if anything magically changes. Seams to me this is probably on SMT’s side, rather than HA.

Do you see anything of interest in the logs?
I run pysmtreader on a separate docker container which gives me more isolation and access to the logs.

I can check when the connection fails for example, and I can see the debugging output indicating why it may fail.

Honestly I’m not very log-savvy.

I’m getting the same error: “Failed to Connect” in July 2021.
If someone can tell a newbie where to find the logs, I’ll post it!

1 Like

I just noticed mine was also failing to connect. Had left it unattended for a long time, and just noticed the docker container was no longer resolving names for some reason. That was a quick fix on my end, but as far as I can tell it’s working on their end.

Any updates with this integration? Is this something that could be used to feed the new energy dashboard in HA?

I think I finally got this to a useable stage with SMT. Here are my notes on what it took. TLDR

As previous users have said: I tried the integration today, the account login credentials work perfectly on but when I put them into the username and password in the HA Integration it says “failed to connect”.

There is nothing in the log file to troubleshoot.