SmartIR - Control your Climate, TV and Fan devices via IR/RF controllers


#124

Yes, me. :slight_smile: Do you own a device? Because I’m waiting mine.


#125

In the upcoming HA version (0.89) there is a breaking change in the climate platform. SmartIR needs to be updated to work properly.

There is already a fix in the SmartIR rc branch that works with HA 0.89 beta versions.


#126

I am trying to migrate my automations from sending Broadlink commands directly, but I am struggling with how to trigger this module from automations. Can someone please give me a hint on how to do this? Example code would be awesome. Thanks!


#127

migrated successfully, too. any hint how to expose a simple on/off switch to homekit? :slight_smile:


#128

Does anything else need to get done? I can’t get the climate component working again,

2019-03-07 19:09:01 ERROR (SyncWorker_19) [homeassistant.loader] Error loading custom_components.smartir.climate. Make sure all dependencies are installed
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/loader.py", line 166, in _load_file
    module = importlib.import_module(path)
  File "/usr/local/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/home/homeassistant/.homeassistant/custom_components/smartir/climate.py", line 20, in <module>
    from . import COMPONENT_ABS_DIR, Helper
ImportError: cannot import name 'COMPONENT_ABS_DIR' from 'custom_components.smartir' (/home/homeassistant/.homeassistant/custom_components/smartir/__init__.py)
2019-03-07 19:09:01 ERROR (SyncWorker_19) [homeassistant.loader] Unable to find platform smartir. Search path was limited to path of component: custom_components
2019-03-07 19:09:03 ERROR (SyncWorker_19) [homeassistant.loader] Error loading custom_components.sharp_aquos. Make sure all dependencies are installed


#129

Please open an issue on GitHub


#130

New issue submitted


#131

Links with platform instructions are dead for me


#132

Hi

just updated to 0.89 and I’m getting this error

And this is my config

  - platform: smartir
    name: "AC sala"
    device_code: 1400
    controller_send_service: switch.broadlink_send_packet_192_168_1_56
    temperature_sensor: sensor.temp_sala_xiaomi
    humidity_sensor: sensor.temphum_sala_3

both sensors have valid data

33

I have 3 climate smartir and all of them does not show the Humidity value

Any suggestion?

Thanks


#133

On Hass.io 0.89.0 I get:


and

EDIT:

I didn’t have controller.py - I added it to the custom_components folder and my problem is now solved.


#134

Please open an issue on GitHub


#135

Hello can anyone tell me how to contribute my climate .json file? i have made one for beko air-conditioning machines and wondered if it would like to be added to the list for everyone else.


#136

I submitted mine as an issue on github and @Vassilis took care of adding my json file.


#137

Its strange - I had that issue on my phone but desktop worked


#138

Confirm. Works from desktop. That is strange but I am fine :slight_smile:


#139

Just in case anyone is a little unsure about how to convert the power sensors for dumb devices using smart plugs (I use xiaomi) on the old config, here’s something that works for me:

old:

fan:
  - platform: broadlink
    name: Living Room Fan
    host: !secret broadlink_pro_ip
    mac: !secret broadlink_pro_mac
    rfcodes_ini: 'broadlink_fan_codes/living_room_fan.ini'
    default_speed: low
    customize:
        speeds:
            - low
    power_consumption_entity: switch.plug_xxxxxxxxxxx
    power_consumption_threshold: 10

new:

binary_sensor:      
  - platform: template
    sensors:
      living_room_fan_power:
        friendly_name: "Living Room Fan Power"
        value_template: >-
          {{ states.switch.plug_xxxxxxx.attributes.load_power|float > 10 }}  

fan:
  - platform: smartir
    name: Living Room Fan
    unique_id: living_room_fan
    device_code: 1030
    controller_send_service: switch.broadlink_send_packet_IPADDRESS
    power_sensor: binary_sensor.living_room_fan_power

#140

@Vassilis

I have a new error message after updating your component: (running 88.2)

The device JSON file is invalid
1:16 PM custom_components/smartir/media_player.py (ERROR)

it all seems to work fine, just a new error. Perhaps you’re aware. No other information given


#141

dear
After upgrading to 0.89.1 i am unable to get smartir working as my
platform: switch.broadlink is not found.
can somebody please help.
I do still have the old vpnmaster custom_components/broadlink/climate.py,fan.py,media_player.py as my custom components, but none are working now.
Please guide.
thanks


#142

@kirpat are the custom components installed in the right folder from the readme


#143

Yes, this the new installation mode for custom_components.