Smartthings nightmare

I had Smartthings integration setup with HA for almost a whole month and never had any trouble with it. I wanted to be prepared to for my SD card going bad and I tested out restoring from a snapshot to a new SD card that was recently flashed with HassOS. I got that to work except I was going to have to reinstall ecobee so I put the original SD card back. Everything went back to normal except Smartthings. I have no idea if it had anything to do with me using a different SD card with a restoral. I wouldn’t think it would matter but it seems it is possible. Maybe having Pihole running as a DNS server on HA had something to do with it.

Anyway, I had even checked the Homeassistant setup in the Smartthings and Smartthings Classic Apps on my phone and both had network problems. I then deleted Smarthings integration from HA and I also deleted the tokens from and I deleted HA from Smartthings on my phone.

I tried the Smartthings integration again and after I get a new token and place it into HA it asks me to add HA to the Smartthings app which I attempted to do in Smartthings Classic but I get an error

Something went wrong. Please try to install the app again

or something very similar.

Is there something that I could be missing? Everything else on my network and on my phone and Smartthings work normal. Was it a coincidence and there is something on the Samsung side that is not allowing for HA to be added as an app? I even tried using Home Assistant via NabuCasa which I have as a trial version but I get the same error message with it.

I’ve tried doing this after a restart of HA with Pi Hole and Nginx disabled. No change. Pi Hole is what caused the problem for in the Smartthings Integration Broken thread.

When I first installed the Smartthings integration I never saved the API token so I deleted the token in one of the attempts to reinstall the Smartthings integration. Therefore, I don’t think that I can use the hass-smartthings-remove python tool to remove all traces. I tried it anyway. I downloaded the Windows version of Python 3.8, which supposedly already had PIP, and ran

pip install hass_smartthings_remove

I get

SyntaxError: invalid syntax

Am I missing something?

The Smartthings file in /.storage only has

"cloudhook_url": ""key"
"instance_id": "key"
"webhook_id": "key"

The instance id key has a format similar to the API token created on the Smartthings API token site Should I use that key/token after getting Python to take pip install hass_smartthings_remove ?

Since I have trouble with python, python3, pip, pip3 and curl on my Ubuntu machine and in Windows 10 I tried a fresh install of Oracle VM VirtualBox and Ubuntu on my Windows 10 machine. I then installed python, python3, pip, and pip3.

Then I ran

pip install hass_smartthings_remove

but I got

No matching distribution found for aiohttp==3.5.4 (from hass_smartthings_remove)

So I tried

pip3 install hass_smartthings_remove

which completed without errors. Then I tried

hass_smartthings_remove xxxx-xxxx-xxxx-xxxx-xxxxx

but I get

hass_smartthings_remove: command not found

What do I need to change with Python, Python3, pip, or pip3 in my Ubuntu setup to be able to use hass_smartthings_remove?

I finally got the following to work on Ubuntu thanks to the comment at

hass_smartthings_remove xxxx-xxxx-xxxx-xxxx-xxxxx

I had to use a recent token that I had created at

That took out all instances of Home Assistant under My Apps in Smartthings Classic.

I still can’t get regular Home Assistant to show in My Apps in Smartthings Classic when I add an existing or even a new token in Smartthings API. If I used the Nabu Casa choice I get the error that

Something went wrong. Please try to install the SmartApp again. 

Finally got Home Assistant in My Apps in Smartthings Classic although with Nabu Casa which I won’t be buying since I don’t see a need for it. That is if I don’t have a problem with Smartthings after the Nabu Casa trial expires or, if I do have a problem, that I can get the zigbee sensors to work with a Go Control HUSBZB-1 USB Hub

This is what I did to get it to work after battling with Python -

I ran hass_smartthings_remove again and verified that nothing showed up in My Apps in Smartthings Classic then I stopped HA. Then I went into the HA config folder through Samba and deleted the smartthings file under /.storage then I deleted the Smartthings API tokens. Then I powered down and powered up the RPI4 then went to Integrations and searched for Smartthings then got a new token in the Smartthings API then added it to HA then went to MyApps in Smartthings Classic and added the only available instance of Home Assistant which is via Nabu Casa.

1 Like

OMG I’m struggling with the exact same thing. I’m on a RaspberryPI though and those comments aren’t working for me. I even found what looks like the bin for hass_smartthings_remove and still can’t seem to run it. This issue is trying my patience.

Even though I got that to work there were a few times when Smartthings wasn’t available due to Smartthings server issues so I decided to go with a Nortek Go Gontrol HUSBZB-1 and the zigbee integration in Home Assistant. All of the Smartthings sensors were recognized when following the process to add them. I like it much better. I had to get used to automations through Home Assistant, as opposed to the Smartthings app, but I got everything working fine.

Also try and get an SSD card and use the 64bit HassOS 5.2 if on an RPi4 so you don’t ever have problems due to the SD card failing.