Smoke Sensor Heiman HS1SA Zigbee Control/Configuration settings

I bought Smart Mini Smoke Sensor Heiman HS1SA for testing with Home Assistant before apply the same for all rooms.

http://www.heimantech.com/product/index.php?type=detail&id=3

This product has smoke detector and Siren together.
I have integrate it with ZHA and it is connected fine

image

There is a control entity which I assume when enabled it will turn ON the siren. but it is not working i am not sure why.

image

also there are few configuration parameters’ which can be set through ZHA but they are not making any difference when I change them. they seems to working between ZHA and the device

image

I have tried to make a test smoke, the siren start the sound. also I get notification “Detected” on the entity. but I tried to mute the sound through the configuration option and it is not working.

image

anyone have idea why the configuration options and control entities not working between ZHA and the device.

1 Like

If a device does not follow Zigbee specs then need a “quirk” in ZHA Device Handlers (a.k.a. zha-quirks):

https://www.home-assistant.io/integrations/zha#zha-exception-and-deviation-handling

If there is not already an existing request for it then submit a new “Device support request” for it here:

https://github.com/zigpy/zha-device-handlers/issues

Be sure to fill provide all the information requested as well as additional info or links about the device.

https://github.com/zigpy/zha-device-handlers

Thanks for reply
Does ZHA support sending “set commands” to the device using zigbee protocol?

How about zigbee2mqtt ?

By default the ZHA integration currently really just exposes device configuration attributes, however the developers are usually open to constructive suggestions and requests, see example discussion here:

https://github.com/zigpy/zigpy/discussions/934

For using advanced Zigbee command you can utilize “ZHA Toolkit” (Zigbee Home Assistant Toolkit):

https://github.com/mdeweerd/zha-toolkit

ZHA Toolkit by @le_top provide both low-evel and high-level Zigbee commands through ZHA via zigpy:

https://community.home-assistant.io/t/zha-toolkit-toolkit-providing-low-and-high-level-zigbee-commands-through-zha-zigpy/373346

Again, still need ZHA to have ZHA Device Handler for the device in ZHA Device Handlers (zha-quirks):

https://github.com/zigpy/zha-device-handlers

FYI, he posted this relative information in another thread:

https://community.home-assistant.io/t/help-understanding-zha-quirks/411253/15

Hi Yousuf, did you find any solution to this?
I have exactly the same. The warning device does nothing really, just ornamental.

You apparently found the automatically closed github topic for the HS1AS-E https://github.com/zigpy/zha-device-handlers/issues/518 .

I can see that in principle the smoke detection is functionally present, but at the same time it is not reported to be functional.

This may be because (re)configuration is not successful for the device which is often because the device is sleepy. I do not know if pushing the button makes the detector wake up and communicate, but if it does, it is usefull to repeatedly push it during the (re)configuration process.

The configuration process is important to tell the device that it should report states to the coordinator (home assistant) which is what the bindings are for.

There are other ways to setup and check the bindings (zha-toolkit/bind_ieee, (zha-toolkit/binds_get)[https://github.com/zigpy/zha-device-handlers/issues/518#issuecomment-872616884] but that is more involved. You could at least check the bindings are there using binds_get.

Further, the alert state is often temporary: the device will report smoke detection and just after that notify the the alert is cleared. So you may just see the state change for a short time which means that the logbook may be more readable than the history (graph).

1 Like

Thanks you @le_top. Do you know what the state of the “ias_WD” should be?
Am I supposed to turn this ON or OFF? It doesn’t do anything when I turn it on but does it mean that the alarm will not sound or not be transmitted to home assistant if there is a fire? There doesn’t seem to be any any info on this. Thank you!

IMHO the control is only there so that you can clear the alarm.

Ideally the detector would position the alarm and leave it active until cleared. There is the “clear” button and I guess that switching it off does the same.

When you trigger the alarm, does it notify HA now?

I have not managed to trigger an actual alarm yet.
When I press the big test button on the right of the device, the device does sound the alarm but home assistant does not show this in any way. The smoke sensor itself in the device in home assistant remains in “clear”, never changes state. But I am not sure if it’s supposed to change stage. I guess, I would have to test this with real smoke?

Normally the test button triggers the alarm, but it then also disappears in my experience.

I would check the bindings as indicated.

Yes! It works now.
I had to delete the device and pair it again. Now the test button does trigger the smoke sensor in home assistant and it works fine! Notifications work too! Thanks for the help!

Hi, just wanted to second this, it suddenly started working after deleting and repairing it several times!

@oneiropagides @eskillx That’s good to know, since I’m considering buying one as well.
Could you please summarize how you got it working ? Any changes to home-assistant / zha needed ?