SolarEdge - New Top Level entry - Missing connections in power flow data

Since the update to 0.99 I am having a lot of errors for SolarEdge.
It seems there are some connections missing in the power flow data.
I have this error about 40 times over night.

Anyone else seeing same behaviour? am I missing something (apart from the connections :slight_smile: )

From 0.99 changelog :

SolarEdge - Monitored conditions are no longer supported
Remove solaredge_local duplicate code

Thank you for the reply. I already did that, I removed the monitored conditions and moved it to the configuration.yaml. Since then I have the problem.

my solaredge sensors are no longer giving me readings either

> - platform: solaredge
>     api_key: !secret solaredge_api_key
>     site_id: !secret solaredge_site_id
>     monitored_conditions:
>       - current_power
>       - energy_today

In the 0.99 breaking changes it says

SolarEdge - Monitored conditions are no longer supported. - (@Cereal2nd - #26282 ) (solaredge docs )

What does that mean (monitored conditions?), no more solaredge sensors?

You should remove the platform from your sensors.yaml and move it to configuration.yaml.
But like this:

  api_key: !secret api_key_solar_edge
  site_id: !secret client_id_solar_edge

So without the monitored coniditions part. You will automatically receive all possible conditions.


got it thanks, all working now.
Guess we need to update the component documentation


I’m very new and this is my first post in the community.

Since the update to 0.100.2 i am having the same error. It looks like the api works fine cause i get updatet data from solaredge, but in de logging i have a lot of errors with the message:

Log Details (ERROR)

Tue Oct 15 2019 10:15:55 GMT+0200 (Midden-Europese zomertijd)

Missing connections in power flow data.

I have the following in my configuration.yaml:

#Solaredge Intergration
  api_key: !secret solaredge_api_key
  site_id: !secret solaredge_site_id

Before the update i never saw this error. that anyone know where this is comming from?

I am very happy I am not the only one having this issue. (Unfortunately for you of course)
For now no one seems to have a solution.

When I get home I will open an issue on github so they can look at it.

1 Like

What’s the issue number?

I’m having the same behaviour since updating to 0.100.2 and updating my SolarEdge configuration.

The error doesn’t say a lot and the SE documentation does not speak about it either.

Hey Skye

I posted the issue today, (sorry for the delay).
The number is #27959

I tired the suggestion below still no luck since upgrading.

I just added SolarEdge to my HA today and…I am getting the same type of errors. Out of curiosity, what do you all get when you manually hit the API via this link (with your site id and API filled in of course)

My page is quite sparse, but I don’t have a frame of reference.

{"overview":{"lastUpdateTime":"2019-11-19 12:02:29","lifeTimeData":{"energy":7239217.0},"lastYearData":{"energy":6322373.0},"lastMonthData":{"energy":224391.0},"lastDayData":{"energy":0.0},"currentPower":{"power":0.0},"measuredBy":"METER"}}

You could try and reverse engineer the Android app, you get a lot more data (per panel voltage, temperature, amperage etc).

I’m looking at the Android app and I don’t see the per panel voltage, temperature, amperage data. Mind pointing me in the right direction within the app?

On the view where you see your panels, click on a panel and you should be able to see all the panel’s information:

Hm, we’ve got different apps, I do not have that screen. Are you in the US?

Here is what my app looks like:

I’m in Europe, the screenshot you show is the default screen I get as well, but it seems you don’t have the detailed tab. Perhaps your installer didn’t enable it for you. You could show them my screenshot and ask for it.

Do you have power optimizers for each panel? If not, maybe that’s the reason? The data comes from those devices I assume.

Sorry, I missed your response for some reason.

This is my fathers system, so I don’t know much about it (or solar in general!). I looked up the optimizers, and I don’t think he has them so that must be it - thanks!

If you have SolarEdge, you definitely have power optimizers. They don’t produce any system without.