[Solved] Hass.io slows down or stops internet access over wifi

Ho guys. For couple o days I have a big issue. When I start HA on my Raspberry Pi 3 my internet speed over wifi dramatically drops. sometimes even goes to 0 upload / download and I need to reset router. When I connect to HA - changing configuration.yaml or something is very slow. I’ve discovered that this is 100% hassio problem. My rpi ip adress is set to static and no other devices connect to this address. Does anyone face this problem before? I will check the sd card speed later on - maybe this is the case? Hassio was running withouy problem for 2 months only

I had a problem occur where my internet access stopped. I looked on the router and the hassio IP was maxing out my connections limit. There were about 4000 connections to Google servers all bring denied. I restarted and it resolved it.

Do you use Google assistant or the assistant webserver add-ons?

No - I only test Hassio - I’ve connected Arduino on mySensors (1 relay, reed swiitch, motion sensor) only. But Arduino is not the issue because HA runs slow even when I run HA without Ardiuno… I’ve checked my SD Card and it works fine so there is another issue. My log shows no error also… How to check connections over router?

Depends on the router, there is an option in the firmware to view the number of active connections on some or they can have a status for percentage of max connections allowed. In my case after I rebooted hassio the issue resolved and didn’t come back.

Do you use nmap in home assistant?

No no nmap. The problem is that everything worked well for couple of months. I didnt change anything since then - only upgrades

I think I found the problem(s). I made some changes in configuration.yaml

  1. Removed bluetooth_tracker (probably slows down hassio)
  2. Changed my wake_on_lan function for RPC Shutdown (reason: my IP address changed when I reboot router and hassio trying to check out my old ip. Now I make my PC IP static):


  • platform: wake_on_lan
    title: PC / Laptop
    mac_address: “XX:XX:XX:XX:XX:XX”
    name: BRO-PRACA
    friendly_name: Urządzenia
    icon: mdi:airplay
    host: XXXX.XXX.X.XXX
    service: hassio.addon_stdin
    addon: core_rpc_shutdown
    input: BRO-PRACA

Seems that Hassio is running ok now and I have no lack of wifi performance… Maybe this issue helps someone in the future…

I noticed the my internet access stops or slows down too with “bluetooth_tracker”. If I remove it, it returns to work well… @Michal_Nowakowski Did you find a solution for that?

@ marcomelilli No I don’t (it was just for testing purposes) :frowning: I’ve disabled this tracker for now… If someone find solution for that please give us feedback…