Solved: Help stop tradfri zigbee remote directly controlling a xiaomi plug (unbinding?)

Hoping for some Zigbee/ZHA guru help

I have acquired a conbeeII stick and am starting to migrate some devices to the new network from my Xiaomi & Ikea Zigbee networks.

I am using the baked in Zigbee (ZHA) integration in Homeassistant. Running Homeassistant container in docker on my NAS. Homeassistant V114.4 (had same behaviour in v113). Added zigbee devices have applied appropriate quirks and are identified in the integration.

I have added an Ikea 5 way remote (E1810) and a xiaomi lumi plug (ZNCZ02LM) to the ZHA network and now any time I press the toggle button on the remote, my plug will toggle. I do not want this behaviour and have not done anything to select it (to my knowledge).

I am assuming this is in the direct Zigbee worked using the magic of groups and/or clusters.

Any tips on how to diagnose and adjust this behavior on the native Zigbee network?

edit: I have attempted to unbind the remotes from the device integration page: manage clusters → device binding and selected the power plugs and hit unbind … seems to not change the behavior. Again - any advice?


1 Like

Check for any ZHA groups and group binding as well!

Thanks - I have looked and the remote does not appear as a member of any binding groups.

I think the issue is that unbinding from the integration page for ZHA is not working.

Will check logs

Double check the plugs too – I believe IKEA remotes by default use group signalling – most likely the group the remotes have picked has your Xiaomi plug in it.

THanks for the suggestion

Is there a recommended way to diagnose?

Can I simply look at the zigbee signiature, or do I have to step through the clusters for bindings and groups (which I have been doing)

Any suggestions or pointers to resources gratefully accepted


Just go Config > Integrations > ZHA => Config > Groups and look for any existing ZHA groups – double check them to see if your Xiaomi plugs are listed.

1 Like

Many thanks @walt, that put me onto it!

I found 5 groups in my zigbee group config (none of which I made) - one of them (the first … 0x0000) had the xiaomi plugs “LUMI.PLUG” as members of that group.

I removed them and now have the intended behavior.

So, it appears that tradfri remotes send group commands to group 0x0000, or the first group they find by default!

I now have 2 ikea remotes that only do what I want them too - :+1:


Hey Guys,
Sorry to bring up an old thread, I am having this issue also, when looking at groups, there are no groups showing, any other ideas on how to solve this?

Does anyone know how to solve that in ZHA? I did all like phileepPhil wrote.

This is true that if I remove my switch (ZNCZ02LM) from group 0x0000 plug stops to listen IKEA remote. It works but not like it should. If I disconnect MIO PLUG from power socket and conect it to power socket again MIO.PLUG automaticaly adds itself to group 0x000. And situation is the same. My MIO.PLUG switches anytime I press IKEA remote. I can switch off my HA and raspberry and MIO.PLUG will listen to IKEA remote . They are automaticaly binded directly when MIO.plug is connected to power.
How to avoid this automatic add xiomi plug to group 0x0000 procedure?
My plan was to move my ZIGBEE MIO PLUG to ZHA and conbee II. I can not do it and still have to use xiaomi gateway only for MIO.plug because it binds automaticaly to IKEA remote in ZHA config.
How to avoid this automatic add xiomi plug to group 0x0000 procedure?

A few of my Aqara plugs does the same, except they DO NOT appear in any of the ZHA groups. Did anyone find a solution to these “direct connect” issues?

1 Like

Same here, I deleted all groups, including the ‘Default LightLink Group’, as well as any/all bindings in the individual devices, but still my Ikea/Tradfri SHORTCUT Button is turning on/off the Aquara/Xaiomi H2 dual light switch, to which it happens to be paired.

If I re-pair it to something else (like a Tradfri Repeater in the same room), then this ‘binding’ behaviour stops, but because the Aquara is probably the nearest router-device, the Tradfri Shortcut button will eventually change to using the Aqara, and the bound behaviour returns.

I’ve googled till my fingers bled, but can’t find anything on how to stop this ‘auto-minding’ behaviour…