SOLVED: Home Assistant + ZHA + Sonoff/Tasmota Zigbee Hub (Wi-Fi)

I am having problem connecting to ZHA to Tasmota Zigbee bridge

I should have the settings for the Tasmota-flashed ZB-GW03 hub (from Sonoff) in place, at least as far as I can find instructions online.

I managed to manually set it (in console page) to listen on port 8888 (tcpstart 8888) and set the transmission speed (TCPBaudRate 115200). When I press the submit-button in the first image (ZHA), then in the second image, the Tasmota hub’s web interface terminal displays “Got connection from (HA IP)…,” but no more data is exchanged. .152 is the address of my HA server.

I tried pinging back and forth between consoles (HA <–> Tasmota bridge), and the pinging goes fine, but something is amiss here.

Now, for example, where can I view logs from HA regarding ZHA so I can see what they’re communicating? If we start from there? :thinking:

Is there more detailed log in Tasmota that I can enable?

Please note that ZHA isn’t installing at all in HA because I can’t establish a connection to that device, so I can’t access its log files directly with my abilities.

I’ve tried several random firmware versions and two with links provided by Aliexpress seller that I bought the item from. None of these are working, and I’ve encountered the same issue in ALL of them.
So, I’m starting to suspect that the problem is on the HA side? It just does not receive connection back, or something? Port problem? :flushed:

Any help would be appreciated 🥲

Here are the pics:

Home Assistant (IP ZHA-integration setup page (it will try to connect like 10 seconds, and then this error comes up):


Tasmota Zigbee Bridge Console (IP

While the bridge has the IP number, you are trying to connect to the IP number Make a fixed IP reservation from your modem with the MAC address of the bridge and restart the modem and bridge. Afterwards, you can install it via the fixed IP address you have determined.

No, HA server has ip .152, bridge is .109 and bridge MAC is bound to that IP in my 5G-router.

Am I missing something here? :thinking:

Connect the bridge to your 2.4Ghz wifi network.

It is connected to 2.4Ghz network allready. Not 5Ghz

Does the bridge get the same address every time,

Yes. Same Address every time.

Can you ping via CMD?

From where? Ha-server? My desktop machine?

Does the Tasmota panel appear when you type the address

Desktop machine

If you can ping with the command prompt and enter the address into your browser, the tasmota address should appear.

ping from desktop machine has fast reply, and no errors

Also ping form HA-server terminal sends quick reply.

I successfully ran ZHA by following the video in the link. Later, I even ran Zigbee2Mqtt with this bridge.

Watch this video carefully and apply it. You may be skipping the commands that need to be sent via Tasmota console…

I have watched that video 4 times and tried that. But video is 2 years old, and my bridge is brand new (ZB-GW03 V1.4) and it does not apply anymore to this unit. Also Tasmotizer does not seem to support ESP32-chips, which these new versions have (not really sure about this support).

NCP Uart upload gives error. Impossible to add that.

I have now tested following firmwares I got from the units Aliexpress seller:
V12.4.0 (I just upgraded to this)

I have also tested other firmwares, but no help there. Every time same problem. I am missing some setup somewhere. Maybe there is no communication between Zigbee-board and ESP32?

I used the bridge for zigbee2mqtt. But devices were constantly disappearing. I was able to solve this problem with Sonoff USB zigbee dongle.