[SOLVED] King Smart (KingArt?) Switch Tuya panel V2021.10 - voltage indication when turned off

Hi guys. I bought this one, blindly, without checking specs firstly:

As you can see, it actually consist of 2x 3 gang switch:

Additional info: I prefer Sonoff, and all other wall switches in my home are Sonoff T3, but unfortunately Sonoff is not manufacturing bathroom switches, i.e. in this size, so I decided to give a try to “no name Aliexpress” Tuya switch. There is some “King Smart…” mark on PCB, so I believe this is the KingArt :joy: (stupid of course, this is not mandatory to be true):

I tried to flash Tasmota, but I figured out this is not ESPxx chip at all. Lucky me, I found Tasmota clone, OpenBK firmware, intended to be used with these new Tuya chip (Beken chip, if I remembered correct). Flashed and configured successfully, device is working, all relays, LEDs, etc. are acting as expected, but…

When I turn off certain relay, either by pressing a button or remote, I still have some low voltage on it’s output. Unfortunately, I have no multimeter at the moment to measure it (will buy one), but I can see it with test lamp. It is obviously some interference or so, and it is obviously lower than 220V, cause test lamp light is much brighter when relay is on, but it is anyway presented.

Relay OFF:

Relay ON:

Two questions:

  1. Was someone experienced this issue before? I mean, at this point I regret why I didn’t at least tried it on official Tuya firmware and checked things such a this, instead of that I flashed it with custom firmware straight out of the box. I don’t believe this could be firmware related, but would be sure if I tried.

  2. I am pretty sure I will avoid installment of this to bathroom, but just for curiousity: Is this low voltage (and I will measure it I promise, as soon as I buy multimeter) dangerous for devices? This was intended for boiler, light, washing machine, fan and my DIY bathroom music (dfplayer + SonoffSV + speaker, 5V power supply) and I’m wondering would it damage devices on long run? I mean, when switch/relay is turned on, there is no difference - device would be supplied with ~220V. But when switch is turned off, it would continue to sending some low voltage to appliances.

Thanks upfront for your opinions.

I am now confused and not sure what to think. As said before, when relays are turned off, test lamp is still showing some low light on their line outputs. I understood this as indication for some low voltage and most probably switch faulty. However, when I measure the voltage between any line output and neutral wire, multimeter showing 0V:

Measuring with relay turned on is showing 230V as expected:

Do anybody knows is this safe for installment?


It was big dilemma about nothing. At the end, it was induction, not real voltage. After I measured 0V, I done few tests:

  1. While relay is turned off and test lamp is showing low light, I shorten that line out with neutral - nothing happened, no sparks, no fuse blow, etc.
  2. While relay is turned off and test lamp is showing low light, I touched that line out several times and I’m still alive :joy:
  3. Out of this switch scope, I get one 3-line-cable about 1m length, and connected one wire only to line from wall power grid. Other two wires in cable not connected to anything on both sides. Test lamp is showing full brightness light when touching wire connected to line on the other end of cable, but it is also showing low light when touching other two wires which weren’t connected on any end of cable. This is quite normal for test lamp because of induction, I read that in mean time. And multimeter is showing 0V between these “floating” wires and neutral.

Switch is installed and it is working ok. There is some other issue, but this is for some another topic, cause it is related with MQTT - it not showing the state when HA is restarted.

Hi Stew47,
I have the same problem you faced: being familiar with sonoffs and tasmotizing, I would now like to get my kingart devices to be tasmotized or at least programmable and talking MQTT.
Can you point to any place where I can find the software you used to “tasmotize” your device?

Thanks in advance,

Hi. First of all, in the world of Chinese no name devices, I cannot be sure is your device have right chip for this software. I wont to be responsible if you brick device - responsibility is on you :joy: Please first determine if your device is coming with Beken chip. I had a hard time to read something like BK7231N on chip itself (used camera and zoom to take a picture), then googled for BK7231N and found it is Beken chip, then found OpenBK firmware. It is also important to determine is it BK7231T or BK7231N (mine was N). Depending on this, you will use respective firmware from here.

OpenBK is Tasmota clone firmware for Beken chip devices. If your chip is ESP82xx, then you need to use Tasmota or ESPHome, OpenBK will not work on ESP82xx chip. Oposite, if your chip is Beken, you cannot flash Tasmota or ESPHome, we are continue with OpenBK.

Download latest firmware for T or N version, depending is it your chip T or N.
Flashing procedure is similar as for Tasmota/ESPHome, you need to connect:

  • VCC on board with VCC on USB flasher
  • GND on board with GND on USB flasher
  • TX on board with RX on USB flasher
  • RX on board with TX on USB flasher

Difference here is that you are not putting device in flash mode before flashing, but somewhere in the middle of flashing. Sorry, I am not a Windows guy and cannot help you with flashing from Windows, especially cause I also tried from Windows unsuccessful, then went back to good old Linux. These would be all needed commands for Debian/Ubuntu:

sudo su
cd ~/
git clone https://github.com/OpenBekenIOT/hid_download_py.git
cd hid_download_py
wget https://github.com/openshwprojects/OpenBK7231T_App/releases/download/1.12.0/OpenBK7231N_QIO_1.12.0.bin
apt install python3 python3-hid python3-serial python3-tqdm
python3 setup.py install --user
ls -al /dev/ttyUSB*
python3 uartprogram /root/hid_download_py/OpenBK7231N_QIO_1.12.0.bin --unprotect -d /dev/ttyUSB0 -w --startaddr 0x0

I believe this would be correct on Archlinux:

sudo su
cd ~/
git clone https://github.com/OpenBekenIOT/hid_download_py.git
cd hid_download_py
wget https://github.com/openshwprojects/OpenBK7231T_App/releases/download/1.12.0/OpenBK7231N_QIO_1.12.0.bin
pacman -S python python-hid python-serial python-tqdm
python setup.py install --user
ls -al /dev/ttyUSB*
python uartprogram /root/hid_download_py/OpenBK7231N_QIO_1.12.0.bin --unprotect -d /dev/ttyUSB0 -w --startaddr 0x0

As I already described here (there you can find also how to put device in flash mode).


  • Above commands were executed at July this year, there is newer version of OpenBK firmware now, so modify github links with newer versions
  • Please read CAREFULLY tutorials here and here, there is slight different (for -startaddr if I remember correct), depending on is it your chip T or N (mine was N).

Happy flashing :joy:

Hi, i have the same device as you.I’m already flashing the device and configurated it. Then i changed the names in config.yaml. In the mosguitto broker in HA the device showing up as entities but are unavailable?
Any suggestions?

Hehe, stuffs like this are usually “set and forget” for my brain, but luckily, I think I know where the problem is, cause recently one of these two switches was factory reset on it’s own and I had to set it again. If I remember correct, it will not create all needed MQTT topics and sub-topics immediately when you set it up and connect to broker (sorry if I’m not using right terminology, I am not some MQTT ninja). Example:

Above is one of these switches, named Tuya Right, showed in MQTT explorer. You can see how it has some sub-items. When I first time connected it to broker, it had showed connected = online only, and it’s entities were also showed in HA, but they were unavailable, if I remember correct. Then, I was turned on/off each switch channel few times form the switch local web UI ( in this case), and (again if I remember correct :innocent:), sub-items were appeared in MQTT Explorer, and entities becomes available in HA. So I think that you need to go directly to OpenBK web UI page and toggle each channel few times.

Hi, i find out the problem. My writing in the config.yaml was wrong.
Any way thank you for reply and help.

1 Like