SOLVED - Lovelace Custom Cards randomly stopped working

Hi everyone, I’ve been looking for a while to try and find a fix for this but to no avail. I’ve got some custom cards downloaded via HACS and up to this point it’s worked perfectly fine and for some I’m also even able to see them as selectable cards in the UI. However, randomly today while adding an integration for octopi, they just stopped working. No update, no changes to the yaml, nothing. One moment the cards were showing everywhere fine, then the next the cards are replaced with the error “Custom element doesn’t exist: …” for every mushroom card. I checked the resources under configuration.yaml, no changes. the .js file is still there as well, and there are no noticeable errors in the HA log. I’ve reinstalled HACS and all the integrations and frontend, I’ve even rolled back the most recent update for HA (2022.9.7) to no avail. Anyone found a fix for this?

This happened to me yesterday. For some reason HA stop responding, restarted it and all of my custom cards stopped working with the same error message. Did you found a solution?

So I did find a solution! (Finally). Basically, I went back and checked HACS to redownload the front end card and I noticed the resource code lines that go in configuration.yaml were a bit different. I copied, reposted in the correct spot, and restarted and refreshed my browser cache and that fixed it.