[SOLVED]Myq cover stoped working (fixed in update 0.92.2)

Chamberlain probably did it just to be jerks.

1 Like

Same here. Worked fine yesterday morning. Went to work and when I came home the garage door did not open. Command fails when calling manually. Same exact log entry as above. I did notice when I opened the MyQ app, the old one is no longer supported and they pointed me to a new one. Not sure if that makes a difference. I can still use the garage door via the app just fine. Hopefully, they get this fixed soon.

My MyQ component was at least showing up until I upgraded from 91.3 to 92.1. Not sure if it was actually working at that point, as I’m more using it so that google assistant can tie into opening/closing the garage without paying the subscription.

I do have a snapshot I could roll back to if anyone thinks that would be useful.

It won’t fix the problem on Chamberlain/Liftmaster’s side. The API changed on their servers, and thus the component will now need to be updated. Rolling back your version of HA doesn’t do anything to fix that.

It’s an API change and has been noted and fixed by the pymyq people and someone has done a PR for HA. Hopefully it makes it in the next release.




And this is exactly why I decided to move away from the MyQ system in my set up. This kind of stuff can (will…?) happen every time you rely on a cloud service.

I was having quite a bit of issues with the MyQ intermittently, but routinely, becoming unavailable (as some of you seemingly have experienced too). I eventually decided to implement a completely local way to operate my garage door via HA that has been 100% reliable for the last year so far. And If for some reason my local stuff doesn’t work then I still have the ability to operate the door via the MyQ app on my phone - assuming they both don’t go down at the same time. :roll_eyes:

If anyone is interested I can post up the information.

I am interested, but feel a bit committed to my current platform, since it is bought and paid for. But I do like hearing what others have done, so feel free to share.

that’s really the best part…you don’t have top give up your current system at all. you are just adding to it. And depending on what you have laying around it might not cost you a dime.

My DIY option was inspired by another user (that I can’t find the thread for).

All you need is a spare remote for your garage door and a Sonoff. The Sonoff can be a Basic and that will be very easily (and safely) modified or you can use any type of dry contact relay.

First pair the remote to your GDO.

Then just disassemble the spare remote and figure out which traces go to the pushbutton switch contacts and solder a couple of thin wires to them. make sure you leave plenty of length. then you will connect those wires to the contacts of the relay so that when the relay turns on the remote thinks that someone just pushed the button. Voila! the door operates.

If you don’t have a dry contact relay device as I said you can modify a Sonoff Basic by cutting the traces/wire from the hot input terminal going to the relay and re-solder that trace/wire to output terminal neutral so that when the relay turns on it shorts the output terminals together simulating the button press but it won’t be able to pass any hot voltage to the output terminals.

the Sonoff is powered by main voltage and the remote is still powered by its battery like usual. And you can put the thing anywhere as long as the remote signal can reach your GDO.

I have tested the fix (by ehendrix23) in my setup (by updating the files in /srv/homeassistant/lib/python3.5/site-packages/pymyq). It works. It will hopefully be part of the upcoming update.

1 Like

This is great news… Thanks!

Excellent. Thank you.

To fix on your own for right now until the fix is added in an update you can download the Home Assistant GitHub repo extract the myq component folder put it in a custom component folder and edit the manifest.json file change “1.2.0” to “1.2.1”

1 Like

and still put myq in the configuration.yaml?

I didn’t change my yaml file at all, kept it as is for the official myq component

I can confirm the custom component route works. Thanks @Nikiya_Osborn

1 Like

Are you using the docker version of HA, or another?

sadly the custom component did not work for me… I can confirm it is using the custom component and the manifest has been updated; but I am missing something else :frowning:

Did you copy everything over including the folder? Are you currently running any other custom components?

I did… and I am not… I think the problem still lies within my core python files… I am trying to see if I can get the latest image from docker…

For me the custom component doest work too. Should i update something more? Is it important what version on HA i have?