[SOLVED][Supervisor] Slow loading when outside network

Hi there!

I’m having issues currently that I didn’t have before with Supervisor or with addons. Whenever I go on my server from an external network on the Supervisor page or on a addon ingress page that I pinned on the side, it takes a lot of itme to load.

When I do the same but from the internal network, no issues. I don’t see any logs with issues.

Here is my setup:

  • RPI4 4GB RAM (using good power adapter)
  • 128Gb SANDISK usb hard drive (boot on usb)
  • Ubuntu 20.04 server LTS
  • Using docker image (followed Installing Home Assistant Supervised on Raspberry Pi OS)
  • Using duckdns + nginx
  • Conbee 2 attached
  • Addons: ADB, duckdns, file editor, grafana (disabled), home assistant google drive backup, influxdb (disabled), mariadb, mosquitto broker, nginx, zibee2mqtt edge

For info, the memory usage is about 26%, 13.6% of hard drive used, 35°C. In terms of internet connectivity, using Google DNS in my router, using IPV4 (I can"t seem to use V6 since I’m using a router behind the internet supplier router and passtrough just doesn’t work).
My download is 18.32Mb/s, upload 0.804Mb/s (using nPerf). When using my internet supplier status I’m at 20.7 and 1.1.

I tried to flash everything back from scratch but to no avail. I tried reinstalling every addon but doesn’t do anything either.

I really don’t know what to do, I hope I don’t need to use a NUC instead since the only issue is when I’m outside of the home network… Furthermore it’s only the supervisor, lovelace works fine, I can’t easily move between the menus et go into the HA config.

Using app on android or through chrome is the same (same on Windows using my phone connection).

Thanks for your help!

1 Like

After checking, it seems like it is caused by /api/hassio/app/frontend_latest/entrypoint.6bc241a4.js that takes a lot of time to load. I made a performance test and it seems like it.

The guide is for Raspberry Pi OS, not Ubuntu on a Pi.

1 Like


Thanks for the help, I switched and used the official install method on Debian 10 on the RPI4 and I have exactly the same issue with a 100% clean install of Debian + HA etc… I only have duckdns and nginx currently.

Sounds like a network configuration issue with Nginx. If it works locally and not remotely, something is not setup correctly.

It works remotely, it’s just super slow, only supervisor and apps, not HA itself. My guess is that the network between the docker images is super slow, maybe because of firewalls?

For NGINX, I didn’t change anything except the hostname:

domain: blablabla.duckdns.org
certfile: fullchain.pem
keyfile: privkey.pem
hsts: max-age=31536000; includeSubDomains
cloudflare: false
  active: false
  default: nginx_proxy_default*.conf
  servers: nginx_proxy/*.conf

I just tested behind my first router and same delay.

Just tested using HASSIO OS and same issue with a 100% clean install. Really strange… Going back to Debian. I’m almost sure that it’s caused by the entrypoint.js that takes too much time.

Having exactly the same issue. Drives me crazy on a regular base, trying different settings etc.

Glad to hear I am not alone. Just wondering, shouldn’t there be many more complaints from all type of users?

Hass OS user here btw.

Yeah I’m a bit suprised that no one has these issues, or maybe no one is accessing supervisor stuff from the outside network or maybe using a VPN?

Imo, there’s a firewall somewhere adding latency here.

Have you opened an issue?

Before opening an issue I wanted to see if other people from the community had this issue. Gonna open one as sonn as I have the time.

Same here. Supervisor or addons slow as …

I’ve just recently gone from using Home Assistant OS on a Ras Pi 3B+ to a Supervised install of Home Assistant on a Rasp Pi 4 (4gb) on SSD boot… I’ve still got both of the instance running as a matter of fact.

I too have noticed that my new instance of HA (Supervisor on Pi 4) does not like to load the supervisor tab nor does it like add-ons …

Interestingly, and I’ve just confirmed this, hence the edit. My ‘old’ instance of HassOS on Rasp Pi 3B+ loads supervisor and add-ons just fine. Seems too coincidental to not be important.

Also just wanted to add that I am using duckdns and my router to port forward both instances … my ‘old’ instance from external 8123 to internal 8123, my ‘new’ instance (the one with the issue) from external 443 to internal 8123 … though I am accessing both instances from within my home network on 8123.

Is it possible that is an issue?

Same here with slowness only for supervisor and add on… The interface otherwise loads fine… I am seeing when accessing through a site to site VPN / different subnet

I came here, because I had a similar issue: when clicking an addon in the sidebar, or clicking the Supervisor item, it always needed a couple of seconds (or longer) to load.
I recently changed my DNS-servers to these of Google (, and some time later to I changed this back to the DNS-servers of my internet provider, and guess what: speed is ok now! I don’t know if this will work for you, but I just put it here as something you can try.


Thanks for the tip, just tested on my side and same issue when I add my ISP provider DNS.

What is your internal/external base_url set to?

My external is https://xxxx.duckdns.org and my internal is set to http://RPI4IP:8123

Try setting them both to duckdns if your router supports NAT loopback.