Solved : Where is config/www

I made a second start with HA because I like lovelace very much.
I manage to solve a lot of problems I meet, especially with the indent’s, but now I am stuck.

I want to use the button-card, and the instructions say I have to create/copy button-card.js to config/www
Looking for a solution in this community people say they create the folder www themselves in config.
But I don’t have a config folder neither :frowning:
I created a folder ‘www’ in the same folder where my *.yaml files are, but then I get an error saying : Custom element does not exists : button-card

So can anyone tell me where to create this folder : starting from /pi or /homeassist

I use Winscp and hide or unhide files do not help

Edit : found that www has to be created in /home/homeassistant/.homeassist


I have running HA in a Docker on a Synology DS. I have mapped the Config Folder so I have the config-folder that contains four subfolders (.cloud .storgae deps and tts) an of course a few files (groups.yaml configuration.yaml ,…) where should I place the www folder?

in the same folder as YAML files and then restart home assistant or you can’t use it.

1 Like

Thanks for your very fast feedback!

I am having trouble adding custom images. I am running Debian 10.
I have a /home/hassio folder but there is no .homeassistant folder there; not much of anything.
My YAML files are in /usr/share/hassio/homeassistant

I’ve tried creating & populating:
but to no avail…

Sorry, I am a NOOB (day 10 with HA). I found another post which made it clearer for me:

My configuration.yaml is in /usr/share/hassio/homeassistant so that is my ‘config’ folder.
I created www/images/Cobra.jpeg there and now https://home_assistant_url:8123/local/images works and my custom badge image loads via my customization in customize.yaml
entity_picture: "/local/images/Cobra.jpeg"

1 Like

Could you maybe specify a little more how ur path looks?

from my understanding it’s supposed to be: /config/www/?

Probably too late to help you, but from within HA (and maybe on Pi installs?), the path is /config/www

When looking from outside the HA container on certain types of installs (like supervised [docker on Linux]), /config/www might be found at /usr/share/hassio/homeassistant/www
Other installs it may be a different location, including possibly somewhere under your home directory.

1 Like

what is the absolute path? IM having trouble installing a custom component…