[solved] Why automations are often broken after update of hass ? will that ever stop?

Hi, sooooo it’s been maybe maybe 8 months now, and I don’t know whenever this will ever get finally fixed or not.

So, I’ve got maybe 20 automations, which mostly rely on buttons being pressed, you know from simple toggle power going to printer to complex automations dependant on multiple conditions and buttons. Problem that I have is that after updating has operating system or hass general upgrade (like 2024.2.6) those automations seems to disconnect them self from button action.
I followed advise of reloading MQTT add-on, and sometimes it works, sometimes it doesn’t and full VM need to be rebooted. After the most recent update the reloading of MQTT makes buttons work, but just destroys view of entities and one can’t see whenever light is on or not. After reboot buttons actions get forgotten by automations :confused: To add insult to injury, the logbook shows properly the actions of buttons happening - but automations just don’t know about them (when trying to remove trigger from automation and adding it again) and while editing automation it just shows the device but trigger is empty and there is nothing in the dropdown.

I’m at the end of the rope with this stuff … automations were promised as best thing since slight cheese, while in fact those turned into an administrative chore and I’m seriously considering abandoning automations and just shifting those to node-red.

Sorry for being bitter.

I am not seeing what you are seeing.

I’d be bitter too if that happened with each update.

I just don’t see much break in my setup with each update. Really, I’d be surprised if moving to node-red fixed all of these issues. But, not using node-red, I am not sure.

I agree with Jeff. You definitely have something else going on that it not the fault of HA automations.

In order to help however we would need more info on what exactly is happening.

In the some 5 years I have been using home assistant, never happened to me.

But maybe read this:

Waaait … what ? I assumed that normal names won’t work and that’s why the GUI automation builder was using them :confused: I shall try this and report back - but if that is a solution maybe folks that programmed the GUI based builder need a word with.


agreed!!! Not sure this is even an issue…

Just FYI, this is a bsic automation for switching on and of test equipment in my office:

alias: Office test equipment button "press"
description: ""
  - platform: device
    domain: mqtt
    device_id: dd2f0241d5e29e7cc21cfdb97d286e5a
    type: action
    subtype: press
    discovery_id: 0x001788010896f823 action_press
condition: []
  - if:
      - condition: device
        type: is_off
        device_id: 836e96a06a52f8bf28c993e4c2107b56
        entity_id: 1e297dbb258bc53b9d00c4189e566fc7
        domain: switch
      - service: homeassistant.turn_on
        data: {}
          device_id: 836e96a06a52f8bf28c993e4c2107b56
      - service: homeassistant.turn_off
        data: {}
          device_id: 836e96a06a52f8bf28c993e4c2107b56
mode: single

I shall redo it in entity_id format as advised and see whenever that fixes the problem. from all the folk that replied here, are you guys using devices_id for buttons of entity id’s in your automations ?

Yes, the IDs are populated automatically and still no issue when updates occur for me.

Are you using a VM?

Until the device breaks down and needs to be replaced…and if an automation has multiple devices, and one device fails or is unavailable(even briefly), the whole automation fails :thinking:.

And, Yes it is possible to use a new device giving it the same ID, but it is a hassle…
Changing an entity’s name is very easy though :wink:

OK, so I’ve finished with automations and all are shifted from devices to entities for triggers - let’s see how it holds up after few months :confused:

But… running for 4 years, never had issues either :grin:

1 Like

OK, maybe somebody can explain to me, why hass seem to have an amnesia and forget the actions ? when I navigate to the device and try to add automation, the list of available triggers has no actions i it:

I may add that this button was in hass for maybe 2 years ? it’s not like it was never pressed or something. It always works, but after update hass has a problem with it since it’s a button and actions from it have a STD :confused:

Apparently the device only has controls no sensors or attributes…

Hard to say thought without seeing the device…

If you look at services, they don’t have much available either:

Weird starting point though, i always start with ‘create new automation’ from automation view…

It’s a philips hue button. it does have some actions like press, hold, release etc …

Here are exactly the same two buttons:

Note that printer button magically forgot the “hold” action :confused: EVEN thou the action does show up in the logbook. For some reason actions are disconnecting from the device.

I know it’s weird starting point hence I don’t use - BUT I’ve managed to find a commonality that if actions don’t show up in this menu → they don’t show up in automation “device” “trigger” dropdown → they stop working as a trigger.

i would look into my devices….

What integrations does hue use anyway ?
zha, zigbee2mqtt, hue bridge?

I might add that ALL zigbee devices are connected via Z2M - there are roughly 160. there are couple of networked devices like pfsense senor etc but those are dime a dozen

And if you looks at the device, does it have all controls, sensors, diagnostics??
Or only missing at the +automation screen ?

example of test equipment button:

Everything seems to be in order / same as other buttons.
Please note that side notebook DOES understand that there are actions being triggered for it, yet when I navigate to navigations, hass is unaware or any existence of actions.

Beats me man…don’t have a clue what the issue is :face_with_diagonal_mouth:

I’m running Zigbee2MQTT too, at first on a different machine, now ass add-on to HAOS.

And I use a ConbeeII coordinator…

always rocksteady with or without automation for the last 4 years…