(SOLVED) Xiaomi Gateway (V3) & devices became unavailable after updates

EDIT: So my issues seem to have been related to updating the Xiaomi Gateway v3 to the 1.5.0_0027 firmware. Downgrading to 1.5.0_0026 by following this guide fixed all my issues.
PLEASE NOTE: The credentials for the gateway have been changed to username: “admin” & password: “admin” with this update! No password or 123123 don’t work when you’re on 1.5.0_0027

Hey all, I have quite a lot of Xiaomi/Mija IoT devices that connect to a Xiaomi Gateway V3 which I integrate into Home Assistant by using AlexxIT’s terrific custom component.

Unfortunately some update, either updating to Home Assistant 2021.7.3 or accidentaly updating the Xiaomi Gateway 3 to 1.5.0_0027, broke my setup with all Xiaomi/Mija devices becoming unavailable.

In the Xiaomi Gateway 3 debugger I get the following logs, but I don’t quite know what to make of them as all the configs are as outlined in AlexxIT’s documentation and have been working previously:

2021-07-20 02:08:00  DEBUG    main          SysInfo: {'installation_type': 'Home Assistant OS', 'version': '2021.7.3', 'dev': False, 'hassio': True, 'virtualenv': False, 'python_version': '3.9.5', 'docker': True, 'arch': 'x86_64', 'os_name': 'Linux', 'os_version': '5.10.45', 'supervisor': '2021.06.8', 'host_os': 'Home Assistant OS 6.1', 'docker_version': '20.10.6', 'chassis': 'vm'}
2021-07-20 02:08:04  DEBUG    main          Loaded from MiCloud 17 devices
2021-07-20 02:08:04  DEBUG    gateway3      172.16.80.131 | Start main thread
2021-07-20 02:08:07  ERROR    gateway3      172.16.80.131 | Can't read devices: Telnet with password don't supported

Does anyone know how I could fix (or better debug if necessary) this problem?

Thanks a lot in advance!

1 Like

Hi,

I face same issue, then I thought I should remove and re-add the gateway integration.

  • Now I made first step adding the account.
  • step 2 adding the device fails, i get the error “Can’t connect to gateway”
    and I don’t really know why.
    • the IP ad key are fetched automatically and can’t be wrong,
    • so I guess it is something with the telnet open command.
    • I tried with the default one :
{"method":"set_ip_info","params":{"ssid":"\"\"","pswd":"123123 ; passwd -d admin ; echo enable > /sys/class/tty/tty/enable; telnetd"}}
  • And I tried replacing the 123123 in the telnet open command by admin
{"method":"set_ip_info","params":{"ssid":"\"\"","pswd":"admin ; passwd -d admin ; echo enable > /sys/class/tty/tty/enable; telnetd"}}

but this did not help.

I have not enabled telnet on the device earlier and therefore I cannot downgrade the firmware like you did.

Any Ideas on how to proceed?

Any help/ideas will be appreciated.

Thanks.

Never mind.

I power the gateway off then on again and it worked with the default telnet open command
with the password 123123 even though it runs firmware 1.5.0_0027

Sorry for the confusion :slight_smile:

Downgrading to 1.5.0_0026 by following this guide fixed all my issues.

Hello Schmetis, ive been having issues with one of my gateways, if the device is reset I have to add it again in HomeAssistant. Ive not had any problems with my other gateway and have noticed that one is running v.0026, but the problem one is running 0027 like yours was.

Im trying to downgrade, but failing at the first step in the guide linked (probably because i have no idea what im doing in Putty!!)…
i enter the correct IP address for the problem gateway, trying with both port 22 (the default when i load Putty), and port 23 (which is showing in the image in the guide)… 22 gives an error : “Network Error: Connection Refused”, and 23 doesnt seem to do anything.
I assume i should be entering the username and password somewhere, i can put a username in Connection- Data, but no joy with that. How did you get into it Schmetis?
Thanks :slight_smile:

i have same error on my home assistant with gateway v1 any idea?

Hi @marine88 ,

I got it to work just after powering the gateway off then on again.

mine doesn´t the light and the sensor stay unavaiable but the rest work just fine!

Hi @marine88
What do you mean by “the rest”
I only have thermometers, I don’t know whether the case is different for Sensors and light.
What communication protocol do these run? Zigbee, Wifi, BLE?
Are these available as child devices in the ME Home app under the gateway settings?

The show automatically in HA but are unavailable?
Have you tried to remove the “Xiaomi Gateway 3” integration and add it again?