Something went wrong. if it is a compressed image please check that the archive is not corrupted

I was trying to flash HAOS on a new hardware using Balena Etcher in an Ubuntu 22.04.2LTS temporary environment. Aim is to flash a bootable M.2 drive for this purpose. I am a novice for HA and was watching lots of videos and reading articles about the specific process to install HAOS on a x84 64bit hardware. I have a new issue now that Balena Etcher running on ubuntu is not flashing with following information:- " something went wrong. if it is a compressed image please check that the archive is not corrupted" Could anyone help me to to get through this obstacle.


I came across this yesterday. What worked for me was downloading the image first, and then flashing the downloaded image from my hard drive, instead of filling the URL into etcher.

1 Like

I have the same problem, tried by link and download. Gives the same issue. Do anyone have a good idea what the issue is or how to solve it?

1 Like

I have the same issue today, tried downloading the image instead of using the link but no luck :frowning:

1 Like

Thank you. Could you let me know the link and the method to download HAOS to hard drive. Appreciate that a lot.

I was setting up an Intel NUC to run it directly (aka. “bare metal installation”, not in a VM) and downloaded the Generic x86-64 image from this page:

The URL is shown under step 4 of “Write the image to your boot medium”, which I just downloaded with my browser to my desktop. Then, I used the “Flash from file” function of Etcher, instead of the “Flash from URL”.

Great, thanks for the valuable info. I will try it now and hope to have a positive results. cheers.

Did it work for you?

1 Like

Yes, finally it worked. as above suggestions I downloaded the HAOS image to my desktop and provided the path to this file for balena etcher. Thank you all.

This is what worked for me. The compressed vs uncompressed size was very surprising but 🤷

Found the solution to Balena Etcher issues, the version was the issue,
Wrote a complete guide here

Yes, downloading the file solved this problem with me.