Sonoff D1 Random Power On

Hi,

Connected bedside lights to a Sonoff D1 dimmer using Sonoff LAN integration from HACS, standard firmware.

All seemed to work OK, but the lights randomly power on every few hours - which is not good in the middle of the night. I’m totally sure this is not triggered by an automation and is something weird going on with the D1. Wondered whether its a random RF433Mhz signal its somehow picking up even though I don’t have the RM433 remote.

2021-10-03 11:15:33  DEBUG    sonoff_local  1001107442 <= Local3 | {'switch': 'on', 'brightness': 1, 'brightMin': 160, 'brightMax': 255, 'startup': 'off', 'mode': 0, 'rssi': -68} | 25
2021-10-03 11:15:33  DEBUG    sonoff_cloud  1001107442 <= Cloud3 | {'action': 'update', 'deviceid': '1001107442', 'apikey': '...', 'userAgent': 'device', 'params': {'switch': 'on', 'brightness': 1, 'rsn': 'rm'}, 'from': 'device'}
2021-10-03 12:39:01  DEBUG    sonoff_local  1001107442 <= Local3 | {'switch': 'on', 'brightness': 0, 'brightMin': 160, 'brightMax': 255, 'startup': 'off', 'mode': 0, 'rssi': -68} | 27
2021-10-03 12:39:01  DEBUG    sonoff_cloud  1001107442 <= Cloud3 | {'action': 'update', 'deviceid': '1001107442', 'apikey': '...', 'userAgent': 'device', 'params': {'switch': 'on', 'brightness': 0, 'rsn': 'rm'}, 'from': 'device'}

Not sure how to interpret the log? How do I debug this further???

Device attributes are:

supported_color_modes: brightness
color_mode: brightness
brightness: 1
manufacturer: SONOFF
model: D1
sw_version: PSF-BLD-GL v3.5.0
cloud: online
rssi: -68
local: online
friendly_name: Bedroom Lamp 3
icon: mdi:lamp
supported_features: 1
assumed_state: false

Thanks :slight_smile:

Probably that.

RF clearing

Long press the “pairing button” on SONOFF until the on/off LED indicator flashes twice, then long press any button on the RM433 until the on/off LED indicator flashes once after clearing is successful. (Other buttons can be cleared through this method.)

Seems to be a ‘thing’ with the D1. I’ve found an old 433 remote and seemed to successfully pair with that, so I’ll see how it goes.

There is also a lot of posts saying it doesn’t work.

I tried to flash mine with ESP-Home without RF capabilities but that didn’t work.
So apparently it’s not software-RF.
There are other suggestions that a low pass filter is needed, not sure how that would be connected on the D1 since it’s different from the other Sonoffs.

I will try the “remove the resistors” way when I get time for it.
That should separate the RF chip from the ESP

Yeah, pairing with an old remote definitely hasn’t worked since the lights still come on on their own :frowning:

Going to have to get the resistors out I think.

TBH, for something brand new, I really should send it back - its a load of junk - and it doesn’t succesfully dim anyway, just make my dimmable led lamps flicker.

Yeah, it’s known bug in D1, and although, as said, commonly known, sonoff still didn’t solve this problem in newest dimmers.It’s known that random turn-on happens even if all remotes are cleared. I guess they rely on the fact that classic bulbs are pretty much history.
Your best option is to phisically eliminate RF receiver (unsolder one pin), you can find all needed HERE. There’s also conversion to ESPHome described there. For elemination of RF only (without going to ESPHome FW) just unsolder and pull-up that pin (or cut appropriate PCB trace) and don’t solder a wire to ESP and RF part will be history.
You can also try with “custom” RF part (driven with ESPHome, not original sonoff, described on above page). But, be aware that current version of ESPHome (2021.9) has problems with D1: lamp never goes off. If you’ll do the testing it do it with 2021.8.x version, which works fine.

That does look a bit easier than dealing with all the resistors. Just so I understand this right, we’re saying to unsolder the top right corner pin on the 590R RF???

Exactly. Or, maybe even easier: do you see a horizontal track, which goes from under right chip to the left under left chip? Right below SMD capacitors? Cut this trace and you’re done. That’s the data line from RF receiver to controller chip. Whatever you prefer.

Well, I’ve attacked it with a soldering iron and some small tweezers.

Still seems to work OK with HA, i’ll see if we get any ghost switch on’s tonight.

Thanks for the advice @Protoncek

:slight_smile:

1 Like

Great news, happy to report that it seems to have fixed it. No ghost turn on for over a day, whereas it was doing every couple of hours.

Brilliant, thanks.:slightly_smiling_face:

1 Like

So?
You desoldered the pin from the PCB and soldered on a wire instead to pin 4?

I unsoldered (well, more like accidentally snapped off) the pin on the chip, but I didn’t bother with the wire as I don’t need to use 433mhz.

Works fine.

@Hellis81 No need to solder it to pin 4 if you have no intention to change FW from original to ESPHome. That connection is meant for more stable RF working, and especially that with this mod you can use other buttons for other stuff (like turn on/off) another relay/light).

But, here at my place 433MHz is pretty noisy and sonoff’s remotes work unreliable, and also some buttons seem to repeat itself. They work perfect when using original FW, but… an example: i learned first of 8-button remote to sonoff’s T1 (one gang) wall switch with ESPHome FW, but running on original RF part (not soldered). Lights toggle with learned first button (left on first row), but also with 4th buton (right one on second row). Same happens if i use modded - soldered ESPHome - codes are same when pressing different buttons. I have two 8-button remotes and with modded-soldered FW one or two buttons are the same even on different remotes. Very odd… I think that used RF chip is sadly chosen very badly.

Now i’m waiting to get sonoff’s RF bridge. Hopefully it will act somewhat better

@Kitkat : great! i’m glad to help.

I have already flashed mine with ESP-Home. I thought the issue was firmware first.
The remote is a bonus, if it can be used and doesn’t cause ghost turn on then I will use it.