Sonoff NSPanel Blueprint - Configure your own custom NSPanel easy via a Blueprint

Thanks and have fun :heart_eyes:

Very good work on this, it has been running flawless for about a week now. Thank you.
Even the wife uses it.

Hi blackymas, nice work.
Unfortunately I’m stuck at step 5 " 5. After the NSPanel is flashed, you can go to "Settings → Devices & Services → Add Integration" to add your new device and finish setting it up."

when I try to add the panel in esphome it asks for the encryption key,

Here are the logs from esp home,

INFO Reading configuration /config/esphome/nspanel.yaml…
INFO Updating[email protected]
WARNING GPIO4 is a Strapping PIN and should be avoided.
Attaching external pullup/down resistors to strapping pins can cause unexpected failures.
See Frequently Asked Questions — ESPHome
INFO Starting log output from nspanel.local using esphome API
INFO nspanel.local: Error while reading incoming messages: Connection requires encryption
WARNING Can’t connect to ESPHome API for nspanel.local: Connection requires encryption
INFO Trying to reconnect to nspanel.local in the background
INFO nspanel.local: Error while reading incoming messages: Connection requires encryption
INFO nspanel.local: Error while reading incoming messages: Connection requires encryption
INFO nspanel.local: Error while reading incoming messages: Connection requires encryption

Any help would be appreciated. Thanks.

saw it only now because tickets are better kept in Github.

Do you use the advanced esphome code?

Thanks for the reply @Blackymas,

My initial tries were with the Short version of the setup of Esphome and Blueprint. I then tried the advanced esphome code but could not get the yaml file to validate in esphome, it will probably require some changes.

I had the panel previously flashed with an earlier version esphome code and I’ve done some digging online and I think that’s where the problem might be as others have had the same problem, not specifically with your code, but with any device that has been previously flashed with esphome.

I have found a post suggesting the use of ESPHome Web “prepare the device for adoption” option which has some success. I’ll give that a try and let you know.
Thanks for your help.

1 Like

if it works i would appreciate a description so that others who have the problem can also solve it

I have a problem for esphome flash.
I saved my original firmware but after configuring my file with my SSID and password :

When I flash I get the following error message:

To connect my Nspanel to the USB module, I kept the same connection as for the backup of the original firmware…

Why doesn’t it work?

1 Like

I succeeded because I had a double URL line in the nspaneljour.yaml config, I put it like this

     ref: hand

However, the physical buttons do not work. They seem to be closed…
If I press it nothing happens. The little colored lines above stay on…

Are they configurable? Ex: I could with ewelik create a scenario to close or open my shutters.

1 Like

yes you have to configure the keys via blueprint

Having yet onfigured the buttons but still not working:

In doubt, I reflashed the modified firmware via esptool and there disaster… I have this error message : system data error… :cold_face:

I hope my Nspanel is not out!!

I can help with Portuguese (BR).

1 Like

no flash again


Thank you for your answer and your work!
I answered and made a small tutorial to fix the problem for “Systeme data error” on this forum but in French :wink:

1 Like

There is another easier way.

Compile esphome as legacy file
Copy the latest nspanel.tft version to your homeassistant config/www folder
Flash tasmota (tasmota32-nspanel.bin), go to Console, type:
FlashNextion http://homeassistant.local:8123/local/nspanel.tft

Flash esphome again using the compiled file


@Blackymas first of all, thank you for the great job, and happy new year to all.

Could you explain the correct procedure to update all after a new release?

I have updated the blueprint, reloaded and now I can see the new options (like the language change), but the thermostat press in the main screen was not working, neither the left and right buttons labels. So I pressed the “updatet tft display” button, and after 24 hours (yes, 24 hours) now I have the same screen that @kalagan55 with the data error

1 Like

Have you tried the display’s reset button entity?

Hello - actually quite simple.

Blueprint - copy the complete code from the Github file nspanel_blueprint.yaml.
Then open an editor in HA and paste the code into your blueprint. After that you have to reload the HA service automations - done.

TFT File - go to your ESPhome NSpanel via Devices and search for TFT Upload - done.

ESPHome - copy the whole code from the github file nspanel_esphome.yaml. Paste it in your ESPhome file and after that you can update via OTA via WLAN to your NSPanel.

@all @kardiologia @kalagan55

Maybe it is better to have these discussions on Github.

I have a small forum on Github where you can discuss problems better.

Also, you could write your solutions there, then everything would be in one place.

1 Like

How do I know if I have the newest version of the blueprint?

Is it normal that the upgrade of the tft file take hours?