Sonoff NSPanel Blueprint - Configure your own custom NSPanel easy via a Blueprint

Have to gather all the errors I get with this new release, but there are many. Now the panel is no longer functioning. Reporting unknown services: esphome.nspanel_set_component_color, esphome.nspanel_send_command_text_printf and esphome.nspanel_page_home.
And the other problem that occurs is Nextion reported variable name invalid, this is a recurring error every 10 minutes.

Where to look for a solution?

You probably have a version mismatch.
Could you please take a look at the different versions shown on the boot screen?
I woukd suggest you update all the parts (ESPHome, Blueprint and TFT) to the same version.

Reboot does not say a lot, only top line version 4.2.6 then a line with esphome and it says retry #1. then no version.

Doing a full new re-install now, hope it will solve this problem.

Allas no even more problems, now I get after the TFT update, System data error! on the screen.

It would be nice if there is also an option for the Blank.TFT in update TFT in settings devices. As always the buffer or memory of the panel often is too full to except the next update, so there is the need to first do the Balnk page update then do the final european TFT update.
After the blank TFT route and then the European TFT second update all things seemed to work again.

Problem solved, but it is apain in the arse, guess it drives you up the wall too sometimes Edward.

1 Like

I have 2 Nspanels and I am very happy with the work provided by Blackymas.
I also have a 10" tablet in my office to display my dashboard. Not always responsive… :wink:
I’m looking for how to dedicate a screen for HA (I can’t find much…) and on Aliexpress, I came across this product (different sizes) :

I don’t think it’s bad but do you think it would be possible to flash this type of product? I’m not a developer so I don’t know much about this…

I can’t update to this as there is an error. I have posted my error and you asked for my Yaml code but no reply

Supplied as you asked for but never heard back. Please help as I cannot update my NS panel

Do you mind reporting this as a bug in GitHub? That interface makes way easier to manage tickets and avoid missing things like you mentioned.

This is the link: Sign in to GitHub · GitHub

Not sure what your goal is. It’s a little off topic. This is an android device. You can not flash this with esphome.
I think you should be able to load a webpage and create a HA dashboard.

1 Like

Hi guys,

Problem SOLVED! :slight_smile:

Today I tried to start my first NSPanel project.
But I have different problems/ errors.

The first one, if I try to configure my first blueprint automation, blueprint is not able to see my nspanel name, the field is empty.
Blueprint version = v4.3.8

And I guess my second problem is maybe related to the first one.
Not able to flash my nspanel, I get following error:

INFO ESPHome 2024.5.5
INFO Reading configuration /config/esphome/test.yaml...
INFO Detected timezone 'Europe/Brussels'
INFO Generating C++ source...
INFO Compiling app...
Processing test (board: esp32dev; framework: espidf; platform: platformio/[email protected])
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
 - framework-espidf @ 3.40407.240606 (4.4.7) 
 - tool-cmake @ 3.16.9 
 - tool-ninja @ 1.10.2 
 - toolchain-esp32ulp @ 2.35.0-20220830 
 - toolchain-xtensa-esp32 @ 8.4.0+2021r2-patch5
Reading CMake configuration...
-- The C compiler identification is GNU 8.4.0
-- The CXX compiler identification is GNU 8.4.0
-- The ASM compiler identification is GNU
-- Found assembler: /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/xtensa-esp32-elf-gcc
-- Check for working C compiler: /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/xtensa-esp32-elf-gcc
-- Check for working C compiler: /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/xtensa-esp32-elf-gcc -- broken
-- Configuring incomplete, errors occurred!
See also "/data/build/test/.pioenvs/test/CMakeFiles/CMakeOutput.log".
See also "/data/build/test/.pioenvs/test/CMakeFiles/CMakeError.log".

fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
CMake Error at /data/cache/platformio/packages/tool-cmake/share/cmake-3.16/Modules/CMakeTestCCompiler.cmake:60 (message):
  The C compiler


  is not able to compile a simple test program.

  It fails with the following output:

    Change Dir: /data/build/test/.pioenvs/test/CMakeFiles/CMakeTmp
    Run Build Command(s):/data/cache/platformio/packages/tool-ninja/ninja cmTC_8fc56 && [1/2] Building C object CMakeFiles/cmTC_8fc56.dir/testCCompiler.c.obj
    [2/2] Linking C executable cmTC_8fc56
    FAILED: cmTC_8fc56 
    : && /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/xtensa-esp32-elf-gcc -mlongcalls -Wno-frame-address   CMakeFiles/cmTC_8fc56.dir/testCCompiler.c.obj  -o cmTC_8fc56   && :
    /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/../lib/gcc/xtensa-esp32-elf/8.4.0/../../../../xtensa-esp32-elf/bin/ld: /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/../libexec/gcc/xtensa-esp32-elf/8.4.0/ error loading plugin: /data/cache/platformio/packages/toolchain-xtensa-esp32/bin/../libexec/gcc/xtensa-esp32-elf/8.4.0/ cannot open shared object file: No such file or directory
    collect2: error: ld returned 1 exit status
    ninja: build stopped: subcommand failed.
  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  /data/cache/platformio/packages/framework-espidf/tools/cmake/project.cmake:381 (__project)
  CMakeLists.txt:3 (project)

========================== [FAILED] Took 7.32 seconds ==========================

And this is my nspanel yaml config:

  # Settings - Editable values
  device_name: "test"
  friendly_name: "test"
  wifi_ssid: !secret wifi_ssid
  wifi_password: !secret wifi_password
  nextion_update_url: "http://homeassistant.local:8123/local/www/nspanel_eu.tft"  # Optional
  # Add-on configuration (if needed)
  # heater_relay: "1"  # Possible values: "1" or "2"

# Customization area
##### My customization - Start #####
##### My customization - End #####

# Core and optional configurations
    ref: main
      - nspanel_esphome.yaml # Basic package
      # Optional advanced and add-on configurations
      # - esphome/nspanel_esphome_advanced.yaml
      # - esphome/nspanel_esphome_addon_ble_tracker.yaml
      # - esphome/nspanel_esphome_addon_bluetooth_proxy.yaml
      # - esphome/nspanel_esphome_addon_climate_cool.yaml
      - esphome/nspanel_esphome_addon_climate_heat.yaml
      # - esphome/nspanel_esphome_addon_climate_dual.yaml
      # - esphome/nspanel_esphome_addon_cover.yaml
    refresh: 300s

    type: esp-idf

Hello I added an icon of moon_phase to the main page with this template:

{{ ['mdi:moon-', states('sensor.moon_phase').replace('_', '-').replace('-moon', '')]|join }} 

It is working well, but the icon doesn’t refresh.
So I created an automation to reload the blueprint:

alias: NSpanel Reload by moonphase
description: ""
  - platform: state
      - sensor.moon_phase
condition: []
  - service: automation.trigger
    entity_id: automation.nspanel_configuration_m
mode: single

The automation trigger and is working, but the icon doesn’t change .
When I reload the blueprint manually, it also doesn’t change.

The only way to refresh (change) the icon is to use the “Save” button in the blueprint.
Is there a way to do this from an automation? (or any other way?)

Problem solved.

The error and compiling issues are gone after I have installed and used Esphome on my laptop. :slight_smile:

1 Like

Good day.

I still cannot update my panel as it’s saying there is a capital ‘N’ but there is none in my esp code. Please assist in helping me update

Do you mind reporting this as an issue in GitHub? This interface here is really bad for supporting in this kind of case.

Good day.

I do not see anything posted for not be able to update to the latest version.

When I try to update I get this error but my device does not have a capital ‘N’ in it

Perhaps do a “Clean build files”


This is why I’m asking you to create a new issue there.
On your screenshots I cannot see your full yaml neither your full logs. Navigating to your previous messages here, I see your yaml, but as it isn’t formatted, it’s hard to understand. And the interface here doesn’t allows to someone else format your yaml.
I’m trying to find the issue with the limitations here, as I always do, but I couldn’t find where it is failing, yet, and this is why I’m asking to report a new issue in GitHub and try making my life a bit easier on this troubleshooting.
If for some reason you don’t want to use GitHub instead, we can keep trying here… It’s just way less efficient. :weary:

1 Like

Many thanks. I have logged as per your suggestion.

FYI, even when I do clean build files I get the same issue

1 Like

I have tried this and get the same issue stating there is a capital ‘N’ when there is not