Sonoff ZBDongle-E with Openthread RCP

Hello everyone,

I am looking into using the Sonoff ZBDongle-E only for Thread/Matter.
I do not need Zigbee and want to avoid the Multi-PAN firmware in combination with
the Silicon Labs Multiprotocol Add-on.
I flashed the OpenThread RCP via the Silabs Firmware Flasher, and it is recognized when looking into the hardware tab of HA, but there is no Border Router even after restarting.

Would it be possible to use the Sonoff just as an OpenThreadBorderRouter and if so, how do I configure it or do I understand something wrong?
Maybe there are even better sticks to use for that?

Kr Patrick

Did you install the openthread border router add-on?

So you are using a fork of some software that HA is no longer supporting due to silabs not being able to patch problems.
Good luch with that.
https://www.reddit.com/r/homeassistant/comments/13wfbz2/enabling_thread_matter_support_on_the_sonoff/.

Home Assistant SkyConnect - Home Assistant,
Under the FAQ: That is why we do not recommend using this firmware, and it will remain an experimental feature of Home Assistant SkyConnect.

Yes, I have manually installed the add-on.
The question would be how to configure it though. It asks for a websocket connection but I just have a device and the device path is not what it needs.

@Sir_Goodenough
So you are suggesting to switch to an Texas instruments soc?

Not a Dongle-E, but a nRF52840, but should be the same


They don’t recommend the multiprotocol firmware any more , but tell people to use either the NCP firmware
(Zigbee) or RCP Firmware (Thread)

I think I was just being stupid…
I tried to add an Integration for OpenThreadBorderRouter instead of installing the add-on.
This tutorial worked after flashing the latest firmware from here.
Flashing: silabs-firmware-builder/firmware_builds/zbdonglee/ot-rcp-v2.3.1.0-zbdonglee-460800.gbl at b58bd0396a0289e4822a66b8c3de6b8843d78c2a · darkxst/silabs-firmware-builder · GitHub
Tutorial: Home Assistant SkyConnect

Using the firmware silabs-firmware/OpenThreadRCP at main · NabuCasa/silabs-firmware · GitHub broke the stick and I had to revert it via the universal flasher and wsl.

1 Like

Hi all,
Need your help.
I have just flashed the MultiPAN RCP to my ZBDongle-E to manage both ZigBee and Thread systems.

After installing all the required integrations the following repair requested appeared on my Home Assistant.

"OTBR and ZHA share the same radio but use different channels.
When OTBR and ZHA share the radio, they must use the same network channel.

If OTBR and ZHA try to connect to networks on different channels, neither Thread/Matter nor Zigbee will work.

OTBR is configured with a Thread network on channel 15, ZHA is configured with a Zigbee network on channel 25."

When I tryed to chnage the channel of Thread, the following message appeared:

The Thread radio has multiprotocol enabled. To change channels when the Thread radio has multiprotocol enabled, use the hardware settings menu.”

Where I can find the “hardware settings menu”?
Thanks

Solved