Sonoff ZbMini immediately disconnects


I’m starting home automation.

I’ve been trying to integrate a SONOFF 01MINI module in Ha for many days, but I still have the same problem, it connects and after 10s, it becomes unavailable. I tried with another SONOFF 01MINI module, the same …

someone can help me ?

I use a raspbery pi 4 with POPP dongle


Do you have a link for the sonoff 01mini ? I only know the sonoff mini, sonoff mini r2 and sonoff zbmini.
What integration are you trying to use ?

That is a sonoff ZBMini, the Zigbee version of the sonoff mini.

What integration are you using ?

sorry, i’m beginning, what do you call “integration” ?

It is not a conbee, so you use either Zigbee2MQTT or ZHA.

Anyway, how did you connect your popp dongle ? Did you use a usb extension cable ? It can simple be rf interference.

I use ZHA, dont know Zigbee2MQTT ?

I branch my dongle on USB2 and my USB key with HA on USB2
I have see there are possible intererence, so i try to branch my dongle on 1m cable, the same thing … :frowning:

Still can be WIFI interference

I think i dont have activate wifi on ma rasp
my wifi box ?

The channel on your wifi box may be the cause.

Auto ( Canal actuel: 6 )
I have this on my box

The default channel on ZHA is 15.

I have set 11 on my internet box, same result …

Maybe this can help :

It’s alway in pairing mode
but after 10s, its disconnect
after many research, i have found something
I activate log et when i try on/off, i have this :

[homeassistant.components.zha.core.channels.base] [0x3686:1:0x0006]: command failed: 'on' args: '()' kwargs '{}' exception: '[0x3686:1:0x0006]: Message send failure'
[homeassistant.components.zha.entity] light.sonoff_01minizbdeuuueuejfp_on_off: turned on: {'on_off': DeliveryError('[0x3686:1:0x0006]: Message send failure')}

nobody can help me ?

I don’t think many people use the Popp dongle here. Do you have other Zigbee devices that do work ?

You never answered my last question. If you bring your zbmini close to your popp donge, repair, and then try to switch, does the same happen?

Did you manage to fix the issue as I have exactly the same issue with a Silicon Labs dongle and ZHA integration. I notice the ZBminin is showing up in the Zigbee topology but is not connected to any other device in the network. Not sure how to fix this?